summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-01-29 22:10:39 +0000
committerJohannes Huber <johu@gentoo.org>2015-01-29 22:10:39 +0000
commit06d1a1de2319734184840598cf4de58abca9bb65 (patch)
tree72163d0c338ebf841bfc9a6b2f172f30165ee084
parentFix USE=mmxext description. Thanks to Doug Freed for figuring out what it act... (diff)
downloadgentoo-2-06d1a1de2319734184840598cf4de58abca9bb65.tar.gz
gentoo-2-06d1a1de2319734184840598cf4de58abca9bb65.tar.bz2
gentoo-2-06d1a1de2319734184840598cf4de58abca9bb65.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
-rw-r--r--media-libs/libechonest/ChangeLog9
-rw-r--r--media-libs/libechonest/libechonest-2.3.0.ebuild68
2 files changed, 75 insertions, 2 deletions
diff --git a/media-libs/libechonest/ChangeLog b/media-libs/libechonest/ChangeLog
index 587088867de4..a7e5b6c20a3c 100644
--- a/media-libs/libechonest/ChangeLog
+++ b/media-libs/libechonest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libechonest
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libechonest/ChangeLog,v 1.30 2014/04/08 16:19:15 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libechonest/ChangeLog,v 1.31 2015/01/29 22:10:39 johu Exp $
+
+*libechonest-2.3.0 (29 Jan 2015)
+
+ 29 Jan 2015; Johannes Huber <johu@gentoo.org> +libechonest-2.3.0.ebuild:
+ Version bump.
08 Apr 2014; Samuli Suominen <ssuominen@gentoo.org>
libechonest-2.2.0-r1.ebuild:
diff --git a/media-libs/libechonest/libechonest-2.3.0.ebuild b/media-libs/libechonest/libechonest-2.3.0.ebuild
new file mode 100644
index 000000000000..a57eb729050a
--- /dev/null
+++ b/media-libs/libechonest/libechonest-2.3.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libechonest/libechonest-2.3.0.ebuild,v 1.1 2015/01/29 22:10:39 johu Exp $
+
+EAPI=5
+inherit cmake-utils multibuild
+
+DESCRIPTION="A library for communicating with The Echo Nest"
+HOMEPAGE="http://projects.kde.org/projects/playground/libs/libechonest"
+SRC_URI="http://files.lfranchi.com/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/2.3"
+KEYWORDS="~amd64 ~x86"
+IUSE="+qt4 qt5"
+
+RESTRICT="test" # Networking required
+
+RDEPEND="
+ qt4? (
+ dev-libs/qjson[qt4(+)]
+ dev-qt/qtcore:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README TODO )
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt4) $(usev qt5) )
+}
+
+src_configure() {
+ myconfigure() {
+ local mycmakeargs=(
+ -DECHONEST_BUILD_TESTS=OFF
+ )
+
+ if [[ ${MULTIBUILD_VARIANT} = qt4 ]]; then
+ mycmakeargs+=(-DBUILD_WITH_QT4=ON)
+ fi
+
+ if [[ ${MULTIBUILD_VARIANT} = qt5 ]]; then
+ mycmakeargs+=(-DBUILD_WITH_QT4=OFF)
+ fi
+
+ cmake-utils_src_configure
+ }
+
+ multibuild_foreach_variant myconfigure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake-utils_src_compile
+}
+
+src_test() {
+ multibuild_foreach_variant cmake-utils_src_test
+}
+
+src_install() {
+ multibuild_foreach_variant cmake-utils_src_install
+}