summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-12 02:04:27 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-12 02:04:27 +0000
commit096bd3095e902b146b5577cbf5af37ef22062862 (patch)
tree924f9e90334465b6adaafb19e2191e5c2816e047
parentFix bad ampersand usage. (diff)
downloadgentoo-2-096bd3095e902b146b5577cbf5af37ef22062862.tar.gz
gentoo-2-096bd3095e902b146b5577cbf5af37ef22062862.tar.bz2
gentoo-2-096bd3095e902b146b5577cbf5af37ef22062862.zip
Version bump.
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
-rw-r--r--net-analyzer/httping/ChangeLog9
-rw-r--r--net-analyzer/httping/httping-1.5.7.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index bfb0872e3de0..882b21d3eb9b 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/httping
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.89 2012/12/10 13:14:46 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.90 2013/01/12 02:04:27 radhermit Exp $
+
+*httping-1.5.7 (12 Jan 2013)
+
+ 12 Jan 2013; Tim Harder <radhermit@gentoo.org> +httping-1.5.7.ebuild:
+ Version bump.
*httping-1.5.6 (10 Dec 2012)
diff --git a/net-analyzer/httping/httping-1.5.7.ebuild b/net-analyzer/httping/httping-1.5.7.ebuild
new file mode 100644
index 000000000000..cd326acac228
--- /dev/null
+++ b/net-analyzer/httping/httping-1.5.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.5.7.ebuild,v 1.1 2013/01/12 02:04:27 radhermit Exp $
+
+EAPI=5
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug ssl"
+
+RDEPEND="
+ >=sys-libs/ncurses-5
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}"
+
+# This would bring in test? ( dev-util/cppcheck ) but unlike
+# upstream we should only care about compile/run time testing
+RESTRICT="test"
+
+src_prepare() {
+ sed -i "/^OFLAGS/d" Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ SSL=$(usex ssl) \
+ DEBUG=$(usex debug)
+}
+
+src_install() {
+ dobin httping
+ doman httping.1
+ dodoc readme.txt
+}