summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCalum Selkirk <cselkirk@gentoo.org>2002-08-12 18:15:10 +0000
committerCalum Selkirk <cselkirk@gentoo.org>2002-08-12 18:15:10 +0000
commit097cbe15f62e1fa479d1a1d1e0bbf16250e4df88 (patch)
tree9cfaf9f2baf76baaea940ac5390839b6003f97b6
parentmasked zsh-4.0.5 for testing (diff)
downloadgentoo-2-097cbe15f62e1fa479d1a1d1e0bbf16250e4df88.tar.gz
gentoo-2-097cbe15f62e1fa479d1a1d1e0bbf16250e4df88.tar.bz2
gentoo-2-097cbe15f62e1fa479d1a1d1e0bbf16250e4df88.zip
New ebuild. Changed --prefix/ to --prefix/usr and added --bindir (this fixes defunct and missing paths in $fpath. Changed --fndir to /usr/share/zsh (--with-function-subdirs).
-rw-r--r--app-shells/zsh/ChangeLog14
-rw-r--r--app-shells/zsh/files/digest-zsh-4.0.51
-rw-r--r--app-shells/zsh/zsh-4.0.5.ebuild56
3 files changed, 69 insertions, 2 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index e6dd54bf8b51..6e55ce40e217 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -1,8 +1,18 @@
# ChangeLog for app-shells/zsh
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.6 2002/07/25 15:39:00 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.7 2002/08/12 18:15:10 cselkirk Exp $
-*zsh-4.0.4-r2 (3 Mar 2002)
+*zsh-4.0.5 (12 Aug 2002)
+
+ 12 Aug 2002 Calum Selkirk <cselkirk@gentoo.org> zsh-4.0.5.ebuild
+ files/digest-zsh-4.0.5 :
+
+ New ebuild.
+ Changed --prefix/ to --prefix/usr and added --bindir (this fixes defunct
+ and missing paths in $fpath.
+ Changed --fndir to /usr/share/zsh (--with-function-subdirs).
+
+ *zsh-4.0.4-r2 (3 Mar 2002)
25 Jul 2002; Daniel Ahlberg <aliz@gentoo.org> zsh-4.0.4-r2.ebuild :
Added SLOT.
diff --git a/app-shells/zsh/files/digest-zsh-4.0.5 b/app-shells/zsh/files/digest-zsh-4.0.5
new file mode 100644
index 000000000000..b13b87344f15
--- /dev/null
+++ b/app-shells/zsh/files/digest-zsh-4.0.5
@@ -0,0 +1 @@
+MD5 ab9c10508941daf384690efbc9b23e18 zsh-4.0.5.tar.gz 2145346
diff --git a/app-shells/zsh/zsh-4.0.5.ebuild b/app-shells/zsh/zsh-4.0.5.ebuild
new file mode 100644
index 000000000000..0a04f05d85fc
--- /dev/null
+++ b/app-shells/zsh/zsh-4.0.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.0.5.ebuild,v 1.1 2002/08/12 18:15:10 cselkirk Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.gz"
+HOMEPAGE="www.zsh.org/"
+SLOT="0"
+LICENSE="ZSH"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1"
+
+RDEPEND="${DEPEND}"
+
+KEYWORDS="x86 ppc"
+
+src_compile() {
+ ./configure --prefix=/usr --host=${CHOST} \
+ --bindir=/bin \
+ --mandir=/usr/share/man \
+ --libdir=/usr/lib \
+ --infodir=/usr/share/info \
+ --enable-maildir-support \
+ --enable-etcdir=/etc/zsh \
+ --enable-zshenv=/etc/zsh/zshenv \
+ --enable-zshlogin=/etc/zsh/zshlogin \
+ --enable-zshrc=/etc/zsh/zshrc \
+ --enable-fndir=/usr/share/zsh \
+ --enable-function-subdirs || die
+ # Can't use emake, b0rks
+ make || die
+ # make check violates sandboxing
+# make check || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ bindir=${D}/bin \
+ mandir=${D}/usr/share/man \
+ libdir=${D}/usr/lib \
+ fndir=${D}/usr/share/zsh \
+ infodir=${D}/usr/share/info \
+ install.bin install.man install.modules \
+ install.info install.fns || die
+
+ dodoc ChangeLog META-FAQ README INSTALL LICENCE config.modules
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+ dodir /etc/zsh
+ cp ${S}/StartupFiles/z* ${D}/etc/zsh
+
+ rm -rf ${D}/share
+}