summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2012-03-06 16:14:31 +0000
committerDenis Dupeyron <calchan@gentoo.org>2012-03-06 16:14:31 +0000
commit09d7dd2ba915a9bd86dcd7bed0c23251712f03a7 (patch)
tree965b9c8191fba9df876ba7d02cabe7d4994d2a1a
parentMarking pyyaml-3.10 ppc for bug 400337 (diff)
downloadgentoo-2-09d7dd2ba915a9bd86dcd7bed0c23251712f03a7.tar.gz
gentoo-2-09d7dd2ba915a9bd86dcd7bed0c23251712f03a7.tar.bz2
gentoo-2-09d7dd2ba915a9bd86dcd7bed0c23251712f03a7.zip
Version bump, thanks to Carles, Alexandre and Brandon (bug #356473).
(Portage version: 2.1.10.49/cvs/Linux x86_64)
-rw-r--r--app-office/homebank/ChangeLog9
-rw-r--r--app-office/homebank/homebank-4.4.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/app-office/homebank/ChangeLog b/app-office/homebank/ChangeLog
index 7fae75384f27..2faf7ea91769 100644
--- a/app-office/homebank/ChangeLog
+++ b/app-office/homebank/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/homebank
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/ChangeLog,v 1.24 2011/11/20 12:19:50 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/ChangeLog,v 1.25 2012/03/06 16:14:31 calchan Exp $
+
+*homebank-4.4 (06 Mar 2012)
+
+ 06 Mar 2012; Denis Dupeyron <calchan@gentoo.org> +homebank-4.4.ebuild:
+ Version bump, thanks to Carles, Alexandre and Brandon (bug #356473).
20 Nov 2011; Pacho Ramos <pacho@gentoo.org> homebank-4.3.ebuild:
Drop DEPRECATED flags, bug #367251
diff --git a/app-office/homebank/homebank-4.4.ebuild b/app-office/homebank/homebank-4.4.ebuild
new file mode 100644
index 000000000000..9dae83d9db9b
--- /dev/null
+++ b/app-office/homebank/homebank-4.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/homebank-4.4.ebuild,v 1.1 2012/03/06 16:14:31 calchan Exp $
+
+EAPI="4"
+
+inherit fdo-mime
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="http://homebank.free.fr/index.php"
+SRC_URI="http://homebank.free.fr/public/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ofx"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=x11-libs/gtk+-2.20
+ >=dev-libs/glib-2.17
+ ofx? ( >=dev-libs/libofx-0.7 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.40.5"
+
+src_configure() {
+ econf $(use_with ofx)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}