summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-10-31 01:11:26 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-10-31 01:11:26 +0000
commit0b62f4eed5e62be47bde85945b11275601724f91 (patch)
treee341ec983a94e157dae59f990a552e17ae35feb6
parentVersion bump for new RC. (diff)
downloadgentoo-2-0b62f4eed5e62be47bde85945b11275601724f91.tar.gz
gentoo-2-0b62f4eed5e62be47bde85945b11275601724f91.tar.bz2
gentoo-2-0b62f4eed5e62be47bde85945b11275601724f91.zip
Fixing bug #150513 and bug #145135
(Portage version: 2.1.2_pre3-r8)
-rw-r--r--sys-apps/pmount/ChangeLog6
-rw-r--r--sys-apps/pmount/pmount-0.9.11.ebuild4
-rw-r--r--sys-apps/pmount/pmount-0.9.13.ebuild16
-rw-r--r--sys-apps/pmount/pmount-0.9.9.ebuild4
4 files changed, 20 insertions, 10 deletions
diff --git a/sys-apps/pmount/ChangeLog b/sys-apps/pmount/ChangeLog
index f21d090e6200..17afe344a0b0 100644
--- a/sys-apps/pmount/ChangeLog
+++ b/sys-apps/pmount/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/pmount
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.34 2006/10/29 17:06:52 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.35 2006/10/31 01:11:26 cardoe Exp $
+
+ 31 Oct 2006; Doug Goldstein <cardoe@gentoo.org> pmount-0.9.9.ebuild,
+ pmount-0.9.11.ebuild, pmount-0.9.13.ebuild:
+ Fixing bug #150513 and bug #145135
29 Oct 2006; Doug Goldstein <cardoe@gentoo.org> pmount-0.9.9.ebuild,
pmount-0.9.11.ebuild, pmount-0.9.13.ebuild:
diff --git a/sys-apps/pmount/pmount-0.9.11.ebuild b/sys-apps/pmount/pmount-0.9.11.ebuild
index dc62adb70ea7..3c73b90349f1 100644
--- a/sys-apps/pmount/pmount-0.9.11.ebuild
+++ b/sys-apps/pmount/pmount-0.9.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.11.ebuild,v 1.3 2006/10/29 17:06:52 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.11.ebuild,v 1.4 2006/10/31 01:11:26 cardoe Exp $
inherit eutils flag-o-matic
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
IUSE="crypt"
-DEPEND="|| ( >=sys-apps/dbus-core-0.91 >=sys-apps/dbus-0.33 )
+DEPEND=">=sys-apps/dbus-0.33
>=sys-apps/hal-0.5.2
>=sys-fs/sysfsutils-1.3.0
crypt? ( sys-fs/cryptsetup-luks )"
diff --git a/sys-apps/pmount/pmount-0.9.13.ebuild b/sys-apps/pmount/pmount-0.9.13.ebuild
index 3391ca7d3a06..aba65f451e02 100644
--- a/sys-apps/pmount/pmount-0.9.13.ebuild
+++ b/sys-apps/pmount/pmount-0.9.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.13.ebuild,v 1.2 2006/10/29 17:06:52 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.13.ebuild,v 1.3 2006/10/31 01:11:26 cardoe Exp $
inherit eutils flag-o-matic
@@ -11,10 +11,10 @@ SRC_URI="http://www.piware.de/projects/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE="crypt"
+IUSE="crypt hal"
-DEPEND="|| ( >=sys-apps/dbus-core-0.91 >=sys-apps/dbus-0.33 )
- >=sys-apps/hal-0.5.2
+DEPEND="hal? ( >=sys-apps/dbus-0.33
+ >=sys-apps/hal-0.5.2 )
>=sys-fs/sysfsutils-1.3.0
crypt? ( sys-fs/cryptsetup-luks )"
@@ -25,10 +25,16 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
- sed -e 's:/sbin/cryptsetup:/bin/cryptsetup:' -i src/policy.h
append-ldflags $(bindnow-flags)
}
+src_compile() {
+ econf $(use_enable hal) \
+ --with-cryptsetup-prog=/bin/cryptsetup
+
+ emake || die "emake failed"
+}
+
src_install () {
# this is where we mount stuff
# moved to hal as of 0.5.7-r1
diff --git a/sys-apps/pmount/pmount-0.9.9.ebuild b/sys-apps/pmount/pmount-0.9.9.ebuild
index ec2e005cc858..b62d4eb97916 100644
--- a/sys-apps/pmount/pmount-0.9.9.ebuild
+++ b/sys-apps/pmount/pmount-0.9.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.9.ebuild,v 1.12 2006/10/29 17:06:52 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.9.ebuild,v 1.13 2006/10/31 01:11:26 cardoe Exp $
inherit eutils flag-o-matic
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="amd64 arm hppa ia64 ppc ppc64 sh sparc x86"
IUSE="crypt"
-DEPEND="|| ( >=sys-apps/dbus-core-0.91 >=sys-apps/dbus-0.33 )
+DEPEND=">=sys-apps/dbus-0.33
>=sys-apps/hal-0.5.2
>=sys-fs/sysfsutils-1.3.0
crypt? ( sys-fs/cryptsetup-luks )"