summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-07-02 19:57:23 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-07-02 19:57:23 +0000
commit0db97fbec3d87ab9d4b90cba7dce019702431d47 (patch)
tree3b73ddd7a56e3b9c05c931b3cb65f400feafb1c9
parentDrop fastrack (diff)
downloadgentoo-2-0db97fbec3d87ab9d4b90cba7dce019702431d47.tar.gz
gentoo-2-0db97fbec3d87ab9d4b90cba7dce019702431d47.tar.bz2
gentoo-2-0db97fbec3d87ab9d4b90cba7dce019702431d47.zip
Drop fastrack
-rw-r--r--net-p2p/gift-cvs/ChangeLog8
-rw-r--r--net-p2p/gift-cvs/Manifest5
-rw-r--r--net-p2p/gift-cvs/files/digest-gift-cvs-0.10.0-r30
-rw-r--r--net-p2p/gift-cvs/gift-cvs-0.10.0-r3.ebuild61
4 files changed, 71 insertions, 3 deletions
diff --git a/net-p2p/gift-cvs/ChangeLog b/net-p2p/gift-cvs/ChangeLog
index 4af854f4b3c8..05b0688a06b1 100644
--- a/net-p2p/gift-cvs/ChangeLog
+++ b/net-p2p/gift-cvs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/gift-cvs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-cvs/ChangeLog,v 1.15 2003/06/21 20:19:52 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-cvs/ChangeLog,v 1.16 2003/07/02 19:57:19 lostlogic Exp $
+
+*gift-cvs-0.10.0-r3 (02 Jul 2003)
+
+ 02 Jul 2003; Brandon Low <lostlogic@gentoo.org> gift-cvs-0.10.0-r3.ebuild:
+ Remove FastTrack, it will now be in a separate package called
+ net-p2p/gift-fasttrack-cvs
21 Jun 2003; Brandon Low <lostlogic@gentoo.org> gift-cvs-0.10.0-r2.ebuild,
gift-cvs-0.10.0.ebuild:
diff --git a/net-p2p/gift-cvs/Manifest b/net-p2p/gift-cvs/Manifest
index f4c925fe5e65..281fa6c3c6a7 100644
--- a/net-p2p/gift-cvs/Manifest
+++ b/net-p2p/gift-cvs/Manifest
@@ -1,6 +1,7 @@
-MD5 aa5d257dc35ff3490c981b1b12d346be gift-cvs-0.10.0-r3.ebuild 1705
+MD5 c819d53fbc3e2b14a14a15ee868166f2 gift-cvs-0.10.0-r3.ebuild 1705
+MD5 dab9a8103aec10f194b8898169227b88 gift-cvs-0.10.0-r2.ebuild 2748
MD5 edc00be17b8d44ccee0db57148aea5a2 gift-cvs-0.10.0.ebuild 1239
-MD5 48b150eb0f5ec7a2a8af2f82b34b7622 ChangeLog 1950
+MD5 a2cd275dfdee12545c42bd3195c485e0 ChangeLog 2156
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gift-cvs-0.10.0-r2 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gift-cvs-0.10.0-r3 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gift-cvs-0.10.0 0
diff --git a/net-p2p/gift-cvs/files/digest-gift-cvs-0.10.0-r3 b/net-p2p/gift-cvs/files/digest-gift-cvs-0.10.0-r3
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/net-p2p/gift-cvs/files/digest-gift-cvs-0.10.0-r3
diff --git a/net-p2p/gift-cvs/gift-cvs-0.10.0-r3.ebuild b/net-p2p/gift-cvs/gift-cvs-0.10.0-r3.ebuild
new file mode 100644
index 000000000000..d60b22f1e328
--- /dev/null
+++ b/net-p2p/gift-cvs/gift-cvs-0.10.0-r3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-cvs/gift-cvs-0.10.0-r3.ebuild,v 1.1 2003/07/02 19:57:19 lostlogic Exp $
+
+DESCRIPTION="A OpenFT, Gnutella and FastTrack p2p network client"
+HOMEPAGE="http://gift.sourceforge.net"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+DEPENDS="virtual/glibc
+ >=sys-apps/sed-4
+ >=sys-libs/zlib-1.1.4"
+
+inherit cvs debug flag-o-matic
+
+strip-flags
+
+# CVS settings for giFT
+ECVS_SERVER="cvs.sourceforge.net:/cvsroot/gift"
+ECVS_MODULE="giFT"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/${PN}"
+S=${WORKDIR}/${ECVS_MODULE}
+
+src_compile() {
+
+ # Compile giFT. Gnutella support is enabled by default (can be switched off).
+ cd ${S}
+ ./autogen.sh --prefix=/usr --enable-gnutella --host=${CHOST} || die "Bootstrap configure failed"
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die "Make failed"
+
+}
+
+src_install() {
+
+ # Install giFT.
+ cd ${S}
+ einstall giftconfdir=${D}/etc/giFT \
+ plugindir=${D}/usr/lib/giFT \
+ giftdatadir=${D}/usr/share/giFT \
+ giftperldir=${D}/usr/bin \
+ libgiftincdir=${D}/usr/include/libgift || die "Install failed"
+
+ # Fix the giFT-setup executable.
+ cd ${D}/usr/bin
+ sed -i -e 's:$prefix/etc/giFT/:/etc/giFT/:' giFT-setup
+
+}
+
+pkg_postinst() {
+ einfo "First of all you need to run giFT-setup with your normal"
+ einfo "user account to create the giFT configuration files."
+ echo
+ einfo "To run giFT with FastTrack support, run:"
+ einfo "giFT -p /usr/lib/giFT/libFastTrack.so"
+ echo
+ einfo "Alternatively you can add the following line to"
+ einfo "your ~/.giFT/gift.conf configuration file:"
+ einfo "plugins = OpenFT:FastTrack"
+}
+