summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2012-09-17 19:53:22 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2012-09-17 19:53:22 +0000
commit1195620c8eb8c3ad5cea2d3bca57102e6d4f9a9f (patch)
tree3b8a49458c8c285eb3a5d5abc604394daf5eeb11
parentLinux patch 3.4.11 (diff)
downloadgentoo-2-1195620c8eb8c3ad5cea2d3bca57102e6d4f9a9f.tar.gz
gentoo-2-1195620c8eb8c3ad5cea2d3bca57102e6d4f9a9f.tar.bz2
gentoo-2-1195620c8eb8c3ad5cea2d3bca57102e6d4f9a9f.zip
part 2 of previous commit
(Portage version: 2.1.11.9/cvs/Linux x86_64)
-rw-r--r--net-analyzer/icinga/ChangeLog6
-rw-r--r--net-analyzer/icinga/files/icinga-init.d2
-rwxr-xr-xnet-analyzer/icinga/files/icinga-init.d-262
-rw-r--r--net-analyzer/icinga/files/ido2db-init.d2
-rw-r--r--net-analyzer/icinga/files/ido2db-init.d-240
5 files changed, 7 insertions, 105 deletions
diff --git a/net-analyzer/icinga/ChangeLog b/net-analyzer/icinga/ChangeLog
index 875e06906517..1d20ab8c3030 100644
--- a/net-analyzer/icinga/ChangeLog
+++ b/net-analyzer/icinga/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/icinga
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/ChangeLog,v 1.26 2012/09/17 19:48:49 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/ChangeLog,v 1.27 2012/09/17 19:53:22 prometheanfire Exp $
+
+ 17 Sep 2012; Matthew Thode <prometheanfire@gentoo.org> files/icinga-init.d,
+ files/ido2db-init.d:
+ part 2 of previous commit
17 Sep 2012; Matthew Thode <prometheanfire@gentoo.org>
-icinga-1.6.1-r2.ebuild, -icinga-1.7.0.ebuild, -icinga-1.7.1-r3.ebuild,
diff --git a/net-analyzer/icinga/files/icinga-init.d b/net-analyzer/icinga/files/icinga-init.d
index ad3108ad5bc9..3eb213c537b3 100644
--- a/net-analyzer/icinga/files/icinga-init.d
+++ b/net-analyzer/icinga/files/icinga-init.d
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/files/icinga-init.d,v 1.3 2012/09/17 19:48:49 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/files/icinga-init.d,v 1.4 2012/09/17 19:53:22 prometheanfire Exp $
: ${ICINGACFG:=/etc/icinga/icinga.cfg}
diff --git a/net-analyzer/icinga/files/icinga-init.d-2 b/net-analyzer/icinga/files/icinga-init.d-2
deleted file mode 100755
index eb3a72bbc128..000000000000
--- a/net-analyzer/icinga/files/icinga-init.d-2
+++ /dev/null
@@ -1,62 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/files/icinga-init.d-2,v 1.8 2012/09/10 15:25:26 prometheanfire Exp $
-
-: ${ICINGACFG:=/etc/icinga/icinga.cfg}
-
-extra_commands="checkconfig"
-extra_started_commands="reload"
-
-command=/usr/sbin/icinga
-command_args="-d ${ICINGACFG}"
-
-get_config() {
- if [ -e "${ICINGACFG}" ]; then
- sed -n -e 's:^[ \t]*'$1'=\([^#]\+\).*:\1:p' "${ICINGACFG}"
- fi
-}
-
-pidfile=$(get_config lock_file)
-start_stop_daemon_args="-e HOME=/var/lib/icinga"
-
-depend() {
- need net
- use dns logger firewall mysql postgresql ido2db
-}
-
-checkconfig() {
- # Silent Check
- ${command} -v ${ICINGACFG} &>/dev/null && return 0
- # Now we know there's problem - run again and display errors
- ${command} -v ${ICINGACFG}
- eend $? "Configuration Error. Please fix your configfile"
-}
-
-reload()
-{
- checkconfig || return 1
- ebegin "Reloading configuration"
- kill -HUP $(cat ${pidfile}) &>/dev/null
- eend $?
-}
-
-start_pre() {
- checkpath -d -o icinga:icinga $(get_config temp_path) $(dirname $(get_config lock_file)) $(dirname $(get_config log_file)) $(dirname $(get_config status_file))
- checkpath -f -o icinga:icinga $(get_config log_file)
- rm -f $(get_config command_file)
-}
-
-stop_post() {
- rm -f $(get_config command_file)
- rm -r /tmp/icinga
-}
-
-svc_restart() {
- checkconfig || return 1
- ebegin "Restarting icinga"
- svc_stop
- svc_start
- eend $?
-}
-
diff --git a/net-analyzer/icinga/files/ido2db-init.d b/net-analyzer/icinga/files/ido2db-init.d
index d9ceb4584e6f..6ad019c3a99c 100644
--- a/net-analyzer/icinga/files/ido2db-init.d
+++ b/net-analyzer/icinga/files/ido2db-init.d
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/files/ido2db-init.d,v 1.3 2012/09/17 19:48:49 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/files/ido2db-init.d,v 1.4 2012/09/17 19:53:22 prometheanfire Exp $
get_config() {
if [ -e "${IDO2DBCFG}" ]; then
diff --git a/net-analyzer/icinga/files/ido2db-init.d-2 b/net-analyzer/icinga/files/ido2db-init.d-2
deleted file mode 100644
index 29c2bae5cd79..000000000000
--- a/net-analyzer/icinga/files/ido2db-init.d-2
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/files/ido2db-init.d-2,v 1.3 2012/09/10 15:25:26 prometheanfire Exp $
-
-get_config() {
- if [ -e "${IDO2DBCFG}" ]; then
- sed -n -e 's:^[ \t]*'$1'=\([^#]\+\).*:\1:p' "${IDO2DBCFG}"
- fi
-}
-
-command=/usr/sbin/ido2db
-command_args="-c ${IDO2DBCFG}"
-pidfile="$(get_config lock_file)"
-
-depend() {
- config "${IDO2DBCFG}"
-
- need net
- use dns logger firewall
-
- case $(get_config db_servertype) in
- mysql)
- use mysql ;;
- pgsql)
- use postgresql ;;
- esac
-}
-
-IDO2DBSOCKET="$(get_config socket_name)"
-
-
-start_pre() {
- if [ -S "${IDO2DBSOCKET}" ] ; then
- ewarn "Strange, the socket file already exist in \"${IDO2DBSOCKET}\""
- ewarn "it will be removed now and re-created by ido2db"
- ewarn "BUT please make your checks."
- rm -f "${IDO2DBSOCKET}"
- fi
-}