summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 16:41:18 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 16:41:18 +0000
commit137504b029224b10da6eaaa92c36d204db5d773c (patch)
tree7e6c5b6bfd17af71d94c2d6b0356f038bc524ff4
parentVersion bump for Gnome 3.12. (diff)
downloadgentoo-2-137504b029224b10da6eaaa92c36d204db5d773c.tar.gz
gentoo-2-137504b029224b10da6eaaa92c36d204db5d773c.tar.bz2
gentoo-2-137504b029224b10da6eaaa92c36d204db5d773c.zip
Version bump for Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
-rw-r--r--gnome-base/dconf/ChangeLog7
-rw-r--r--gnome-base/dconf/dconf-0.20.0.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/gnome-base/dconf/ChangeLog b/gnome-base/dconf/ChangeLog
index ca90ba37dec4..92062ad9b2f3 100644
--- a/gnome-base/dconf/ChangeLog
+++ b/gnome-base/dconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/dconf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/ChangeLog,v 1.57 2014/04/26 17:52:12 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/ChangeLog,v 1.58 2014/04/27 16:41:18 eva Exp $
+
+*dconf-0.20.0 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org> +dconf-0.20.0.ebuild:
+ Version bump for Gnome 3.12.
26 Apr 2014; Pacho Ramos <pacho@gentoo.org> -dconf-0.16.1.ebuild:
drop old
diff --git a/gnome-base/dconf/dconf-0.20.0.ebuild b/gnome-base/dconf/dconf-0.20.0.ebuild
new file mode 100644
index 000000000000..171e79e9d042
--- /dev/null
+++ b/gnome-base/dconf/dconf-0.20.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/dconf-0.20.0.ebuild,v 1.1 2014/04/27 16:41:18 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 bash-completion-r1 virtualx
+
+DESCRIPTION="Simple low-level configuration system"
+HOMEPAGE="https://wiki.gnome.org/dconf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+# TODO: coverage ?
+IUSE="test +X"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~arm-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.39.1:2
+ sys-apps/dbus
+ X? (
+ >=dev-libs/libxml2-2.7.7:2
+ >=x11-libs/gtk+-3.4:3 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-gcov \
+ --enable-man \
+ $(use_enable X editor) \
+ VALAC=$(type -P true)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ # GSettings backend may be one of: memory, gconf, dconf
+ # Only dconf is really considered functional by upstream
+ # must have it enabled over gconf if both are installed
+ echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
+ doenvd 51dconf
+
+ # Install bash-completion file properly to the system
+ rm -rv "${ED}usr/share/bash-completion" || die
+ dobashcomp "${S}/bin/completion/dconf"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ # Kill existing dconf-service processes as recommended by upstream due to
+ # possible changes in the dconf private dbus API.
+ # dconf-service will be dbus-activated on next use.
+ pids=$(pgrep -x dconf-service)
+ if [[ $? == 0 ]]; then
+ ebegin "Stopping dconf-service; it will automatically restart on demand"
+ kill ${pids}
+ eend $?
+ fi
+}