summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-03-27 08:20:34 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-03-27 08:20:34 +0000
commit15dc7b8a2e9cf55a0a2481179662e0a8b2c67368 (patch)
treeb982c4d831dd90aec5c60d0b65fe7349aa8ee4d3
parentAdded ~ppc (diff)
downloadgentoo-2-15dc7b8a2e9cf55a0a2481179662e0a8b2c67368.tar.gz
gentoo-2-15dc7b8a2e9cf55a0a2481179662e0a8b2c67368.tar.bz2
gentoo-2-15dc7b8a2e9cf55a0a2481179662e0a8b2c67368.zip
version bump, fixes bugs 172277 and 156038: Removed mailcrypt
dependency and crypt USE flag; this does not influence the building of the package. Always install bbdb-pgp.el. Added explanation message to pkg_postinst. Additional die handle SITEFILE the normal way Thanks to Ulrich Mueller <ulm@kph.uni-mainz.de> (Portage version: 2.1.2.2)
-rw-r--r--app-emacs/bbdb/ChangeLog13
-rw-r--r--app-emacs/bbdb/bbdb-2.35.ebuild74
-rw-r--r--app-emacs/bbdb/files/digest-bbdb-2.359
3 files changed, 95 insertions, 1 deletions
diff --git a/app-emacs/bbdb/ChangeLog b/app-emacs/bbdb/ChangeLog
index a4b6b50d36bd..1c6b83e21ef1 100644
--- a/app-emacs/bbdb/ChangeLog
+++ b/app-emacs/bbdb/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-emacs/bbdb
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/ChangeLog,v 1.19 2007/03/07 05:47:24 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/ChangeLog,v 1.20 2007/03/27 08:20:34 opfer Exp $
+
+*bbdb-2.35 (27 Mar 2007)
+
+ 27 Mar 2007; Christian Faulhammer <opfer@gentoo.org> +bbdb-2.35.ebuild:
+ version bump, fixes bugs 172277 and 156038: Removed mailcrypt
+ dependency and crypt USE flag; this does not influence the building of
+ the package. Always install bbdb-pgp.el. Added explanation message to
+ pkg_postinst.
+ Additional die
+ handle SITEFILE the normal way
+ Thanks to Ulrich Mueller <ulm@kph.uni-mainz.de>
07 Mar 2007; Christian Faulhammer <opfer@gentoo.org>
files/50bbdb-gentoo.el:
diff --git a/app-emacs/bbdb/bbdb-2.35.ebuild b/app-emacs/bbdb/bbdb-2.35.ebuild
new file mode 100644
index 000000000000..17b2a17e2006
--- /dev/null
+++ b/app-emacs/bbdb/bbdb-2.35.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/bbdb/bbdb-2.35.ebuild,v 1.1 2007/03/27 08:20:34 opfer Exp $
+
+inherit elisp
+
+DESCRIPTION="The Insidious Big Brother Database"
+HOMEPAGE="http://bbdb.sourceforge.net/"
+SRC_URI="http://bbdb.sourceforge.net/${P}.tar.gz
+ http://www.mit.edu/afs/athena/contrib/emacs-contrib/Fin/point-at.el
+ http://www.mit.edu/afs/athena/contrib/emacs-contrib/Fin/dates.el"
+
+LICENSE="GPL-2 as-is"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+IUSE="tetex"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ tetex? ( virtual/tetex )"
+
+SITEFILE=50bbdb-gentoo.el
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ sed -i -e '0,/^--- bbdb-mail-folders.el ---$/d;/^--- end ---$/,$d' \
+ bits/bbdb-mail-folders.el || die "sed failed"
+ sed -i -e '/^;/,$!d' bits/bbdb-sort-mailrc.el || die "sed failed"
+ cp ${DISTDIR}/{dates,point-at}.el bits
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake -j1 || die "emake failed"
+
+ cat >${T}/lp.el <<-EOF
+ (add-to-list 'load-path "${S}/bits")
+ (add-to-list 'load-path "${S}/lisp")
+ EOF
+ emacs -batch -no-site-file -l ${T}/lp.el \
+ -f batch-byte-compile bits/*.el || die "make bits failed"
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el{,c} || die
+ elisp-install ${PN}/bits bits/*.el{,c} || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ doinfo texinfo/*.info*
+ dodoc ChangeLog INSTALL README bits/*.txt
+ newdoc bits/README README.bits
+ if use tetex; then
+ insinto /usr/share/texmf/tex/bbdb
+ doins tex/*.tex
+ fi
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ use tetex && texconfig rehash
+
+ echo
+ elog "If you use encryption or signing, you may specify the encryption"
+ elog "method by customising variable \"bbdb/pgp-method\". For details,"
+ elog "see the documentation of this variable. Depending on the Emacs"
+ elog "version, installation of additional packages like app-emacs/gnus"
+ elog "or app-emacs/mailcrypt may be required."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+ use tetex && texconfig rehash
+}
diff --git a/app-emacs/bbdb/files/digest-bbdb-2.35 b/app-emacs/bbdb/files/digest-bbdb-2.35
new file mode 100644
index 000000000000..2b31c7d7395f
--- /dev/null
+++ b/app-emacs/bbdb/files/digest-bbdb-2.35
@@ -0,0 +1,9 @@
+MD5 5c4e7f2b2a6a8e25ff77351f533f3910 bbdb-2.35.tar.gz 393097
+RMD160 efa04f4ea1428f591bd20738f8c7d0c5f3a919e8 bbdb-2.35.tar.gz 393097
+SHA256 3fb1316e2ed74d47ca61187fada550e58797467bd9e8ad67343ed16da769f916 bbdb-2.35.tar.gz 393097
+MD5 1979e29c242f16c6a96f091a04a6a74a dates.el 7048
+RMD160 f8428bf5614031b907fc1395b3d4f3e59345649b dates.el 7048
+SHA256 8de33f7b00ac1766eb104c1bf2f362aff54e3de4d67cbd0a4da1b6b137363ec4 dates.el 7048
+MD5 fc14cd7ca30c3abc4acc1c3ab95c1644 point-at.el 440
+RMD160 139834d869575df5b826e681e37f3d0f769af789 point-at.el 440
+SHA256 c9695455b96f17fbebc9cf0ae21b042fb04b688016279010d87c01e9d270e0c8 point-at.el 440