summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-08-16 01:45:33 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-08-16 01:45:33 +0000
commit17cedd96f146fb91e7ec600c8e84854b6186314c (patch)
tree5d940679febd1668892d9f326b6de97f053c6cce
parentFix WANT_AUTOCONF for bug #143429 (diff)
downloadgentoo-2-17cedd96f146fb91e7ec600c8e84854b6186314c.tar.gz
gentoo-2-17cedd96f146fb91e7ec600c8e84854b6186314c.tar.bz2
gentoo-2-17cedd96f146fb91e7ec600c8e84854b6186314c.zip
Version bump. This fixes bug #143076.
(Portage version: 2.1.1_pre5)
-rw-r--r--sci-libs/itpp/ChangeLog8
-rw-r--r--sci-libs/itpp/files/digest-itpp-3.10.53
-rw-r--r--sci-libs/itpp/itpp-3.10.5.ebuild58
3 files changed, 68 insertions, 1 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index d3675cb2883d..53c4a1c8f7a4 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.8 2006/08/08 01:02:35 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.9 2006/08/16 01:45:33 markusle Exp $
+
+*itpp-3.10.5 (16 Aug 2006)
+
+ 16 Aug 2006; Markus Dittrich <markusle@gentoo.org> +itpp-3.10.5.ebuild:
+ Version bump. Thanks much to Adam Piatyszek <ediap@et.put.poznan.pl>
+ for keeping us posted. This fixes bug #143076.
*itpp-3.10.4 (08 Aug 2006)
diff --git a/sci-libs/itpp/files/digest-itpp-3.10.5 b/sci-libs/itpp/files/digest-itpp-3.10.5
new file mode 100644
index 000000000000..94d48f19b69f
--- /dev/null
+++ b/sci-libs/itpp/files/digest-itpp-3.10.5
@@ -0,0 +1,3 @@
+MD5 a4c9a13ff457ee168cec5edade272ff8 itpp-3.10.5.tar.bz2 798983
+RMD160 6341ee6db0c1a903040cab537cb7e3968234f22d itpp-3.10.5.tar.bz2 798983
+SHA256 a4ddf582273a566a60bb44e77a38512cf7f1025bc4c2563ed79b47c380ddf250 itpp-3.10.5.tar.bz2 798983
diff --git a/sci-libs/itpp/itpp-3.10.5.ebuild b/sci-libs/itpp/itpp-3.10.5.ebuild
new file mode 100644
index 000000000000..67b70ebb0b93
--- /dev/null
+++ b/sci-libs/itpp/itpp-3.10.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-3.10.5.ebuild,v 1.1 2006/08/16 01:45:33 markusle Exp $
+
+inherit fortran
+
+DESCRIPTION="IT++ is a C++ library of mathematical, signal processing, speech processing, and communications classes and functions"
+LICENSE="GPL-2"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="blas cblas debug doc fftw lapack"
+
+DEPEND="fftw? ( >=sci-libs/fftw-3.0.0 )
+ blas? ( virtual/blas
+ cblas? ( || ( >=sci-libs/gsl-1.4
+ >=sci-libs/acml-2.5.3
+ >=sci-libs/blas-atlas-3.6.0
+ sci-libs/cblas-reference ) )
+ lapack? ( virtual/lapack ) )
+ doc? ( app-doc/doxygen
+ virtual/tetex )"
+
+pkg_setup() {
+ # lapack/cblas can only be used in conjunction with blas
+ if use cblas && ! use blas; then
+ die "USE=cblas requires USE=blas to be set"
+ fi
+ if use lapack && ! use blas; then
+ die "USE=lapack requires USE=blas to be set"
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if use blas; then
+ myconf="--with-blas=-lblas"
+ else
+ myconf="--without-blas"
+ fi
+ econf $(use_enable doc html-doc) \
+ $(use_enable debug) \
+ $(use_with cblas) \
+ $(use_with lapack) \
+ $(use_with fftw fft) \
+ "$myconf" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO || \
+ die "failed to install docs"
+}