summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-13 10:26:40 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-13 10:26:40 +0000
commit1818fdb293cda7d43f6babeca9d687a4b13c408a (patch)
treea4a3f957bd01eb97937bac4e5d68696d87f7e5af
parentRemove old versions. (diff)
downloadgentoo-2-1818fdb293cda7d43f6babeca9d687a4b13c408a.tar.gz
gentoo-2-1818fdb293cda7d43f6babeca9d687a4b13c408a.tar.bz2
gentoo-2-1818fdb293cda7d43f6babeca9d687a4b13c408a.zip
Remove old versions.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
-rw-r--r--dev-ruby/rspec-core/ChangeLog9
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.0.0_beta22.ebuild54
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.6.0.ebuild (renamed from dev-ruby/rspec-core/rspec-core-2.4.0.ebuild)9
3 files changed, 12 insertions, 60 deletions
diff --git a/dev-ruby/rspec-core/ChangeLog b/dev-ruby/rspec-core/ChangeLog
index 8cb74a46994d..3c4c0344e2a6 100644
--- a/dev-ruby/rspec-core/ChangeLog
+++ b/dev-ruby/rspec-core/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/rspec-core
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.7 2011/02/19 09:27:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.8 2011/05/13 10:26:40 graaff Exp $
+
+*rspec-core-2.6.0 (13 May 2011)
+
+ 13 May 2011; Hans de Graaff <graaff@gentoo.org>
+ -rspec-core-2.0.0_beta22.ebuild, -rspec-core-2.4.0.ebuild,
+ +rspec-core-2.6.0.ebuild:
+ Remove old versions.
*rspec-core-2.5.1 (19 Feb 2011)
diff --git a/dev-ruby/rspec-core/rspec-core-2.0.0_beta22.ebuild b/dev-ruby/rspec-core/rspec-core-2.0.0_beta22.ebuild
deleted file mode 100644
index a4c01a2b9b09..000000000000
--- a/dev-ruby/rspec-core/rspec-core-2.0.0_beta22.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.0.0_beta22.ebuild,v 1.4 2010/12/27 21:00:45 grobian Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 ruby19"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-
-RUBY_FAKEGEM_EXTRADOC="README.markdown Upgrade.markdown"
-
-RUBY_FAKEGEM_EXTRAINSTALL="autotest"
-
-RUBY_FAKEGEM_VERSION="2.0.0.beta.22"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="http://rspec.rubyforge.org/"
-SRC_URI="mirror://rubygems/${PN}-${RUBY_FAKEGEM_VERSION}.gem"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "dev-ruby/syntax"
-
-ruby_add_rdepend "
- ~dev-ruby/rspec-expectations-${PV}
- ~dev-ruby/rspec-mocks-${PV}"
-
-# >=dev-ruby/cucumber-0.5.3
-# >=dev-ruby/autotest-4.2.9
-# dev-ruby/aruba"
-
-all_ruby_prepare() {
- # Don't set up bundler: it doesn't understand our setup.
- # Instead include rspec's version to fix an issue with the rdoc task.
- sed -i -e 's|require "bundler"|require "rspec/core/version"|' Rakefile || die
- sed -i -e '/Bundler/d' Rakefile || die
-
- # Remove the Gemfile to avoid running through 'bundle exec'
- rm Gemfile || die
-
- # Also clean the /usr/lib/rubyee path (which is our own invention).
- sed -i -e 's#lib\\d\*\\/ruby\\/#lib\\d*\\/ruby(ee|)\\/#' lib/rspec/core/configuration.rb || die
-}
-
-each_ruby_test() {
- PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec
-
- # There are features but they require aruba which we don't have yet.
-}
diff --git a/dev-ruby/rspec-core/rspec-core-2.4.0.ebuild b/dev-ruby/rspec-core/rspec-core-2.6.0.ebuild
index b0d0544aa93e..e680b3cdcb5d 100644
--- a/dev-ruby/rspec-core/rspec-core-2.4.0.ebuild
+++ b/dev-ruby/rspec-core/rspec-core-2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.4.0.ebuild,v 1.2 2011/02/02 14:12:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.6.0.ebuild,v 1.1 2011/05/13 10:26:40 graaff Exp $
EAPI=2
USE_RUBY="ruby18 ree18 ruby19"
@@ -8,7 +8,7 @@ USE_RUBY="ruby18 ree18 ruby19"
RUBY_FAKEGEM_TASK_TEST="none"
RUBY_FAKEGEM_TASK_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="History.markdown README.md Upgrade.markdown"
+RUBY_FAKEGEM_EXTRADOC="README.md"
inherit ruby-fakegem
@@ -41,8 +41,6 @@ all_ruby_prepare() {
# Also clean the /usr/lib/rubyee path (which is our own invention).
sed -i -e 's#lib\\d\*\\/ruby\\/#lib\\d*\\/ruby(ee|)\\/#' lib/rspec/core/configuration.rb || die
-
- epatch "${FILESDIR}"/${P}-tests.patch
}
all_ruby_compile() {
@@ -54,5 +52,6 @@ all_ruby_compile() {
each_ruby_test() {
PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec || die "Tests failed."
- # There are features but they require aruba which we don't have yet.
+ # There are features but it seems as if these only work against a
+ # fully installed version.
}