summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-03-09 16:06:41 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-03-09 16:06:41 +0000
commit186ff90393b67acc90da7867f078a0f11e846e60 (patch)
treea9ac888e47a383c19aaeec8a55051d8b067180b2
parentStable on x86 wrt bug #212398 (diff)
downloadgentoo-2-186ff90393b67acc90da7867f078a0f11e846e60.tar.gz
gentoo-2-186ff90393b67acc90da7867f078a0f11e846e60.tar.bz2
gentoo-2-186ff90393b67acc90da7867f078a0f11e846e60.zip
Version bump
(Portage version: 2.1.4.4)
-rw-r--r--net-libs/rb_libtorrent/ChangeLog8
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.13_rc1.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index ce07b0bdb3b4..f8cbae1bd29f 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.42 2008/02/10 15:51:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.43 2008/03/09 16:06:41 armin76 Exp $
+
+*rb_libtorrent-0.13_rc1 (09 Mar 2008)
+
+ 09 Mar 2008; Raúl Porcel <armin76@gentoo.org>
+ +rb_libtorrent-0.13_rc1.ebuild:
+ Version bump
10 Feb 2008; Raúl Porcel <armin76@gentoo.org> -rb_libtorrent-0.12.ebuild:
old
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.13_rc1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.13_rc1.ebuild
new file mode 100644
index 000000000000..6cc5092dbd8b
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.13_rc1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.13_rc1.ebuild,v 1.1 2008/03/09 16:06:41 armin76 Exp $
+
+inherit eutils autotools
+
+MY_P=${PN/rb_/}-${PV/_rc/rc}
+S="${WORKDIR}/${MY_P/rc*}"
+
+DESCRIPTION="BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="http://libtorrent.org/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND="dev-libs/boost
+ !net-libs/libtorrent"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ # We need boost built with threads
+ if ! has_version ">=dev-libs/boost-1.34_pre20061214" && \
+ ! built_with_use "dev-libs/boost" threads; then
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
+ fi
+}
+
+src_compile() {
+ BOOST_LIBS="--with-boost-date-time=boost_date_time-mt \
+ --with-boost-filesystem=boost_filesystem-mt \
+ --with-boost-thread=boost_thread-mt \
+ --with-boost-regex=boost_regex-mt \
+ --with-boost-program_options=boost_program_options-mt"
+
+ econf $(use_enable debug) \
+ ${BOOST_LIBS} \
+ LDFLAGS="${LDFLAGS} -pthread" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog AUTHORS NEWS README
+}