summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-04-12 17:55:57 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-04-12 17:55:57 +0000
commit1d0c093b3ce713c5215f4e71d4d032c16ac37608 (patch)
tree99011fe7d9a0b5e9cac049c73e770f4e8e771c60
parentallow any rev of automake-1.4_p6 to avoid dep breakage (diff)
downloadgentoo-2-1d0c093b3ce713c5215f4e71d4d032c16ac37608.tar.gz
gentoo-2-1d0c093b3ce713c5215f4e71d4d032c16ac37608.tar.bz2
gentoo-2-1d0c093b3ce713c5215f4e71d4d032c16ac37608.zip
Run tests correctly, bug #314831 by Dustin Polke
<gentoobugsie.20.dsurawicz@spamgourmet.com> (Portage version: 2.1.7.17/cvs/Linux i686)
-rw-r--r--app-misc/lockfile-progs/ChangeLog6
-rw-r--r--app-misc/lockfile-progs/files/Makefile34
2 files changed, 24 insertions, 16 deletions
diff --git a/app-misc/lockfile-progs/ChangeLog b/app-misc/lockfile-progs/ChangeLog
index 3a999d6d45ee..fcd1cc54794e 100644
--- a/app-misc/lockfile-progs/ChangeLog
+++ b/app-misc/lockfile-progs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/lockfile-progs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lockfile-progs/ChangeLog,v 1.6 2010/03/28 19:03:32 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lockfile-progs/ChangeLog,v 1.7 2010/04/12 17:55:57 phajdan.jr Exp $
+
+ 12 Apr 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> files/Makefile:
+ Run tests correctly, bug #314831 by Dustin Polke
+ <gentoobugsie.20.dsurawicz@spamgourmet.com>
28 Mar 2010; Raúl Porcel <armin76@gentoo.org>
lockfile-progs-0.1.13.ebuild:
diff --git a/app-misc/lockfile-progs/files/Makefile b/app-misc/lockfile-progs/files/Makefile
index 77b41608c275..27276b30f5da 100644
--- a/app-misc/lockfile-progs/files/Makefile
+++ b/app-misc/lockfile-progs/files/Makefile
@@ -28,24 +28,28 @@ install: all
ln -s lockfile-progs.1 $(DESTDIR)/usr/share/man/man1/mail-touchlock.1
test: all
- lockfile-create testfile
- lockfile-check testfile
- lockfile-touch --oneshot testfile
- lockfile-check testfile
- lockfile-remove testfile
+ ln -s lockfile-create ./lockfile-remove
+ ln -s lockfile-create ./lockfile-touch
+ ln -s lockfile-create ./lockfile-check
+
+ ./lockfile-create testfile
+ ./lockfile-check testfile
+ ./lockfile-touch --oneshot testfile
+ ./lockfile-check testfile
+ ./lockfile-remove testfile
! test -e testfile
- ! lockfile-check testfile
+ ! ./lockfile-check testfile
- lockfile-create --lock-name test.lock
- lockfile-check --lock-name test.lock
- ! lockfile-check test.lock
+ ./lockfile-create --lock-name test.lock
+ ./lockfile-check --lock-name test.lock
+ ! ./lockfile-check test.lock
! test -e test.lock.lock
- lockfile-touch --oneshot --lock-name test.lock
- lockfile-check --lock-name test.lock
- ! lockfile-check test.lock
- lockfile-remove --lock-name test.lock
+ ./lockfile-touch --oneshot --lock-name test.lock
+ ./lockfile-check --lock-name test.lock
+ ! ./lockfile-check test.lock
+ ./lockfile-remove --lock-name test.lock
! test -e test.lock
- ! lockfile-check --lock-name test.lock
- ! lockfile-check test.lock
+ ! ./lockfile-check --lock-name test.lock
+ ! ./lockfile-check test.lock
.PHONY: install test