summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-12 18:35:42 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-12 18:35:42 +0000
commit1e08ed762623f5e65e134ec2e358dfa26c24628e (patch)
tree75182c5ed883430f74b6774868b71db46b571ed6
parentStable for ppc, wrt bug #436348 (diff)
downloadgentoo-2-1e08ed762623f5e65e134ec2e358dfa26c24628e.tar.gz
gentoo-2-1e08ed762623f5e65e134ec2e358dfa26c24628e.tar.bz2
gentoo-2-1e08ed762623f5e65e134ec2e358dfa26c24628e.zip
fix syntax highlighting wrt #460710
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
-rw-r--r--dev-util/ninja-ide/ChangeLog8
-rw-r--r--dev-util/ninja-ide/files/ninja-ide-2.1.1-syntaxhighlighting.patch27
-rw-r--r--dev-util/ninja-ide/ninja-ide-2.1.1-r4.ebuild50
3 files changed, 84 insertions, 1 deletions
diff --git a/dev-util/ninja-ide/ChangeLog b/dev-util/ninja-ide/ChangeLog
index 611533a5f5af..c649bde91eda 100644
--- a/dev-util/ninja-ide/ChangeLog
+++ b/dev-util/ninja-ide/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/ninja-ide
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja-ide/ChangeLog,v 1.8 2013/01/22 19:24:19 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja-ide/ChangeLog,v 1.9 2013/03/12 18:35:41 hasufell Exp $
+
+*ninja-ide-2.1.1-r4 (12 Mar 2013)
+
+ 12 Mar 2013; Julian Ospald <hasufell@gentoo.org> +ninja-ide-2.1.1-r4.ebuild,
+ +files/ninja-ide-2.1.1-syntaxhighlighting.patch:
+ fix syntax highlighting wrt #460710
*ninja-ide-2.1.1-r3 (22 Jan 2013)
diff --git a/dev-util/ninja-ide/files/ninja-ide-2.1.1-syntaxhighlighting.patch b/dev-util/ninja-ide/files/ninja-ide-2.1.1-syntaxhighlighting.patch
new file mode 100644
index 000000000000..cfeb8149d327
--- /dev/null
+++ b/dev-util/ninja-ide/files/ninja-ide-2.1.1-syntaxhighlighting.patch
@@ -0,0 +1,27 @@
+From c722e86c4e497efac56de674c47d5e094ea4c5c5 Mon Sep 17 00:00:00 2001
+From: Diego Sarmentero <diego.sarmentero@ninja-ide.org>
+Date: Tue, 12 Mar 2013 14:04:56 -0300
+Subject: [PATCH] Fixed Issue #1106
+
+backported by hasufell@gentoo.org for 2.1.1
+
+--- ninja_ide/gui/editor/highlighter.py
++++ ninja_ide/gui/editor/highlighter.py
+@@ -276,7 +276,7 @@
+ hls = []
+ block = self.currentBlock()
+ user_data = block.userData()
+- if user_data is None:
++ if user_data is None or not isinstance(user_data, SyntaxUserData):
+ user_data = SyntaxUserData(False)
+ user_data.clear_data()
+ block_number = block.blockNumber()
+@@ -321,7 +321,7 @@
+ hls = []
+ block = self.currentBlock()
+ user_data = block.userData()
+- if user_data is None:
++ if user_data is None or not isinstance(user_data, SyntaxUserData):
+ user_data = SyntaxUserData(False)
+ user_data.clear_data()
+ block_number = block.blockNumber()
diff --git a/dev-util/ninja-ide/ninja-ide-2.1.1-r4.ebuild b/dev-util/ninja-ide/ninja-ide-2.1.1-r4.ebuild
new file mode 100644
index 000000000000..bd787907b768
--- /dev/null
+++ b/dev-util/ninja-ide/ninja-ide-2.1.1-r4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja-ide/ninja-ide-2.1.1-r4.ebuild,v 1.1 2013/03/12 18:35:41 hasufell Exp $
+
+# XXX: tests
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit eutils gnome2-utils distutils-r1 vcs-snapshot
+
+DESCRIPTION="Ninja-IDE Is Not Just Another IDE"
+HOMEPAGE="http://www.ninja-ide.org"
+SRC_URI="https://github.com/ninja-ide/ninja-ide/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt4[webkit]
+ dev-python/simplejson
+ dev-python/pyinotify
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-lang.patch
+ "${FILESDIR}"/${P}-syntaxhighlighting.patch
+ )
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newicon -s 256 icon.png ${PN}.png
+ make_desktop_entry ${PN} "NINJA-IDE"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}