summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 02:36:47 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 02:36:47 +0000
commit209321e74778d21392fb3bd091da22330c3412de (patch)
treee8119344c97be3007e74c2dc24df6b595b8c3a92
parentChanged src_install () to src_install() (diff)
downloadgentoo-2-209321e74778d21392fb3bd091da22330c3412de.tar.gz
gentoo-2-209321e74778d21392fb3bd091da22330c3412de.tar.bz2
gentoo-2-209321e74778d21392fb3bd091da22330c3412de.zip
Changed econf||die to econf
-rw-r--r--app-crypt/gpgme/gpgme-0.3.13.ebuild7
-rw-r--r--app-crypt/gpgsm/gpgsm-0.3.10.ebuild8
-rw-r--r--app-crypt/gringotts/gringotts-0.5.9.ebuild7
-rw-r--r--app-crypt/gringotts/gringotts-0.6.1.ebuild8
-rw-r--r--app-crypt/gringotts/gringotts-0.6.2.ebuild8
-rw-r--r--app-crypt/mhash/mhash-0.8.16.ebuild12
-rw-r--r--app-crypt/mhash/mhash-0.8.9.ebuild12
7 files changed, 22 insertions, 40 deletions
diff --git a/app-crypt/gpgme/gpgme-0.3.13.ebuild b/app-crypt/gpgme/gpgme-0.3.13.ebuild
index 89d326b45ee5..7ef01dfb1168 100644
--- a/app-crypt/gpgme/gpgme-0.3.13.ebuild
+++ b/app-crypt/gpgme/gpgme-0.3.13.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-0.3.13.ebuild,v 1.1 2002/11/27 04:34:52 jrray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-0.3.13.ebuild,v 1.2 2002/11/30 02:32:51 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications."
SRC_URI="ftp://ftp.gnupg.org/gcrypt/gpgme/${P}.tar.gz"
HOMEPAGE="http://www.gnupg.org/gpgme.html"
@@ -25,11 +24,11 @@ src_compile() {
use doc \
&& myconf="${myconf} --enable-maintainer-mode"
- econf ${myconf} || die
+ econf ${myconf}
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README README-alpha THANKS TODO VERSION
}
diff --git a/app-crypt/gpgsm/gpgsm-0.3.10.ebuild b/app-crypt/gpgsm/gpgsm-0.3.10.ebuild
index aac12818130d..a455c777f8af 100644
--- a/app-crypt/gpgsm/gpgsm-0.3.10.ebuild
+++ b/app-crypt/gpgsm/gpgsm-0.3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgsm/gpgsm-0.3.10.ebuild,v 1.1 2002/11/01 10:29:43 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgsm/gpgsm-0.3.10.ebuild,v 1.2 2002/11/30 02:36:47 vapier Exp $
S="${WORKDIR}/newpg-${PV}"
DESCRIPTION="GnuPG Cryptographic message syntax and temporary project for gnupg extensions. Will be merged into gnupg for the gnupg-2.0 release."
@@ -24,13 +24,13 @@ RDEPEND="nls? ( sys-devel/gettext )"
src_compile(){
local myconf
use nls \
+ && myconf="--enable-nls" \
|| myconf="--disable-nls"
-
- econf ${myconf} || die
+ econf ${myconf}
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc ABOUT-NLS AUTHORS ChangeLog COPYING INSTALL NEWS README README-alpha THANKS TODO VERSION
}
diff --git a/app-crypt/gringotts/gringotts-0.5.9.ebuild b/app-crypt/gringotts/gringotts-0.5.9.ebuild
index 545bc8687d90..f745adebf4cb 100644
--- a/app-crypt/gringotts/gringotts-0.5.9.ebuild
+++ b/app-crypt/gringotts/gringotts-0.5.9.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/gringotts-0.5.9.ebuild,v 1.4 2002/10/04 03:57:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/gringotts-0.5.9.ebuild,v 1.5 2002/11/30 02:33:21 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Gringotts is a utility that allows you to jot down sensitive data"
SRC_URI="http://devel.pluto.linux.it/projects/Gringotts/current/${P}.tar.bz2"
HOMEPAGE="http://devel.pluto.linux.it/projects/Gringotts/"
@@ -17,14 +16,12 @@ RDEPEND=">=dev-libs/glib-2.0.3
>=x11-libs/gtk+-2.0.5
>=dev-libs/libmcrypt-2.4.19-r1
>=app-crypt/mhash-0.8.16"
-
DEPEND="${RDEPEND}
>=dev-util/intltool-0.17
>=dev-util/pkgconfig-0.12.0"
src_compile() {
- econf || die
-
+ econf
emake || die
}
diff --git a/app-crypt/gringotts/gringotts-0.6.1.ebuild b/app-crypt/gringotts/gringotts-0.6.1.ebuild
index 9bd7357004de..c80c7acf58f2 100644
--- a/app-crypt/gringotts/gringotts-0.6.1.ebuild
+++ b/app-crypt/gringotts/gringotts-0.6.1.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/gringotts-0.6.1.ebuild,v 1.2 2002/10/04 03:57:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/gringotts-0.6.1.ebuild,v 1.3 2002/11/30 02:33:50 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Gringotts is a utility that allows you to jot down sensitive data"
SRC_URI="http://devel.pluto.linux.it/projects/Gringotts/current/${P}.tar.bz2"
HOMEPAGE="http://devel.pluto.linux.it/projects/Gringotts/"
@@ -15,19 +14,16 @@ RDEPEND=">=dev-libs/glib-2.0.6-r1
>=x11-libs/gtk+-2.0.6-r1
>=dev-libs/libmcrypt-2.5.1
>=app-crypt/mhash-0.8.16"
-
DEPEND="${RDEPEND}
>=dev-util/intltool-0.17
>=dev-util/pkgconfig-0.12.0"
src_compile() {
- econf || die
-
+ econf
emake || die
}
src_install() {
make DESTDIR=${D} install || die
-
dodoc COPYING ChangeLog README AUTHORS
}
diff --git a/app-crypt/gringotts/gringotts-0.6.2.ebuild b/app-crypt/gringotts/gringotts-0.6.2.ebuild
index 1922677d829e..8a7bb1531b7a 100644
--- a/app-crypt/gringotts/gringotts-0.6.2.ebuild
+++ b/app-crypt/gringotts/gringotts-0.6.2.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/gringotts-0.6.2.ebuild,v 1.2 2002/10/04 03:57:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/gringotts-0.6.2.ebuild,v 1.3 2002/11/30 02:34:11 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Gringotts is a utility that allows you to jot down sensitive data"
SRC_URI="http://devel.pluto.linux.it/projects/Gringotts/current/${P}.tar.bz2"
HOMEPAGE="http://devel.pluto.linux.it/projects/Gringotts/"
@@ -15,19 +14,16 @@ RDEPEND=">=dev-libs/glib-2.0.6-r1
>=x11-libs/gtk+-2.0.6-r1
>=dev-libs/libmcrypt-2.5.1
>=app-crypt/mhash-0.8.16"
-
DEPEND="${RDEPEND}
>=dev-util/intltool-0.17
>=dev-util/pkgconfig-0.12.0"
src_compile() {
- econf || die
-
+ econf
emake || die
}
src_install() {
make DESTDIR=${D} install || die
-
dodoc COPYING ChangeLog README AUTHORS
}
diff --git a/app-crypt/mhash/mhash-0.8.16.ebuild b/app-crypt/mhash/mhash-0.8.16.ebuild
index 987acbe8f046..26d97292242b 100644
--- a/app-crypt/mhash/mhash-0.8.16.ebuild
+++ b/app-crypt/mhash/mhash-0.8.16.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.8.16.ebuild,v 1.8 2002/10/18 20:56:40 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.8.16.ebuild,v 1.9 2002/11/30 02:35:30 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="mhash is a library providing a uniform interface to a large number of hash algorithms."
SRC_URI="mirror://sourceforge/mhash/${P}.tar.gz"
HOMEPAGE="http://mhash.sourceforge.net/"
@@ -12,18 +11,17 @@ LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
DEPEND="virtual/glibc"
-
RDEPEND=""
src_compile() {
- econf || die
+ econf
emake || die
}
-src_install () {
+src_install() {
dodir /usr/{bin,include,lib}
-
- einstall || die
+
+ einstall
dodoc AUTHORS COPYING INSTALL NEWS README TODO
dodoc doc/*.txt doc/skid*
diff --git a/app-crypt/mhash/mhash-0.8.9.ebuild b/app-crypt/mhash/mhash-0.8.9.ebuild
index 176820a88b18..956b8ea3abb6 100644
--- a/app-crypt/mhash/mhash-0.8.9.ebuild
+++ b/app-crypt/mhash/mhash-0.8.9.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.8.9.ebuild,v 1.7 2002/10/04 03:58:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.8.9.ebuild,v 1.8 2002/11/30 02:35:53 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="mhash is a library providing a uniform interface to a large number of hash algorithms."
SRC_URI="http://mhash.sourceforge.net/dl/${P}.tar.gz"
HOMEPAGE="http://mhash.sourceforge.net/"
@@ -14,16 +13,13 @@ KEYWORDS="x86 sparc sparc64"
DEPEND="virtual/glibc"
src_compile() {
-
- econf || die
+ econf
emake || die
}
-src_install () {
-
+src_install() {
dodir /usr/{bin,include,lib}
-
- einstall || die
+ einstall
dodoc AUTHORS COPYING INSTALL NEWS README TODO
dodoc doc/*.txt doc/skid*