summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-01-27 10:13:21 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-01-27 10:13:21 +0000
commit213ae89fedc497a94634ce2b6b9b86e4a7eae32e (patch)
tree2fc875496d3bc3f98e66ea37ec98235f5d3c188e
parentTaking over maintainership (diff)
downloadgentoo-2-213ae89fedc497a94634ce2b6b9b86e4a7eae32e.tar.gz
gentoo-2-213ae89fedc497a94634ce2b6b9b86e4a7eae32e.tar.bz2
gentoo-2-213ae89fedc497a94634ce2b6b9b86e4a7eae32e.zip
Stable on x86. Shaped up DEPEND a bit.
(Portage version: 2.0.51-r15)
-rw-r--r--app-antivirus/clamav/ChangeLog6
-rw-r--r--app-antivirus/clamav/clamav-0.81.ebuild14
2 files changed, 15 insertions, 5 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 69762477dedd..a1d590c7ee80 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.36 2005/01/27 08:54:52 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.37 2005/01/27 10:13:21 ticho Exp $
+
+ 27 Jan 2005; Andrej Kacian <ticho@gentoo.org> clamav-0.81.ebuild:
+ Stable on x86, wrt #78656. Depend on fixed version of zlib (#61749) and
+ curl, according to configure.in.
*clamav-0.81 (27 Jan 2005)
diff --git a/app-antivirus/clamav/clamav-0.81.ebuild b/app-antivirus/clamav/clamav-0.81.ebuild
index 20b420c8e4d2..847771c4bf62 100644
--- a/app-antivirus/clamav/clamav-0.81.ebuild
+++ b/app-antivirus/clamav/clamav-0.81.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.81.ebuild,v 1.2 2005/01/27 08:54:52 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.81.ebuild,v 1.3 2005/01/27 10:13:21 ticho Exp $
inherit eutils flag-o-matic
@@ -10,11 +10,13 @@ SRC_URI="mirror://sourceforge/clamav/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~hppa ~alpha ~ppc64"
+KEYWORDS="x86 ~ppc ~sparc ~amd64 ~hppa ~alpha ~ppc64"
IUSE="crypt milter selinux"
DEPEND="virtual/libc
- crypt? ( >=dev-libs/gmp-4.1.2 )"
+ crypt? ( >=dev-libs/gmp-4.1.2 )
+ >=sys-libs/zlib-1.2.1-r3
+ >=net-misc/curl-7.10.0"
RDEPEND="selinux? ( sec-policy/selinux-clamav )"
PROVIDE="virtual/antivirus"
@@ -31,7 +33,11 @@ src_compile() {
local myconf
- use milter && myconf="--enable-milter"
+ # we depend on fixed zlib, so we can disable this check to prevent redundant
+ # warning (bug #61749)
+ myconf="${myconf} --disable-zlib-vcheck"
+
+ use milter && myconf="${myconf} --enable-milter"
econf ${myconf} --with-dbdir=/var/lib/clamav || die
emake || die
}