summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-08-23 10:03:13 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-08-23 10:03:13 +0000
commit224cc6722c6f7bad4f28b92da3bfc6284e608057 (patch)
tree1203a77296ed6b49285de427585e5ba242851c52
parentupdated SRC_URI (diff)
downloadgentoo-2-224cc6722c6f7bad4f28b92da3bfc6284e608057.tar.gz
gentoo-2-224cc6722c6f7bad4f28b92da3bfc6284e608057.tar.bz2
gentoo-2-224cc6722c6f7bad4f28b92da3bfc6284e608057.zip
updated to 0.6.6 and removed old SRC_URI
-rw-r--r--gnome-base/oaf/files/digest-oaf-0.6.61
-rw-r--r--gnome-base/oaf/oaf-0.6.6.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/gnome-base/oaf/files/digest-oaf-0.6.6 b/gnome-base/oaf/files/digest-oaf-0.6.6
new file mode 100644
index 000000000000..4a1e544c2232
--- /dev/null
+++ b/gnome-base/oaf/files/digest-oaf-0.6.6
@@ -0,0 +1 @@
+MD5 ae0150ee506d8b9a9f7b7edd7e1b87f4 oaf-0.6.6.tar.gz
diff --git a/gnome-base/oaf/oaf-0.6.6.ebuild b/gnome-base/oaf/oaf-0.6.6.ebuild
new file mode 100644
index 000000000000..5d2034e177f1
--- /dev/null
+++ b/gnome-base/oaf/oaf-0.6.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/oaf/oaf-0.6.6.ebuild,v 1.1 2001/08/23 10:03:13 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Object Activation Framework for GNOME"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
+
+DEPEND="virtual/glibc >=sys-devel/perl-5
+ >=dev-libs/popt-1.5
+ >=gnome-base/gnome-env-1.0
+ >=gnome-base/ORBit-0.5.8
+ >=gnome-base/libxml-1.8.11
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/popt-1.5
+ >=gnome-base/gnome-env-1.0
+ >=gnome-base/ORBit-0.5.8
+ >=gnome-base/libxml-1.8.11"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp -a configure configure.orig
+ sed -e "s:perl5\.00404:perl5.6.1:" configure.orig > configure
+}
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome --datadir=/opt/gnome/share ${myconf}
+ try pmake
+}
+
+src_install() {
+
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome \
+ datadir=${D}/opt/gnome/share install
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+pkg_postinst() {
+ ldconfig -r ${ROOT}
+}
+
+
+