summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-10-01 16:36:55 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-10-01 16:36:55 +0000
commit24444fb39eb5544dcdb99bc3556ddd73546504dc (patch)
tree2b090cca376ef015c8743b981ae00cf21909760a
parentVersion bumped. (diff)
downloadgentoo-2-24444fb39eb5544dcdb99bc3556ddd73546504dc.tar.gz
gentoo-2-24444fb39eb5544dcdb99bc3556ddd73546504dc.tar.bz2
gentoo-2-24444fb39eb5544dcdb99bc3556ddd73546504dc.zip
Initial import. Submitted by Mark Karpeles, bug #234264.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
-rw-r--r--dev-libs/libhid/ChangeLog10
-rw-r--r--dev-libs/libhid/Manifest4
-rw-r--r--dev-libs/libhid/libhid-0.2.16.ebuild51
-rw-r--r--dev-libs/libhid/metadata.xml15
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/libhid/ChangeLog b/dev-libs/libhid/ChangeLog
new file mode 100644
index 000000000000..8df97a17f273
--- /dev/null
+++ b/dev-libs/libhid/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/libhid
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhid/ChangeLog,v 1.1 2008/10/01 16:36:55 matsuu Exp $
+
+*libhid-0.2.16 (01 Oct 2008)
+
+ 01 Oct 2008; MATSUU Takuto <matsuu@gentoo.org> +metadata.xml,
+ +libhid-0.2.16.ebuild:
+ Initial import. Submitted by Mark Karpeles, bug #234264.
+
diff --git a/dev-libs/libhid/Manifest b/dev-libs/libhid/Manifest
new file mode 100644
index 000000000000..77ed3155d146
--- /dev/null
+++ b/dev-libs/libhid/Manifest
@@ -0,0 +1,4 @@
+DIST libhid-0.2.16.tar.gz 435245 RMD160 f61f016ae54bc5532202fd676d38d1f684e7ab8d SHA1 9a25fef674e8f20f97fea6700eb91c21ebbbcc02 SHA256 f6809ab3b9c907cbb05ceba9ee6ca23a705f85fd71588518e14b3a7d9f2550e5
+EBUILD libhid-0.2.16.ebuild 1383 RMD160 eb07fb2f719a16fca0d4f8695b56dce899dcea44 SHA1 43ad47e210cdca391cc1856800c0e7896517cd15 SHA256 88609f599844d721e640ec6a661a1277219fa4c0532cf47199ee53816e0f66c7
+MISC ChangeLog 295 RMD160 c9f96e18512fd5a6c98444e8d196595c87a84442 SHA1 0f215cf2aa46747171a850bfbff3fa9d5e2d9469 SHA256 63c797ec0b84dc287adf2587668bd96cc384496c298f0fb5179727c0e3fb2ec8
+MISC metadata.xml 550 RMD160 93eacd05e85031e424468b57585ce7bd20bcfb87 SHA1 57562a7ba3822914c992304f814fc5b0fe6142b0 SHA256 24d8e5690795c1a6842852b9ac2f9b33323805e26ac83a16c1571d016ace4fae
diff --git a/dev-libs/libhid/libhid-0.2.16.ebuild b/dev-libs/libhid/libhid-0.2.16.ebuild
new file mode 100644
index 000000000000..51c48a11552d
--- /dev/null
+++ b/dev-libs/libhid/libhid-0.2.16.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhid/libhid-0.2.16.ebuild,v 1.1 2008/10/01 16:36:55 matsuu Exp $
+
+DESCRIPTION="Provides a generic and flexible way to access and interact with USB HID devices"
+HOMEPAGE="http://libhid.alioth.debian.org/"
+SRC_URI="http://beta.magicaltux.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc python"
+
+RDEPEND="dev-libs/libusb"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ python? (
+ dev-lang/swig
+ >=dev-lang/python-2.1.0
+ )"
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} $(use_with doc doxygen)"
+ myconf="${myconf} $(use_enable debug)"
+ myconf="${myconf} $(use_enable python swig)"
+
+ if use python; then
+ # libhid includes its own python detection m4 from
+ # http://autoconf-archive.cryp.to/ac_python_devel.html
+ # As it seems to detect python in the wrong place, we'll force it by
+ # passing the right environnement variables, only if we have the python
+ # flag
+ PYTHON_LDFLAGS="$(python-config --ldflags)" econf ${myconf} || die
+ else
+ # avoid libhid running swig if it finds it automatically as long as the
+ # "python" use flag is not set
+ econf ${myconf} || die
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README README.licence TODO || die
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+}
diff --git a/dev-libs/libhid/metadata.xml b/dev-libs/libhid/metadata.xml
new file mode 100644
index 000000000000..8ec6a4501bb4
--- /dev/null
+++ b/dev-libs/libhid/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>matsuu@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+libhid provides a generic and flexible way to access and interact with USB
+HID devices, much like libusb does for plain USB devices. It is based on
+libusb, thus it requires no HID support in the kernel and provides means to
+take control over a device even if the kernel governs it.
+</longdescription>
+</pkgmetadata>
+