summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-07 23:19:44 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-07 23:19:44 +0000
commit2498fd68ec55b432ae2721cf11ed1812352f31ea (patch)
tree0a3f4aea68d0c4026f3bf613dd936616203d0589
parentold (Manifest recommit) (diff)
downloadgentoo-2-2498fd68ec55b432ae2721cf11ed1812352f31ea.tar.gz
gentoo-2-2498fd68ec55b432ae2721cf11ed1812352f31ea.tar.bz2
gentoo-2-2498fd68ec55b432ae2721cf11ed1812352f31ea.zip
move gcc-2.x patches into subdir
-rw-r--r--sys-devel/gcc/files/2.95.3/gcc-2.95.3-alpha.diff (renamed from sys-devel/gcc/files/gcc-2.95.3-alpha.diff)0
-rw-r--r--sys-devel/gcc/files/2.95.3/gcc-2.95.3-new-atexit.diff (renamed from sys-devel/gcc/files/gcc-2.95.3-new-atexit.diff)0
-rw-r--r--sys-devel/gcc/files/cc3
-rw-r--r--sys-devel/gcc/files/cpp3
-rw-r--r--sys-devel/gcc/files/gcc-2.95.3-atexit.diff52
-rw-r--r--sys-devel/gcc/files/gcc-2.95.3-destructor-atexit.diff123
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r8.ebuild6
7 files changed, 5 insertions, 182 deletions
diff --git a/sys-devel/gcc/files/gcc-2.95.3-alpha.diff b/sys-devel/gcc/files/2.95.3/gcc-2.95.3-alpha.diff
index f97fb94b90e4..f97fb94b90e4 100644
--- a/sys-devel/gcc/files/gcc-2.95.3-alpha.diff
+++ b/sys-devel/gcc/files/2.95.3/gcc-2.95.3-alpha.diff
diff --git a/sys-devel/gcc/files/gcc-2.95.3-new-atexit.diff b/sys-devel/gcc/files/2.95.3/gcc-2.95.3-new-atexit.diff
index af4de7908197..af4de7908197 100644
--- a/sys-devel/gcc/files/gcc-2.95.3-new-atexit.diff
+++ b/sys-devel/gcc/files/2.95.3/gcc-2.95.3-new-atexit.diff
diff --git a/sys-devel/gcc/files/cc b/sys-devel/gcc/files/cc
index c1c24e1bd131..3d3b37b53a1f 100644
--- a/sys-devel/gcc/files/cc
+++ b/sys-devel/gcc/files/cc
@@ -1,3 +1,2 @@
#!/bin/sh
-
-gcc "$@"
+exec gcc "$@"
diff --git a/sys-devel/gcc/files/cpp b/sys-devel/gcc/files/cpp
index e4a91acae67a..d933a186f9f4 100644
--- a/sys-devel/gcc/files/cpp
+++ b/sys-devel/gcc/files/cpp
@@ -1,3 +1,2 @@
#!/bin/sh
-
-cpp "$@"
+exec cpp "$@"
diff --git a/sys-devel/gcc/files/gcc-2.95.3-atexit.diff b/sys-devel/gcc/files/gcc-2.95.3-atexit.diff
deleted file mode 100644
index 573b3b38857b..000000000000
--- a/sys-devel/gcc/files/gcc-2.95.3-atexit.diff
+++ /dev/null
@@ -1,52 +0,0 @@
---- gcc/config/i386/linux.h.jj Mon Mar 12 11:45:15 2001
-+++ gcc/config/i386/linux.h Fri Mar 16 18:52:31 2001
-@@ -170,3 +170,21 @@ Boston, MA 02111-1307, USA. */
- } \
- } while (0)
- #endif
-+
-+#if defined(__PIC__) && defined (USE_GNULIBC_1)
-+/* This is a kludge. The i386 GNU/Linux dynamic linker needs ___brk_addr,
-+ __environ and atexit (). We have to make sure they are in the .dynsym
-+ section. We accomplish it by making a dummy call here. This
-+ code is never reached. */
-+
-+#define CRT_END_INIT_DUMMY \
-+ do \
-+ { \
-+ extern void *___brk_addr; \
-+ extern char **__environ; \
-+ \
-+ ___brk_addr = __environ; \
-+ atexit (0); \
-+ } \
-+ while (0)
-+#endif
-============================================================
-Index: gcc/crtstuff.c
---- gcc/crtstuff.c 1999/03/23 00:43:51 1.18
-+++ gcc/crtstuff.c 2001/03/19 10:21:44
-@@ -379,20 +379,8 @@
- FORCE_INIT_SECTION_ALIGN;
- #endif
- asm (TEXT_SECTION_ASM_OP);
--
--/* This is a kludge. The i386 GNU/Linux dynamic linker needs ___brk_addr,
-- __environ and atexit (). We have to make sure they are in the .dynsym
-- section. We accomplish it by making a dummy call here. This
-- code is never reached. */
--
--#if defined(__linux__) && defined(__PIC__) && defined(__i386__)
-- {
-- extern void *___brk_addr;
-- extern char **__environ;
--
-- ___brk_addr = __environ;
-- atexit ();
-- }
-+#ifdef CRT_END_INIT_DUMMY
-+ CRT_END_INIT_DUMMY;
- #endif
- }
-
-
diff --git a/sys-devel/gcc/files/gcc-2.95.3-destructor-atexit.diff b/sys-devel/gcc/files/gcc-2.95.3-destructor-atexit.diff
deleted file mode 100644
index d9cc67f1efaf..000000000000
--- a/sys-devel/gcc/files/gcc-2.95.3-destructor-atexit.diff
+++ /dev/null
@@ -1,123 +0,0 @@
---- gcc-2.95.x/gcc/config/alpha/crtbegin.asm.jj Wed Dec 16 22:00:53 1998
-+++ gcc-2.95.x/gcc/config/alpha/crtbegin.asm Wed Jun 13 12:41:28 2001
-@@ -97,6 +97,31 @@ __EH_FRAME_BEGIN__:
- # Support recursive calls to exit.
- $ptr: .quad __DTOR_LIST__
-
-+/* A globally unique widget for c++ local destructors to hang off.
-+
-+ This has a unique value in every dso; in the main program its
-+ value is zero. The object should be protected. This means the
-+ instance in any dso or the main program is not used in any other
-+ dso. The dynamic linker takes care of this. */
-+
-+ .global __dso_handle
-+ .type __dso_handle,@object
-+ .size __dso_handle,8
-+#ifdef SHARED
-+.section .data
-+ .align 3
-+__dso_handle:
-+ .quad __dso_handle
-+#else
-+.section .bss
-+ .align 3
-+__dso_handle:
-+ .zero 8
-+#endif
-+#ifdef HAVE_GAS_HIDDEN
-+ .hidden __dso_handle
-+#endif
-+
- .text
-
- .align 3
-============================================================
-Index: gcc/crtstuff.c
---- gcc-2.95.x/gcc/crtstuff.c 2001/04/03 10:34:32 1.18.4.1
-+++ gcc-2.95.x/gcc/crtstuff.c 2001/08/09 06:56:33
-@@ -55,6 +55,7 @@ Boston, MA 02111-1307, USA. */
- #include "defaults.h"
- #include <stddef.h>
- #include "frame.h"
-+#include "auto-host.h"
-
- /* We do not want to add the weak attribute to the declarations of these
- routines in frame.h because that will cause the definition of these
-@@ -134,7 +135,29 @@ typedef void (*func_ptr) (void);
- #ifdef INIT_SECTION_ASM_OP
-
- #ifdef OBJECT_FORMAT_ELF
-+/* Declare the __dso_handle variable. It should have a unique value
-+ in every shared-object; in a main program its value is zero. The
-+ object should in any case be protected. This means the instance
-+ in one DSO or the main program is not used in another object. The
-+ dynamic linker takes care of this. */
-+
-+/* XXX Ideally the following should be implemented using
-+ __attribute__ ((__visibility__ ("hidden")))
-+ but the __attribute__ support is not yet there. */
-+#ifdef HAVE_GAS_HIDDEN
-+asm (".hidden\t__dso_handle");
-+#endif
-+
-+#ifdef CRTSTUFFS_O
-+void *__dso_handle = &__dso_handle;
-+#else
-+void *__dso_handle = 0;
-+#endif
-
-+/* The __cxa_finalize function may not be available so we use only a
-+ weak declaration. */
-+extern void __cxa_finalize (void *) TARGET_ATTRIBUTE_WEAK;
-+
- /* Run all the global destructors on exit from the program. */
-
- /* Some systems place the number of pointers in the first word of the
-@@ -164,6 +187,11 @@ __do_global_dtors_aux (void)
-
- if (completed)
- return;
-+
-+#ifdef CRTSTUFFS_O
-+ if (__cxa_finalize)
-+ __cxa_finalize (__dso_handle);
-+#endif
-
- while (*p)
- {
---- gcc-2.95.x/gcc/configure.in.jj Wed Oct 13 09:58:02 1999
-+++ gcc-2.95.x/gcc/configure.in Wed Jun 13 12:44:34 2001
-@@ -4053,6 +4053,21 @@ EOF
- fi
- AC_MSG_RESULT($gcc_cv_as_subsections)
-
-+AC_MSG_CHECKING(assembler hidden support)
-+gcc_cv_as_hidden=
-+if test x$gcc_cv_as != x; then
-+ # Check if we have .hidden
-+ echo " .hidden foobar" > conftest.s
-+ echo "foobar:" >> conftest.s
-+ if $gcc_cv_as -o conftest.o conftest.s > /dev/null 2>&1; then
-+ AC_DEFINE(HAVE_GAS_HIDDEN, 1,
-+ [Define if your assembler supports .hidden.])
-+ gcc_cv_as_hidden="yes"
-+ fi
-+ rm -f conftest.s conftest.o conftest.nm1 conftest.nm2
-+fi
-+AC_MSG_RESULT($gcc_cv_as_hidden)
-+
- AC_MSG_CHECKING(assembler instructions)
- gcc_cv_as_instructions=
- if test x$gcc_cv_as != x; then
---- gcc-2.95.x/gcc/config.in.jj Mon Oct 25 10:02:08 1999
-+++ gcc-2.95.x/gcc/config.in Wed Jun 13 12:45:56 2001
-2 the beginning of your section */
- #undef HAVE_GAS_SUBSECTION_ORDERING
-
-+/* Define if your assembler supports .hidden. */
-+#undef HAVE_GAS_HIDDEN
-+
- /* Define if your assembler uses the old HImode fild and fist notation. */
- #undef HAVE_GAS_FILDS_FISTS
-
diff --git a/sys-devel/gcc/gcc-2.95.3-r8.ebuild b/sys-devel/gcc/gcc-2.95.3-r8.ebuild
index 1034d60e3889..83e766dffd50 100644
--- a/sys-devel/gcc/gcc-2.95.3-r8.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r8.ebuild,v 1.26 2004/04/22 02:38:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r8.ebuild,v 1.27 2004/06/07 23:19:44 vapier Exp $
inherit eutils flag-o-matic gcc
@@ -108,9 +108,9 @@ src_unpack() {
# Azarah - 30 Jun 2002
#
if ! use alpha ; then
- epatch ${FILESDIR}/${P}-new-atexit.diff
+ epatch ${FILESDIR}/${PV}/${P}-new-atexit.diff
else
- epatch ${FILESDIR}/${P}-alpha.diff
+ epatch ${FILESDIR}/${PV}/${P}-alpha.diff
fi
# Currently if any path is changed via the configure script, it breaks