summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-12-08 15:26:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-12-08 15:26:41 +0000
commit24df27475384caaf561efdbe40b26c50b6ccdf59 (patch)
tree5dbf8cdcc28f48e16cee6b8d76468da904617d57
parent[bump] virtual/perl-IO-Compress-2.58.0 (diff)
downloadgentoo-2-24df27475384caaf561efdbe40b26c50b6ccdf59.tar.gz
gentoo-2-24df27475384caaf561efdbe40b26c50b6ccdf59.tar.bz2
gentoo-2-24df27475384caaf561efdbe40b26c50b6ccdf59.zip
backport upstream patch to avoid underlinking, bug #443934
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
-rw-r--r--x11-libs/libva-intel-driver/ChangeLog6
-rw-r--r--x11-libs/libva-intel-driver/files/libm.patch27
-rw-r--r--x11-libs/libva-intel-driver/libva-intel-driver-1.0.19.ebuild5
3 files changed, 35 insertions, 3 deletions
diff --git a/x11-libs/libva-intel-driver/ChangeLog b/x11-libs/libva-intel-driver/ChangeLog
index cbcd5247ceab..bab14539bbb8 100644
--- a/x11-libs/libva-intel-driver/ChangeLog
+++ b/x11-libs/libva-intel-driver/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/libva-intel-driver
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva-intel-driver/ChangeLog,v 1.16 2012/11/26 23:54:10 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva-intel-driver/ChangeLog,v 1.17 2012/12/08 15:26:41 aballier Exp $
+
+ 08 Dec 2012; Alexis Ballier <aballier@gentoo.org>
+ libva-intel-driver-1.0.19.ebuild, +files/libm.patch:
+ backport upstream patch to avoid underlinking, bug #443934
26 Nov 2012; Alexis Ballier <aballier@gentoo.org>
-libva-intel-driver-1.0.15.ebuild, -libva-intel-driver-1.0.18-r1.ebuild:
diff --git a/x11-libs/libva-intel-driver/files/libm.patch b/x11-libs/libva-intel-driver/files/libm.patch
new file mode 100644
index 000000000000..0def10f585a8
--- /dev/null
+++ b/x11-libs/libva-intel-driver/files/libm.patch
@@ -0,0 +1,27 @@
+commit eb39abb70886d9277cf7d5114125cb7b22e7c362
+Author: Joe Konno <joe.konno@intel.com>
+Date: Tue Nov 20 07:42:27 2012 -0800
+
+ configure: add missing dependency to libm.
+
+ Build broke when trying to compile with expressive debug CFLAGS (-g3).
+ This was root-caused to the lack of the "-lm" linker flag. By adding a
+ simple autoconf check we ensure that libm is linked.
+
+ More specifically, recent VEBOX changes depend on cos() and sin() math
+ functions.
+
+ Signed-off-by: Joe Konno <joe.konno@intel.com>
+
+diff --git a/configure.ac b/configure.ac
+index 4427839..2655d74 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -64,6 +64,7 @@ AM_PROG_CC_C_O
+ AC_C_BIGENDIAN
+ AC_HEADER_STDC
+ AC_SYS_LARGEFILE
++AC_CHECK_LIB([m], [sin])
+
+ LIBVA_PACKAGE_VERSION=libva_package_version
+ AC_SUBST(LIBVA_PACKAGE_VERSION)
diff --git a/x11-libs/libva-intel-driver/libva-intel-driver-1.0.19.ebuild b/x11-libs/libva-intel-driver/libva-intel-driver-1.0.19.ebuild
index 0a95a216607a..cbc904ce960f 100644
--- a/x11-libs/libva-intel-driver/libva-intel-driver-1.0.19.ebuild
+++ b/x11-libs/libva-intel-driver/libva-intel-driver-1.0.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva-intel-driver/libva-intel-driver-1.0.19.ebuild,v 1.2 2012/11/21 18:16:19 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva-intel-driver/libva-intel-driver-1.0.19.ebuild,v 1.3 2012/12/08 15:26:41 aballier Exp $
EAPI="3"
@@ -11,7 +11,7 @@ if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
EGIT_REPO_URI="git://anongit.freedesktop.org/git/vaapi/intel-driver"
fi
-inherit autotools ${SCM} multilib
+inherit autotools ${SCM} multilib eutils
DESCRIPTION="HW video decode support for Intel integrated graphics"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
@@ -40,6 +40,7 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
+ epatch "${FILESDIR}/libm.patch"
eautoreconf
}