summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-07-11 16:07:24 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-07-11 16:07:24 +0000
commit26b2654f46606fa29e57061da83082bea55229e3 (patch)
tree46b1d80a353c242fae8f070e1f3ddd08e1f8e9d1
parentVersion bump. (diff)
downloadgentoo-2-26b2654f46606fa29e57061da83082bea55229e3.tar.gz
gentoo-2-26b2654f46606fa29e57061da83082bea55229e3.tar.bz2
gentoo-2-26b2654f46606fa29e57061da83082bea55229e3.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
-rw-r--r--dev-libs/libinput/ChangeLog7
-rw-r--r--dev-libs/libinput/libinput-0.19.0.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-libs/libinput/ChangeLog b/dev-libs/libinput/ChangeLog
index 7a2da7401771..620f686632c5 100644
--- a/dev-libs/libinput/ChangeLog
+++ b/dev-libs/libinput/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libinput
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/ChangeLog,v 1.23 2015/07/11 07:02:30 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/ChangeLog,v 1.24 2015/07/11 16:07:24 mrueg Exp $
+
+*libinput-0.19.0 (11 Jul 2015)
+
+ 11 Jul 2015; Manuel Rüger <mrueg@gentoo.org> +libinput-0.19.0.ebuild:
+ Version bump.
11 Jul 2015; Markus Meier <maekke@gentoo.org> libinput-0.9.0.ebuild:
arm stable, bug #553500
diff --git a/dev-libs/libinput/libinput-0.19.0.ebuild b/dev-libs/libinput/libinput-0.19.0.ebuild
new file mode 100644
index 000000000000..e979a5450b35
--- /dev/null
+++ b/dev-libs/libinput/libinput-0.19.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libinput/libinput-0.19.0.ebuild,v 1.1 2015/07/11 16:07:24 mrueg Exp $
+
+EAPI=5
+
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/libevdev-0.4
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_configure() {
+ # Doc handling in kinda strange but everything
+ # is available in the tarball already.
+ sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ # building documentation silently fails with graphviz syntax errors
+ econf \
+ --disable-documentation \
+ --disable-event-gui \
+ $(use_enable test tests) \
+ --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc -r doc/html
+ prune_libtool_files
+}