summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-11-09 12:41:41 +0000
committerMike Frysinger <vapier@gentoo.org>2009-11-09 12:41:41 +0000
commit28172e762c2fb7ace3ff22c280fc899932db4eeb (patch)
treea3dfef1146589db917d1c20a10dfa45f8d69f2e6
parentstable x86, security bug 280393 (diff)
downloadgentoo-2-28172e762c2fb7ace3ff22c280fc899932db4eeb.tar.gz
gentoo-2-28172e762c2fb7ace3ff22c280fc899932db4eeb.tar.bz2
gentoo-2-28172e762c2fb7ace3ff22c280fc899932db4eeb.zip
Version bump.
(Portage version: 2.2_rc49/cvs/Linux x86_64)
-rw-r--r--media-libs/sdl-mixer/ChangeLog7
-rw-r--r--media-libs/sdl-mixer/sdl-mixer-1.2.10.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/media-libs/sdl-mixer/ChangeLog b/media-libs/sdl-mixer/ChangeLog
index b2c0fd6763b8..cde6ad3ad390 100644
--- a/media-libs/sdl-mixer/ChangeLog
+++ b/media-libs/sdl-mixer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/sdl-mixer
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.62 2009/10/21 07:06:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.63 2009/11/09 12:41:41 vapier Exp $
+
+*sdl-mixer-1.2.10 (09 Nov 2009)
+
+ 09 Nov 2009; Mike Frysinger <vapier@gentoo.org> +sdl-mixer-1.2.10.ebuild:
+ Version bump.
*sdl-mixer-1.2.9 (21 Oct 2009)
diff --git a/media-libs/sdl-mixer/sdl-mixer-1.2.10.ebuild b/media-libs/sdl-mixer/sdl-mixer-1.2.10.ebuild
new file mode 100644
index 000000000000..8c02fe4c05ce
--- /dev/null
+++ b/media-libs/sdl-mixer/sdl-mixer-1.2.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/sdl-mixer-1.2.10.ebuild,v 1.1 2009/11/09 12:41:41 vapier Exp $
+
+EAPI=2
+
+inherit eutils
+
+MY_P=${P/sdl-/SDL_}
+DESCRIPTION="Simple Direct Media Layer Mixer Library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_mixer/"
+SRC_URI="http://www.libsdl.org/projects/SDL_mixer/release/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="flac mad +midi mikmod mp3 timidity vorbis +wav"
+
+DEPEND=">=media-libs/libsdl-1.2.10
+ flac? ( media-libs/flac )
+ timidity? ( media-sound/timidity++ )
+ mad? ( media-libs/libmad )
+ !mad? ( mp3? ( >=media-libs/smpeg-0.4.4-r1 ) )
+ vorbis? ( >=media-libs/libvorbis-1.0_beta4 media-libs/libogg )
+ mikmod? ( >=media-libs/libmikmod-3.1.10 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # this guy breaks SONAME by accident -- fix is in upstream
+ sed -i '/^BINARY_AGE=/s:=.*:=10:' configure
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable wav music-wave) \
+ $(use_enable midi music-midi) \
+ $(use_enable timidity music-timidity-midi) \
+ $(use_enable mikmod music-mod) \
+ $(use_enable vorbis music-ogg) \
+ $(use_enable flac music-flac) \
+ $(use mad && echo --disable-music-mp3 || use_enable mp3 music-mp3) \
+ $(use_enable mad music-mp3-mad-gpl) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGES README
+}