summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-01-18 01:34:13 +0000
committerTod Neidt <tod@gentoo.org>2002-01-18 01:34:13 +0000
commit28579046348aeff3531a8506a9d64791862f1059 (patch)
tree71eddac6103ac1b9ae3c91b37a9fa34ab5340a28
parentAdded the dev version. It seems to be working for me, so I'm not going (diff)
downloadgentoo-2-28579046348aeff3531a8506a9d64791862f1059.tar.gz
gentoo-2-28579046348aeff3531a8506a9d64791862f1059.tar.bz2
gentoo-2-28579046348aeff3531a8506a9d64791862f1059.zip
Initial commit for texi2html and myself (Hi Mom!). texi2html compliments texi2pdf and texi2dvi from the tetex package. texi2html is also rumored to be better than 'makeinfo --html'.
-rw-r--r--app-text/texi2html/texi2html-1.64.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/texi2html/texi2html-1.64.ebuild b/app-text/texi2html/texi2html-1.64.ebuild
new file mode 100644
index 000000000000..2d5de3a5984b
--- /dev/null
+++ b/app-text/texi2html/texi2html-1.64.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tod Neidt <tod@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/texi2html/texi2html-1.64.ebuild,v 1.1 2002/01/18 01:34:13 tod Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Perl script that converts Texinfo to HTML"
+
+SRC_URI="http://www.mathematik.uni-kl.de/~obachman/Texi2html/Distrib/${P}.tar.gz"
+
+HOMEPAGE="http://www.mathematik.uni-kl.de/~obachman/Texi2html/"
+
+DEPEND="virtual/glibc
+ >=sys-devel/perl-5.6.1"
+
+src_compile() {
+
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+
+}
+
+src_install () {
+
+ #yes, htmldir line is correct, no ${D}
+ make DESTDIR=${D} \
+ htmldir=/usr/share/doc/${PF}/html \
+ install || die "Installation Failed"
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL INTRODUCTION NEWS \
+ README TODO
+
+}