summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2007-12-14 15:58:10 +0000
committerJustin Bronder <jsbronder@gentoo.org>2007-12-14 15:58:10 +0000
commit294cddcb3568cd5e32c4f1ba5f9766294a79780d (patch)
treedb968372dbc2ed484cdc58419803010218fc26b7
parentUse r1 version of patches. (diff)
downloadgentoo-2-294cddcb3568cd5e32c4f1ba5f9766294a79780d.tar.gz
gentoo-2-294cddcb3568cd5e32c4f1ba5f9766294a79780d.tar.bz2
gentoo-2-294cddcb3568cd5e32c4f1ba5f9766294a79780d.zip
sys-cluster/openmpi-1.2.4-r1, use f90-size=medium when gfortran is not in use. Bug #166787.
(Portage version: 2.1.3.19)
-rw-r--r--sys-cluster/openmpi/files/digest-openmpi-1.2.4-r13
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.4-r1.ebuild91
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.4.ebuild5
3 files changed, 98 insertions, 1 deletions
diff --git a/sys-cluster/openmpi/files/digest-openmpi-1.2.4-r1 b/sys-cluster/openmpi/files/digest-openmpi-1.2.4-r1
new file mode 100644
index 000000000000..f19425117f77
--- /dev/null
+++ b/sys-cluster/openmpi/files/digest-openmpi-1.2.4-r1
@@ -0,0 +1,3 @@
+MD5 311b38c597f54d8d6b277225ef458666 openmpi-1.2.4.tar.bz2 3541543
+RMD160 3eea820f19fcc69b4c1813331aa43171549aad25 openmpi-1.2.4.tar.bz2 3541543
+SHA256 594a3a0af69cc7895e0d8f9add776a44bf9ed389794323d0b1b45e181a97e538 openmpi-1.2.4.tar.bz2 3541543
diff --git a/sys-cluster/openmpi/openmpi-1.2.4-r1.ebuild b/sys-cluster/openmpi/openmpi-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..41d3cc19a277
--- /dev/null
+++ b/sys-cluster/openmpi/openmpi-1.2.4-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.4-r1.ebuild,v 1.1 2007/12/14 15:58:10 jsbronder Exp $
+
+inherit eutils multilib flag-o-matic toolchain-funcs fortran
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A high-performance message passing library (MPI)"
+HOMEPAGE="http://www.open-mpi.org"
+SRC_URI="http://www.open-mpi.org/software/ompi/v1.2/downloads/${MY_P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pbs fortran nocxx threads romio slurm heterogeneous smp ipv6"
+RDEPEND="pbs? ( sys-cluster/torque )
+ !sys-cluster/mpich
+ !sys-cluster/lam-mpi
+ !sys-cluster/mpich2"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if use threads; then
+ ewarn
+ ewarn "WARNING: use of threads is still disabled by default in"
+ ewarn "upstream builds."
+ ewarn "You may stop now and set USE=-threads"
+ ewarn
+ epause 5
+ fi
+
+ elog
+ elog "OpenMPI has an overwhelming count of configuration options."
+ elog "Don't forget the EXTRA_ECONF environment variable can let you"
+ elog "specify configure options if you find them necessary."
+ elog
+
+ if use fortran; then
+ FORTRAN="g77 gfortran ifc"
+ fortran_pkg_setup
+ fi
+}
+
+src_compile() {
+ local myconf="
+ --sysconfdir=/etc/${PN}
+ --without-xgrid
+ --enable-pretty-print-stacktrace
+ --enable-orterun-prefix-by-default"
+
+ if use threads; then
+ myconf="${myconf}
+ --enable-mpi-threads
+ --with-progress-threads
+ --with-threads=posix"
+ fi
+
+ if use fortran; then
+ if [[ "${FORTRANC}" = "g77" ]]; then
+ myconf="${myconf} --disable-mpi-f90"
+ elif [[ "${FORTRANC}" = "gfortran" ]]; then
+ # Because that's just a pain in the butt.
+ myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
+ elif [[ "${FORTRANC}" = if* ]]; then
+ # Enabled here as gfortran compile times are huge with this enabled.
+ myconf="${myconf} --with-mpi-f90-size=medium"
+ fi
+ else
+ myconf="${myconf}
+ --disable-mpi-f90
+ --disable-mpi-f77"
+ fi
+
+ econf ${myconf} \
+ $(use_enable !nocxx mpi-cxx) \
+ $(use_enable romio romio-io) \
+ $(use_enable smp smp-locks) \
+ $(use_enable heterogeneous) \
+ $(use_with pbs tm /usr/$(get_libdir)/pbs) \
+ $(use_with slurm) \
+ $(use_enable ipv6) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README AUTHORS NEWS VERSION
+}
diff --git a/sys-cluster/openmpi/openmpi-1.2.4.ebuild b/sys-cluster/openmpi/openmpi-1.2.4.ebuild
index 941ee0c71e7d..2d41ee0e3a6e 100644
--- a/sys-cluster/openmpi/openmpi-1.2.4.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.4.ebuild,v 1.2 2007/12/13 22:39:53 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.4.ebuild,v 1.3 2007/12/14 15:58:10 jsbronder Exp $
inherit eutils multilib flag-o-matic toolchain-funcs fortran
@@ -62,6 +62,9 @@ src_compile() {
elif [[ "${FORTRANC}" = "gfortran" ]]; then
# Because that's just a pain in the butt.
myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
+ elif [[ "${FORTRANC}" = if* ]]; then
+ # Enabled here as gfortran compile times are huge with this enabled.
+ myconf="${myconf} --with-mpi-f90-size=medium"
fi
else
myconf="${myconf}