summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-02-24 17:20:35 +0000
committerMike Frysinger <vapier@gentoo.org>2012-02-24 17:20:35 +0000
commit2a9230f7b2f7493ff34898eacd0c1f68716d1f6a (patch)
tree12b8c408b07f144b0dc53c8db802704ec167493c
parentVersion bump #405331 by teidakankan. (diff)
downloadgentoo-2-2a9230f7b2f7493ff34898eacd0c1f68716d1f6a.tar.gz
gentoo-2-2a9230f7b2f7493ff34898eacd0c1f68716d1f6a.tar.bz2
gentoo-2-2a9230f7b2f7493ff34898eacd0c1f68716d1f6a.zip
Version bump #405331 by teidakankan.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
-rw-r--r--sys-fs/e2fsprogs/ChangeLog9
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.42.1.ebuild157
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.42.1-libext2fs-config.patch29
-rw-r--r--sys-fs/e2fsprogs/files/e2fsprogs-1.42.1-libext2fs-gettimeofday.patch34
4 files changed, 228 insertions, 1 deletions
diff --git a/sys-fs/e2fsprogs/ChangeLog b/sys-fs/e2fsprogs/ChangeLog
index 86e38bac4ab2..bcd1f35149d6 100644
--- a/sys-fs/e2fsprogs/ChangeLog
+++ b/sys-fs/e2fsprogs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/e2fsprogs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.242 2012/02/22 18:40:56 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.243 2012/02/24 17:20:34 vapier Exp $
+
+*e2fsprogs-1.42.1 (24 Feb 2012)
+
+ 24 Feb 2012; Mike Frysinger <vapier@gentoo.org> +e2fsprogs-1.42.1.ebuild,
+ +files/e2fsprogs-1.42.1-libext2fs-config.patch,
+ +files/e2fsprogs-1.42.1-libext2fs-gettimeofday.patch:
+ Version bump #405331 by teidakankan.
22 Feb 2012; Brent Baude <ranger@gentoo.org> e2fsprogs-1.42.ebuild:
Marking e2fsprogs-1.42 ppc for bug 403405
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.42.1.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.42.1.ebuild
new file mode 100644
index 000000000000..d451d7b49962
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.42.1.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.42.1.ebuild,v 1.1 2012/02/24 17:20:34 vapier Exp $
+
+case ${PV} in
+*_pre*) UP_PV="${PV%_pre*}-WIP-${PV#*_pre}" ;;
+*) UP_PV=${PV} ;;
+esac
+
+EAPI="3"
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Standard EXT2/EXT3/EXT4 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/e2fsprogs/${PN}-${UP_PV}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 -x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
+IUSE="nls static-libs elibc_FreeBSD"
+
+RDEPEND="~sys-libs/${PN}-libs-${PV}
+ >=sys-apps/util-linux-2.16
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig
+ sys-apps/texinfo"
+
+S=${WORKDIR}/${P%_pre*}
+
+pkg_setup() {
+ if [[ ! -e ${EROOT}/etc/mtab ]] ; then
+ # add some crap to deal with missing /etc/mtab #217719
+ ewarn "No /etc/mtab file, creating one temporarily"
+ echo "${PN} crap for src_test" > "${EROOT}"/etc/mtab
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
+ epatch "${FILESDIR}"/${PN}-1.41.8-makefile.patch
+ epatch "${FILESDIR}"/${PN}-1.40-fbsd.patch
+ epatch "${FILESDIR}"/${PN}-1.42-no-quota.patch
+ epatch "${FILESDIR}"/${PN}-1.42.1-libext2fs-gettimeofday.patch
+ epatch "${FILESDIR}"/${PN}-1.42.1-libext2fs-config.patch
+ # use symlinks rather than hardlinks
+ sed -i \
+ -e 's:$(LN) -f $(DESTDIR).*/:$(LN_S) -f :' \
+ {e2fsck,misc}/Makefile.in || die
+ epatch "${FILESDIR}"/${PN}-1.41.12-darwin-makefile.patch
+ if [[ ${CHOST} == *-mint* ]] ; then
+ epatch "${FILESDIR}"/${PN}-1.41-mint.patch
+ epatch "${FILESDIR}"/${PN}-1.41.12-mint-blkid.patch
+ fi
+ # blargh ... trick e2fsprogs into using e2fsprogs-libs
+ rm -rf doc
+ sed -i -r \
+ -e 's:@LIBINTL@:@LTLIBINTL@:' \
+ -e '/^LIB(COM_ERR|SS)/s:[$][(]LIB[)]/lib([^@]*)@LIB_EXT@:-l\1:' \
+ -e '/^DEPLIB(COM_ERR|SS)/s:=.*:=:' \
+ MCONFIG.in || die "muck libs" #122368
+ sed -i -r \
+ -e '/^LIB_SUBDIRS/s:lib/(et|ss)::g' \
+ Makefile.in || die "remove subdirs"
+
+ # Avoid rebuild
+ touch lib/ss/ss_err.h
+}
+
+src_configure() {
+ # Keep the package from doing silly things #261411
+ export VARTEXFONTS=${T}/fonts
+
+ # needs open64() prototypes and friends
+ append-cppflags -D_GNU_SOURCE
+
+ # We want to use the "bsd" libraries while building on Darwin, but while
+ # building on other Gentoo/*BSD we prefer elf-naming scheme.
+ local libtype
+ case ${CHOST} in
+ *-darwin*) libtype=--enable-bsd-shlibs ;;
+ *-mint*) libtype= ;;
+ *) libtype=--enable-elf-shlibs ;;
+ esac
+
+ ac_cv_path_LDCONFIG=: \
+ QUOTA_CMT='#' \
+ econf \
+ --with-root-prefix="${EPREFIX}/" \
+ ${libtype} \
+ $(tc-has-tls || echo --disable-tls) \
+ --without-included-gettext \
+ $(use_enable nls) \
+ --disable-libblkid \
+ --disable-libuuid \
+ --disable-quota \
+ --disable-fsck \
+ --disable-uuidd
+ if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
+ eerror "INTL sanity check failed, aborting build."
+ eerror "Please post your ${S}/config.log file as an"
+ eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
+ die "Preventing included intl cruft from building"
+ fi
+}
+
+src_compile() {
+ emake COMPILE_ET=compile_et MK_CMDS=mk_cmds || die
+
+ # Build the FreeBSD helper
+ if use elibc_FreeBSD ; then
+ cp "${FILESDIR}"/fsck_ext2fs.c .
+ emake fsck_ext2fs || die
+ fi
+}
+
+pkg_preinst() {
+ if [[ -r ${EROOT}/etc/mtab ]] ; then
+ if [[ $(<"${EROOT}"/etc/mtab) == "${PN} crap for src_test" ]] ; then
+ rm -f "${EROOT}"/etc/mtab
+ fi
+ fi
+}
+
+src_install() {
+ # need to set root_libdir= manually as any --libdir options in the
+ # econf above (i.e. multilib) will screw up the default #276465
+ emake \
+ STRIP=: \
+ root_libdir="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" \
+ install install-libs || die
+ dodoc README RELEASE-NOTES
+
+ insinto /etc
+ doins "${FILESDIR}"/e2fsck.conf || die
+
+ # Move shared libraries to /lib/, install static libraries to
+ # /usr/lib/, and install linker scripts to /usr/lib/.
+ gen_usr_ldscript -a e2p ext2fs
+ # configure doesn't have an option to disable static libs :/
+ find "${D}" -name '*.a' -delete
+
+ if use elibc_FreeBSD ; then
+ # Install helpers for us
+ into /
+ dosbin "${S}"/fsck_ext2fs || die
+ doman "${FILESDIR}"/fsck_ext2fs.8 || die
+
+ # filefrag is linux only
+ rm \
+ "${ED}"/usr/sbin/filefrag \
+ "${ED}"/usr/share/man/man8/filefrag.8 || die
+ fi
+}
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.42.1-libext2fs-config.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.42.1-libext2fs-config.patch
new file mode 100644
index 000000000000..2afc83263270
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/e2fsprogs-1.42.1-libext2fs-config.patch
@@ -0,0 +1,29 @@
+From c699110b4b08e7fdee24d2b895403f15dad1502c Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Fri, 24 Feb 2012 12:08:43 -0500
+Subject: [PATCH] libext2fs: include config.h for HAVE_xxx defines
+
+We check HAVE_UNISTD_H but haven't included config.h yet, so we end up
+hitting warnings about missing prototypes for close/read/etc... funcs.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ lib/ext2fs/mmp.c | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/lib/ext2fs/mmp.c b/lib/ext2fs/mmp.c
+index b27d9a4..49a11da 100644
+--- a/lib/ext2fs/mmp.c
++++ b/lib/ext2fs/mmp.c
+@@ -13,6 +13,8 @@
+ #define _GNU_SOURCE
+ #endif
+
++#include "config.h"
++
+ #if HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
+--
+1.7.8.4
+
diff --git a/sys-fs/e2fsprogs/files/e2fsprogs-1.42.1-libext2fs-gettimeofday.patch b/sys-fs/e2fsprogs/files/e2fsprogs-1.42.1-libext2fs-gettimeofday.patch
new file mode 100644
index 000000000000..4eeb0b578858
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/e2fsprogs-1.42.1-libext2fs-gettimeofday.patch
@@ -0,0 +1,34 @@
+From 19a60067bedc4083af035fc2ef531d7114c5eed4 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Fri, 24 Feb 2012 12:07:21 -0500
+Subject: [PATCH] libext2fs: include sys/time.h for gettimeofday()
+
+Building on my glibc-2.15 system hits a warning:
+ gen_bitmap64.c: In function 'ext2fs_alloc_generic_bmap':
+ gen_bitmap64.c:127:2: warning: implicit declaration of function
+ 'gettimeofday' [-Wimplicit-function-declaration]
+
+Include sys/time.h if it's available for the prototype.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ lib/ext2fs/gen_bitmap64.c | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/lib/ext2fs/gen_bitmap64.c b/lib/ext2fs/gen_bitmap64.c
+index bf1a76b..fa8d7b7 100644
+--- a/lib/ext2fs/gen_bitmap64.c
++++ b/lib/ext2fs/gen_bitmap64.c
+@@ -25,6 +25,9 @@
+ #if HAVE_SYS_TYPES_H
+ #include <sys/types.h>
+ #endif
++#ifdef HAVE_SYS_TIME_H
++#include <sys/time.h>
++#endif
+
+ #include "ext2_fs.h"
+ #include "ext2fsP.h"
+--
+1.7.8.4
+