summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-08-30 18:57:50 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-08-30 18:57:50 +0000
commit2aafb2086aa331959139657fe30996a42791e94b (patch)
tree3bc16e2375e62c932a147225a2272db94aca705f
parentVersion bump (diff)
downloadgentoo-2-2aafb2086aa331959139657fe30996a42791e94b.tar.gz
gentoo-2-2aafb2086aa331959139657fe30996a42791e94b.tar.bz2
gentoo-2-2aafb2086aa331959139657fe30996a42791e94b.zip
GCC 4 patch, thanks to Dave Baker.
(Portage version: 2.1.1_rc1-r2)
-rw-r--r--media-libs/libofa/ChangeLog6
-rw-r--r--media-libs/libofa/files/libofa-0.9.3-gcc-4.patch39
-rw-r--r--media-libs/libofa/libofa-0.9.3.ebuild12
3 files changed, 54 insertions, 3 deletions
diff --git a/media-libs/libofa/ChangeLog b/media-libs/libofa/ChangeLog
index 8b2fd2e524b5..d2083767a3a5 100644
--- a/media-libs/libofa/ChangeLog
+++ b/media-libs/libofa/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libofa
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libofa/ChangeLog,v 1.2 2006/08/27 14:39:47 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libofa/ChangeLog,v 1.3 2006/08/30 18:57:50 carlo Exp $
+
+ 30 Aug 2006; Carsten Lohrke <carlo@gentoo.org>
+ +files/libofa-0.9.3-gcc-4.patch, libofa-0.9.3.ebuild:
+ GCC 4 patch, thanks to Dave Baker.
27 Aug 2006; Carsten Lohrke <carlo@gentoo.org> libofa-0.9.3.ebuild:
Fix whitespace.
diff --git a/media-libs/libofa/files/libofa-0.9.3-gcc-4.patch b/media-libs/libofa/files/libofa-0.9.3-gcc-4.patch
new file mode 100644
index 000000000000..d1059bafa55f
--- /dev/null
+++ b/media-libs/libofa/files/libofa-0.9.3-gcc-4.patch
@@ -0,0 +1,39 @@
+--- lib/JAMA/tnt_math_utils.h.orig 2006-06-17 01:46:22.000000000 +0300
++++ lib/JAMA/tnt_math_utils.h 2006-06-17 01:47:02.000000000 +0300
+@@ -20,11 +20,20 @@
+ namespace TNT
+ {
+ /**
++ @returns the absolute value of a real (no-complex) scalar.
++*/
++template <class Real>
++Real abs(const Real &a)
++{
++ return (a > 0 ? a : -a);
++}
++/**
+ @returns hypotenuse of real (non-complex) scalars a and b by
+ avoiding underflow/overflow
+ using (a * sqrt( 1 + (b/a) * (b/a))), rather than
+ sqrt(a*a + b*b).
+ */
++
+ template <class Real>
+ Real hypot(const Real &a, const Real &b)
+ {
+@@ -56,15 +65,6 @@
+ }
+ */
+
+-/**
+- @returns the absolute value of a real (no-complex) scalar.
+-*/
+-template <class Real>
+-Real abs(const Real &a)
+-{
+- return (a > 0 ? a : -a);
+-}
+-
+ }
+ #endif
+ /* MATH_UTILS_H */
diff --git a/media-libs/libofa/libofa-0.9.3.ebuild b/media-libs/libofa/libofa-0.9.3.ebuild
index 72cedee298b6..bc5b634ddc51 100644
--- a/media-libs/libofa/libofa-0.9.3.ebuild
+++ b/media-libs/libofa/libofa-0.9.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 2006-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libofa/libofa-0.9.3.ebuild,v 1.2 2006/08/27 14:39:47 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libofa/libofa-0.9.3.ebuild,v 1.3 2006/08/30 18:57:50 carlo Exp $
+
+inherit eutils
DESCRIPTION="Open Fingerprint Architecture"
HOMEPAGE="http://www.musicdns.org/"
@@ -22,8 +24,14 @@ pkg_setup() {
die "Correct your C[XX]FLAGS. Using -ffast-math is unsafe and not supported."
}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/libofa-0.9.3-gcc-4.patch
+}
+
src_compile() {
- econf || die "configure failed"
+ econf || die "configure failed"
emake || die "emake failed"
}
src_install() {