summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-20 13:20:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-20 13:20:36 +0000
commit2c98c7b8fffc01e246d68fa908b9a58192f8b6bb (patch)
tree41d9b807b45b9b462ee455837733f2588b945824
parentWhitespace. (diff)
downloadgentoo-2-2c98c7b8fffc01e246d68fa908b9a58192f8b6bb.tar.gz
gentoo-2-2c98c7b8fffc01e246d68fa908b9a58192f8b6bb.tar.bz2
gentoo-2-2c98c7b8fffc01e246d68fa908b9a58192f8b6bb.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--dev-lang/yasm/ChangeLog8
-rw-r--r--dev-lang/yasm/files/yasm-1.1.0-skip_cython_check.patch17
-rw-r--r--dev-lang/yasm/yasm-1.1.0.ebuild46
3 files changed, 70 insertions, 1 deletions
diff --git a/dev-lang/yasm/ChangeLog b/dev-lang/yasm/ChangeLog
index b08a3da5dc3f..1a1c307aff2a 100644
--- a/dev-lang/yasm/ChangeLog
+++ b/dev-lang/yasm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/yasm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.40 2010/07/12 18:01:12 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.41 2010/08/20 13:20:35 ssuominen Exp $
+
+*yasm-1.1.0 (20 Aug 2010)
+
+ 20 Aug 2010; Samuli Suominen <ssuominen@gentoo.org> +yasm-1.1.0.ebuild,
+ +files/yasm-1.1.0-skip_cython_check.patch:
+ Version bump.
12 Jul 2010; Christian Faulhammer <fauli@gentoo.org> yasm-1.0.1.ebuild:
stable x86, bug 325273
diff --git a/dev-lang/yasm/files/yasm-1.1.0-skip_cython_check.patch b/dev-lang/yasm/files/yasm-1.1.0-skip_cython_check.patch
new file mode 100644
index 000000000000..c4e5b3687d22
--- /dev/null
+++ b/dev-lang/yasm/files/yasm-1.1.0-skip_cython_check.patch
@@ -0,0 +1,17 @@
+Skip semi-broken Cython version check because it barfs on 0.13_beta0.
+
+--- configure.ac
++++ configure.ac
+@@ -285,11 +285,7 @@
+ AC_MSG_NOTICE([Checking to see if we can build Python bindings])
+ have_python_bindings=no
+ if test x$have_python = xyes; then
+- AC_MSG_CHECKING([for Cython >= 0.11.3])
+- CYTHON_CHECK_VERSION(0.11.3, [AC_MSG_RESULT(yes)
+- have_cython=yes],
+- [AC_MSG_RESULT(no)
+- have_cython=no])
++ have_cython=yes
+
+ AM_CHECK_PYTHON_HEADERS(have_python_headers=yes,have_python_headers=no)
+
diff --git a/dev-lang/yasm/yasm-1.1.0.ebuild b/dev-lang/yasm/yasm-1.1.0.ebuild
new file mode 100644
index 000000000000..903fb01dcf0c
--- /dev/null
+++ b/dev-lang/yasm/yasm-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-1.1.0.ebuild,v 1.1 2010/08/20 13:20:35 ssuominen Exp $
+
+EAPI=2
+PYTHON_DEPEND="python? 2:2.4"
+
+inherit autotools eutils python
+
+DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
+HOMEPAGE="http://www.tortall.net/projects/yasm/"
+SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
+
+LICENSE="Artistic BSD GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="nls python"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )
+ python? ( >=dev-python/cython-0.11.3 )"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.0-skip_cython_check.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable python python-bindings) \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS
+}