summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-08-28 20:39:08 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-08-28 20:39:08 +0000
commit2cb6e79461a6215e04bfc7b22a33a7637a3140f1 (patch)
tree960f9290fa47db664e9a3085e561053b990472eb
parentadd description of opengl USE flag (diff)
downloadgentoo-2-2cb6e79461a6215e04bfc7b22a33a7637a3140f1.tar.gz
gentoo-2-2cb6e79461a6215e04bfc7b22a33a7637a3140f1.tar.bz2
gentoo-2-2cb6e79461a6215e04bfc7b22a33a7637a3140f1.zip
Added an upstream patch to fix compilation with openexr-1.6.0 as per bug 189798.
(Portage version: 2.1.3.7)
-rw-r--r--kde-base/kdegraphics/ChangeLog8
-rw-r--r--kde-base/kdegraphics/files/kdegraphics-kfile-plugins-3.5.7-openexr-1.6.0.patch25
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.5.7-r1.ebuild5
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.5.7-r2.ebuild5
4 files changed, 38 insertions, 5 deletions
diff --git a/kde-base/kdegraphics/ChangeLog b/kde-base/kdegraphics/ChangeLog
index 9a3475d196eb..61a411ecbcef 100644
--- a/kde-base/kdegraphics/ChangeLog
+++ b/kde-base/kdegraphics/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdegraphics
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/ChangeLog,v 1.314 2007/08/23 17:40:16 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/ChangeLog,v 1.315 2007/08/28 20:39:08 philantrop Exp $
+
+ 28 Aug 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/kdegraphics-kfile-plugins-3.5.7-openexr-1.6.0.patch,
+ kdegraphics-3.5.7-r1.ebuild, kdegraphics-3.5.7-r2.ebuild:
+ Added an upstream patch to fix compilation with openexr-1.6.0 as per bug
+ 189798.
*kdegraphics-3.5.7-r2 (23 Aug 2007)
diff --git a/kde-base/kdegraphics/files/kdegraphics-kfile-plugins-3.5.7-openexr-1.6.0.patch b/kde-base/kdegraphics/files/kdegraphics-kfile-plugins-3.5.7-openexr-1.6.0.patch
new file mode 100644
index 000000000000..de82dba73000
--- /dev/null
+++ b/kde-base/kdegraphics/files/kdegraphics-kfile-plugins-3.5.7-openexr-1.6.0.patch
@@ -0,0 +1,25 @@
+--- kfile-plugins/exr/kfile_exr.cpp
++++ kfile-plugins/exr/kfile_exr.cpp
+@@ -32,6 +32,7 @@
+ #include <ImfVecAttribute.h>
+ #include <ImfPreviewImage.h>
+ #include <ImfVersion.h>
++#include <ImfCRgbaFile.h>
+
+ #include <iostream>
+
+@@ -226,7 +227,14 @@
+ qcapDateString.setLength(capDateString.size());
+ appendItem( stdgroup, "Capture Date", qcapDateString );
+ }
++ // This define was introduced in EXR 1.6.0
++#ifndef IMF_B44_COMPRESSION
++ // This is the 1.4 and earlier version
+ if ( hasutcOffset(h) ) {
++#else
++ // This is the 1.6.0 and later version
++ if ( hasUtcOffset(h) ) {
++#endif
+ QString UTCOffset;
+ if (utcOffset(h)>0.0) {
+ UTCOffset.append(QString("%1").arg(utcOffset(h)/3600, 0, 'f', 1));
diff --git a/kde-base/kdegraphics/kdegraphics-3.5.7-r1.ebuild b/kde-base/kdegraphics/kdegraphics-3.5.7-r1.ebuild
index 5c79f0f93bf3..3ce47ae1ca55 100644
--- a/kde-base/kdegraphics/kdegraphics-3.5.7-r1.ebuild
+++ b/kde-base/kdegraphics/kdegraphics-3.5.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.5.7-r1.ebuild,v 1.9 2007/08/15 05:20:27 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.5.7-r1.ebuild,v 1.10 2007/08/28 20:39:08 philantrop Exp $
inherit kde-dist eutils
@@ -33,7 +33,8 @@ RDEPEND="${DEPEND}
app-text/cstetex
app-text/dvipdfm ) )"
-PATCHES="${FILESDIR}/post-3.5.7-kdegraphics-CVE-2007-3387.diff"
+PATCHES="${FILESDIR}/post-3.5.7-kdegraphics-CVE-2007-3387.diff
+ ${FILESDIR}/kdegraphics-kfile-plugins-3.5.7-openexr-1.6.0.patch"
pkg_setup() {
kde_pkg_setup
diff --git a/kde-base/kdegraphics/kdegraphics-3.5.7-r2.ebuild b/kde-base/kdegraphics/kdegraphics-3.5.7-r2.ebuild
index 566b5836512b..b450289e6fb4 100644
--- a/kde-base/kdegraphics/kdegraphics-3.5.7-r2.ebuild
+++ b/kde-base/kdegraphics/kdegraphics-3.5.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.5.7-r2.ebuild,v 1.1 2007/08/23 17:40:16 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.5.7-r2.ebuild,v 1.2 2007/08/28 20:39:08 philantrop Exp $
inherit kde-dist eutils
@@ -34,7 +34,8 @@ RDEPEND="${DEPEND}
app-text/dvipdfm ) )"
PATCHES="${FILESDIR}/post-3.5.7-kdegraphics-CVE-2007-3387.diff
- ${FILESDIR}/kpdf-3.5.7-hash_path.diff"
+ ${FILESDIR}/kpdf-3.5.7-hash_path.diff
+ ${FILESDIR}/kdegraphics-kfile-plugins-3.5.7-openexr-1.6.0.patch"
pkg_setup() {
kde_pkg_setup