summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2012-07-15 04:44:00 +0000
committerAkinori Hattori <hattya@gentoo.org>2012-07-15 04:44:00 +0000
commit2ed99b9dbbf7bd6d76f56bec9b4b63526bf4c2b1 (patch)
tree2c39e9545137b03ff8ffbd7c5a198a093f418b0a
parentuse sed for LDFLAGS (diff)
downloadgentoo-2-2ed99b9dbbf7bd6d76f56bec9b4b63526bf4c2b1.tar.gz
gentoo-2-2ed99b9dbbf7bd6d76f56bec9b4b63526bf4c2b1.tar.bz2
gentoo-2-2ed99b9dbbf7bd6d76f56bec9b4b63526bf4c2b1.zip
fix implicit declaration of built-in function 'exit'
(Portage version: 2.1.10.65/cvs/Linux i686)
-rw-r--r--app-i18n/kcc/ChangeLog6
-rw-r--r--app-i18n/kcc/files/kcc-exit.diff10
-rw-r--r--app-i18n/kcc/files/kcc-gcc3-gentoo.diff4
-rw-r--r--app-i18n/kcc/kcc-1.0.ebuild3
4 files changed, 19 insertions, 4 deletions
diff --git a/app-i18n/kcc/ChangeLog b/app-i18n/kcc/ChangeLog
index a8e6a85dd30a..77abda5fbe02 100644
--- a/app-i18n/kcc/ChangeLog
+++ b/app-i18n/kcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/kcc
# Copyright 2002-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kcc/ChangeLog,v 1.12 2012/07/15 04:27:20 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kcc/ChangeLog,v 1.13 2012/07/15 04:44:00 hattya Exp $
+
+ 15 Jul 2012; Akinori Hattori <hattya@gentoo.org> +files/kcc-exit.diff,
+ files/kcc-gcc3-gentoo.diff, kcc-1.0.ebuild:
+ fix implicit declaration of built-in function 'exit'
15 Jul 2012; Akinori Hattori <hattya@gentoo.org> kcc-1.0.ebuild:
use sed for LDFLAGS
diff --git a/app-i18n/kcc/files/kcc-exit.diff b/app-i18n/kcc/files/kcc-exit.diff
new file mode 100644
index 000000000000..478977a88256
--- /dev/null
+++ b/app-i18n/kcc/files/kcc-exit.diff
@@ -0,0 +1,10 @@
+--- a/kcc.c
++++ b/kcc.c
+@@ -27,6 +27,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/app-i18n/kcc/files/kcc-gcc3-gentoo.diff b/app-i18n/kcc/files/kcc-gcc3-gentoo.diff
index bf82c3096a13..88f08e20161d 100644
--- a/app-i18n/kcc/files/kcc-gcc3-gentoo.diff
+++ b/app-i18n/kcc/files/kcc-gcc3-gentoo.diff
@@ -1,5 +1,5 @@
---- kcc.c.orig 1994-03-28 20:00:12.000000000 +0900
-+++ kcc.c 2004-01-07 18:36:29.589293728 +0900
+--- a/kcc.c
++++ b/kcc.c
@@ -134,7 +134,11 @@
extern unsigned short hiragana[];
unsigned short *kanatbl = katakana;
diff --git a/app-i18n/kcc/kcc-1.0.ebuild b/app-i18n/kcc/kcc-1.0.ebuild
index 87d2b7b33a12..73912e24ae76 100644
--- a/app-i18n/kcc/kcc-1.0.ebuild
+++ b/app-i18n/kcc/kcc-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/kcc/kcc-1.0.ebuild,v 1.17 2012/07/15 04:34:15 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kcc/kcc-1.0.ebuild,v 1.18 2012/07/15 04:44:00 hattya Exp $
EAPI="4"
@@ -19,6 +19,7 @@ S="${WORKDIR}/${PN}"
src_prepare() {
epatch "${FILESDIR}/${PN}-gcc3-gentoo.diff"
+ epatch "${FILESDIR}/${PN}-exit.diff"
sed -i "s:\(-o kcc\):\$(LDFLAGS) \1:" Makefile
}