summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-12-24 15:41:51 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-12-24 15:41:51 +0000
commit301e937752b351de485d50e3af537afd3ae058f2 (patch)
treee1ca96d37c15b841a2c6a22f1a4acc398cd15377
parentVersion bump; tests are enabled, but there is a failure still, which needs to... (diff)
downloadgentoo-2-301e937752b351de485d50e3af537afd3ae058f2.tar.gz
gentoo-2-301e937752b351de485d50e3af537afd3ae058f2.tar.bz2
gentoo-2-301e937752b351de485d50e3af537afd3ae058f2.zip
Pythonize ebuild, add support for multiple python ABIs
(Portage version: 2.1.10.41/cvs/Linux x86_64)
-rw-r--r--dev-python/pydb/ChangeLog7
-rw-r--r--dev-python/pydb/pydb-1.26-r1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/pydb/ChangeLog b/dev-python/pydb/ChangeLog
index 36a32f1bd62d..2e26d09113b0 100644
--- a/dev-python/pydb/ChangeLog
+++ b/dev-python/pydb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pydb
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pydb/ChangeLog,v 1.5 2011/12/24 13:21:05 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydb/ChangeLog,v 1.6 2011/12/24 15:41:51 maksbotan Exp $
+
+*pydb-1.26-r1 (24 Dec 2011)
+
+ 24 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> +pydb-1.26-r1.ebuild:
+ Pythonize ebuild, add support for multiple python ABIs
24 Dec 2011; Andrey Grozin <grozin@gentoo.org> pydb-1.26.ebuild:
Bug #379193 fixed, thanks to Ulrich Müller <ulm@gentoo.org>
diff --git a/dev-python/pydb/pydb-1.26-r1.ebuild b/dev-python/pydb/pydb-1.26-r1.ebuild
new file mode 100644
index 000000000000..a2af8c36f32a
--- /dev/null
+++ b/dev-python/pydb/pydb-1.26-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydb/pydb-1.26-r1.ebuild,v 1.1 2011/12/24 15:41:51 maksbotan Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit elisp-common python
+
+DESCRIPTION="Extended python debugger"
+HOMEPAGE="http://bashdb.sourceforge.net/pydb/"
+SRC_URI="mirror://sourceforge/bashdb/${P}.tar.bz2"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs"
+
+DEPEND="
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+# This package uses not distutils but the usual
+# ./configure; make; make install
+# The default src_compile is OK
+
+src_configure() {
+ configuration() {
+ econf --with-lispdir="${SITELISP}/${PN}" \
+ EMACS="$(use emacs && echo "${EMACS}" || echo no)" \
+ --with-site-packages=$(python_get_sitedir) \
+ --with-python=$(PYTHON -a)
+ }
+ python_execute_function -s configuration
+}
+
+src_install() {
+ installation(){
+ emake DESTDIR="${D}" install || die "emake install failed"
+ mv "${ED}"/usr/bin/${PN} "${ED}"/usr/bin/${PN}-${PYTHON_ABI} || die
+ }
+ python_execute_function -s installation
+ python_generate_wrapper_scripts "${ED}"/usr/bin/${PN}
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "dodoc failed"
+}