summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-07-31 10:40:09 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-07-31 10:40:09 +0000
commit309c9c80e8810aae5005d19342b035fa85414962 (patch)
tree150eed62a8941b0844c4dfeb96e032d50d79a49c
parentBugfix release on the 1.8 branch. Fixes, among other things, a null pointer d... (diff)
downloadgentoo-2-309c9c80e8810aae5005d19342b035fa85414962.tar.gz
gentoo-2-309c9c80e8810aae5005d19342b035fa85414962.tar.bz2
gentoo-2-309c9c80e8810aae5005d19342b035fa85414962.zip
Moved rev. with network-cron to r20 and applied fix for bug #424417 in r21.
Thanks to Martin Jürgens <martin.accounts@gmx.de> for finding the report and the patch. The patch has been written by Eduard Bloch <blade@debian.org>, see <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=479840>. (Portage version: 2.1.11.9/cvs/Linux x86_64)
-rw-r--r--app-admin/hddtemp/ChangeLog13
-rw-r--r--app-admin/hddtemp/files/hddtemp-0.3_beta15-dontwake.patch20
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta15-r20.ebuild (renamed from app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild)4
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta15-r21.ebuild96
4 files changed, 130 insertions, 3 deletions
diff --git a/app-admin/hddtemp/ChangeLog b/app-admin/hddtemp/ChangeLog
index c2de180bb20b..6d2c01999c40 100644
--- a/app-admin/hddtemp/ChangeLog
+++ b/app-admin/hddtemp/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-admin/hddtemp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.114 2012/07/31 09:30:14 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.115 2012/07/31 10:40:08 aidecoe Exp $
+
+*hddtemp-0.3_beta15-r21 (31 Jul 2012)
+*hddtemp-0.3_beta15-r20 (31 Jul 2012)
+
+ 31 Jul 2012; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ -hddtemp-0.3_beta15-r4.ebuild, +hddtemp-0.3_beta15-r20.ebuild,
+ +hddtemp-0.3_beta15-r21.ebuild, +files/hddtemp-0.3_beta15-dontwake.patch:
+ Moved rev. with network-cron to r20 and applied fix for bug #424417 in r21.
+ Thanks to Martin Jürgens <martin.accounts@gmx.de> for finding the report and
+ the patch. The patch has been written by Eduard Bloch <blade@debian.org>, see
+ <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=479840>.
31 Jul 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> files/hddgentoo.db:
Added Hitachi Travelstar E7K100 to hddgentoo.db. Fixes bug #419463.
diff --git a/app-admin/hddtemp/files/hddtemp-0.3_beta15-dontwake.patch b/app-admin/hddtemp/files/hddtemp-0.3_beta15-dontwake.patch
new file mode 100644
index 000000000000..969da7a70e40
--- /dev/null
+++ b/app-admin/hddtemp/files/hddtemp-0.3_beta15-dontwake.patch
@@ -0,0 +1,20 @@
+--- hddtemp-0.3-beta15/src/sata.c 2012-07-01 16:35:01.681708074 +0200
++++ hddtemp-0.3-beta15/src/sata.c 2012-07-01 16:33:58.172109699 +0200
+@@ -125,6 +125,17 @@
+ dsk->fd = -1;
+ return GETTEMP_NOSENSOR;
+ }
++
++ switch(ata_get_powermode(dsk->fd)) {
++ case PWM_STANDBY:
++ case PWM_SLEEPING:
++ if (!wakeup)
++ return GETTEMP_DRIVE_SLEEP;
++ case PWM_UNKNOWN:
++ case PWM_ACTIVE: /* active or idle */
++ default:
++ break;
++ }
+
+ /* get SMART values */
+ if(sata_enable_smart(dsk->fd) != 0) {
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta15-r20.ebuild
index d1f6cf04d50e..40c88d37064d 100644
--- a/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild
+++ b/app-admin/hddtemp/hddtemp-0.3_beta15-r20.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild,v 1.7 2011/11/14 12:25:25 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r20.ebuild,v 1.1 2012/07/31 10:40:08 aidecoe Exp $
EAPI=4
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta15-r21.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta15-r21.ebuild
new file mode 100644
index 000000000000..6a2a974fc6db
--- /dev/null
+++ b/app-admin/hddtemp/hddtemp-0.3_beta15-r21.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r21.ebuild,v 1.1 2012/07/31 10:40:08 aidecoe Exp $
+
+EAPI=4
+
+inherit eutils autotools
+
+MY_P=${P/_beta/-beta}
+DBV=20080531
+
+DESCRIPTION="A simple utility to read the temperature of SMART capable hard drives"
+HOMEPAGE="http://savannah.nongnu.org/projects/hddtemp/"
+SRC_URI="http://download.savannah.gnu.org/releases/hddtemp/${MY_P}.tar.bz2 mirror://gentoo/hddtemp-${DBV}.db.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="network-cron nls"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=(README TODO ChangeLog)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-satacmds.patch
+ epatch "${FILESDIR}"/${P}-byteswap.patch
+ epatch "${FILESDIR}"/${P}-execinfo.patch
+ epatch "${FILESDIR}"/${P}-nls.patch
+ epatch "${FILESDIR}"/${P}-iconv.patch
+ epatch "${FILESDIR}"/${P}-dontwake.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ myconf="--with-db-path=/usr/share/hddtemp/hddtemp.db"
+ # disabling nls breaks compiling
+ use nls || myconf="--disable-nls ${myconf}"
+ econf ${myconf}
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/hddtemp
+ newins "${WORKDIR}/hddtemp-${DBV}.db" hddtemp.db
+ doins "${FILESDIR}"/hddgentoo.db
+
+ update_db "${D}/usr/share/hddtemp/hddgentoo.db" "${D}/usr/share/hddtemp/hddtemp.db"
+ newconfd "${FILESDIR}"/hddtemp-conf.d hddtemp
+ newinitd "${FILESDIR}"/hddtemp-init hddtemp
+
+ dosbin "${FILESDIR}"/update-hddtemp.db
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ echo -e "#!/bin/sh\n/usr/sbin/update-hddtemp.db" > "${T}"/hddtemp.cron
+ newexe "${T}"/hddtemp.cron update-hddtemp.db
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to update your hddtemp database, run:"
+ elog " update-hddtemp.db"
+ elog ""
+ elog "If your hard drive is not recognized by hddtemp, please consider"
+ elog "submitting your HDD info for inclusion into the Gentoo hddtemp"
+ elog "database by filing a bug at https://bugs.gentoo.org/"
+ elog ""
+ elog "The hddtemp deamon requires a network interface to be up. If you"
+ elog "don't have an Ethernet interface, make sure at least the loopback"
+ elog "interface is up by setting 'rc_depend_strict=\"NO\"' in /etc/rc.conf."
+ echo
+ ewarn "If hddtemp complains but finds your HDD temperature sensor, use the"
+ ewarn "--quiet option to suppress the warning."
+}
+
+update_db() {
+ local src=$1
+ local dst=$2
+
+ while read line ; do
+ if [[ -z $(echo "${line}" | sed -re 's/(^#.*|^\w*$)//') ]]; then
+ echo "${line}" >> "${dst}"
+ fi
+
+ id=$(echo "${line}" | grep -o '"[^"]*"')
+
+ grep "${id}" "${dst}" 2>&1 >/dev/null || echo "${line}" >> "${dst}"
+ done < "${src}"
+}