summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-06-19 03:28:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-06-19 03:28:03 +0000
commit31da4a5408282d88b91b38e5f402a8f700f0dc99 (patch)
tree637aaa8088cde2b0fdc9ef870ec5d64823216982
parentfix dosym warning, bug #470106 (diff)
downloadgentoo-2-31da4a5408282d88b91b38e5f402a8f700f0dc99.tar.gz
gentoo-2-31da4a5408282d88b91b38e5f402a8f700f0dc99.tar.bz2
gentoo-2-31da4a5408282d88b91b38e5f402a8f700f0dc99.zip
Bump
(Portage version: 2.2.0_alpha181/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-libs/leveldb/ChangeLog7
-rw-r--r--dev-libs/leveldb/leveldb-1.11.0.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/leveldb/ChangeLog b/dev-libs/leveldb/ChangeLog
index 4e948ce97829..3b990967621e 100644
--- a/dev-libs/leveldb/ChangeLog
+++ b/dev-libs/leveldb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/leveldb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/ChangeLog,v 1.12 2013/06/11 19:09:53 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/ChangeLog,v 1.13 2013/06/19 03:28:03 patrick Exp $
+
+*leveldb-1.11.0 (19 Jun 2013)
+
+ 19 Jun 2013; Patrick Lauer <patrick@gentoo.org> +leveldb-1.11.0.ebuild:
+ Bump
11 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> leveldb-1.10.0.ebuild:
Keyword amd64-linux and x86-linux
diff --git a/dev-libs/leveldb/leveldb-1.11.0.ebuild b/dev-libs/leveldb/leveldb-1.11.0.ebuild
new file mode 100644
index 000000000000..10ccd6885feb
--- /dev/null
+++ b/dev-libs/leveldb/leveldb-1.11.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/leveldb-1.11.0.ebuild,v 1.1 2013/06/19 03:28:03 patrick Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="a fast key-value storage library written at Google"
+HOMEPAGE="http://code.google.com/p/leveldb/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="+snappy static-libs +tcmalloc"
+
+DEPEND="tcmalloc? ( dev-util/google-perftools )
+ snappy? (
+ app-arch/snappy
+ static-libs? ( app-arch/snappy[static-libs] )
+ )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # These vars all get picked up by build_detect_platform
+ # which the Makefile runs for us automatically.
+ tc-export AR CC CXX
+ export OPT="-DNDEBUG ${CPPFLAGS}"
+ # Probably needs more filling out
+ export TARGET_OS
+ case ${CHOST} in
+ *) TARGET_OS="Linux";;
+ esac
+ export USE_SNAPPY=$(usex snappy)
+ export USE_TCMALLOC=no
+}
+
+src_compile() {
+ emake $(usex static-libs '' 'LIBRARY=') all libmemenv.a
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ insinto /usr/include
+ doins -r include/* helpers/memenv/memenv.h
+ dolib.so libleveldb*$(get_libname)*
+ use static-libs && dolib.a libleveldb.a
+ dolib.a libmemenv.a
+}