summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-05-31 19:32:21 +0000
committerNed Ludd <solar@gentoo.org>2003-05-31 19:32:21 +0000
commit332652e73d6b13ce9aa7e6a5169edef3b113b581 (patch)
treecf6e2e4dfa21b67cd537c0a28097756715a12266
parentAdded support for ospfapi, Improvved init,conf scripts (diff)
downloadgentoo-2-332652e73d6b13ce9aa7e6a5169edef3b113b581.tar.gz
gentoo-2-332652e73d6b13ce9aa7e6a5169edef3b113b581.tar.bz2
gentoo-2-332652e73d6b13ce9aa7e6a5169edef3b113b581.zip
Added support for ospfapi, Improvved init,conf scripts
-rw-r--r--net-misc/zebra/ChangeLog9
-rw-r--r--net-misc/zebra/Manifest4
-rw-r--r--net-misc/zebra/zebra-0.93b-r1.ebuild99
3 files changed, 109 insertions, 3 deletions
diff --git a/net-misc/zebra/ChangeLog b/net-misc/zebra/ChangeLog
index 56ef58406456..822f9e244ad5 100644
--- a/net-misc/zebra/ChangeLog
+++ b/net-misc/zebra/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/zebra
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/zebra/ChangeLog,v 1.3 2003/04/28 19:57:16 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zebra/ChangeLog,v 1.4 2003/05/31 19:31:50 solar Exp $
+
+*zebra-0.93b-r1 (31 May 2003)
+
+ 28 Apr 2003; Ned Ludd <solar@gentoo.org> Manifest,
+ zebra-0.93b-r1.ebuild:
+ Added support for ospfapi extentions, and better
+ {init,conf}.d scripts
*zebra-0.93b (28 Apr 2003)
diff --git a/net-misc/zebra/Manifest b/net-misc/zebra/Manifest
index f1a02f5cefb4..e9db346e681e 100644
--- a/net-misc/zebra/Manifest
+++ b/net-misc/zebra/Manifest
@@ -1,7 +1,7 @@
-MD5 22b2fe75f8554144ed1dfb5bb111ccdf ChangeLog 824
+MD5 225450e7a455472b478f0173fd60f1cd ChangeLog 817
MD5 122a878efde20a1fc40817371a0146ad zebra-0.93a.ebuild 1317
MD5 122a878efde20a1fc40817371a0146ad zebra-0.93b.ebuild 1317
-MD5 f671c18337ea1303ac6d5247e6f57581 zebra-0.93b-r1.ebuild 2898
+MD5 6d50de8ce7d732446e7aa6d0643d675c zebra-0.93b-r1.ebuild 2908
MD5 1aea49f1bd903cd18e3a3ff2292c2639 files/digest-zebra-0.93a 64
MD5 0fd0812e7d1180d5965b9b997cd10011 files/digest-zebra-0.93b 64
MD5 5cc027d5ee8a3a1564d0e21423461b49 files/zebra.confd 638
diff --git a/net-misc/zebra/zebra-0.93b-r1.ebuild b/net-misc/zebra/zebra-0.93b-r1.ebuild
new file mode 100644
index 000000000000..4dc4b3114bcd
--- /dev/null
+++ b/net-misc/zebra/zebra-0.93b-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zebra/zebra-0.93b-r1.ebuild,v 1.1 2003/05/31 19:31:50 solar Exp $
+
+S=${WORKDIR}/${P}
+IUSE="pam snmp ipv6 ospfapi"
+
+DESCRIPTION="Multithreaded TCP/IP Routing Software that supports BGP-4, RIPv1, RIPv2 and OSPFv2. Includes OSPFAPI"
+SRC_URI="ftp://ftp.zebra.org/pub/zebra/${P}.tar.gz \
+ ospfapi? ( http://www.tik.ee.ethz.ch/~keller/ospfapi/src/ospfapi-release_0_93b-2003-01-25.tar.gz )"
+
+HOMEPAGE="http://www.zebra.org"
+HOMEPAGE="${HOMEPAGE} http://www.tik.ee.ethz.ch/~keller/ospfapi"
+
+KEYWORDS="~x86 ~sparc"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ pam? ( >=pam-0.75-r11 )"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${WORKDIR}
+ ln -s ${S} zebra
+
+ if [ `use ospfapi` ] ; then
+ epatch ospfapi-release_*-200[3-9]-[0-9][0-9]-[0-9][0-9].patch
+ fi
+
+ ##################################
+ # This fix is for zebra-0.93b only
+ ##################################
+ cd ${S}/ospfd || die
+ epatch ${FILESDIR}/${P}/ospfd-assert-fix.patch
+ epatch ${FILESDIR}/${P}/ospfd-nbr-fix.patch
+ ##################################
+}
+
+src_compile() {
+ local myconf="--enable-vtysh --enable-tcp-zebra"
+
+ use pam || myconf="${myconf} --disable-pam"
+ use snmp || myconf="${myconf} --disable-snmp"
+ use ipv6 || myconf="${myconf} --disable-ipv6"
+
+ use ospfapi && myconf="${myconf} --enable-opaque-lsa --enable-ospf-te \
+ --enable-nssa"
+ use ospfapi && ./update-autotools
+
+ econf --prefix=/usr --sysconfdir=/etc/zebra ${myconf} || \
+ die "econf failed"
+ emake || die "emake failed"
+
+ if [ `use ospfapi` ] ; then
+ cd apiclient
+ econf --prefix=/usr --sysconfdir=/etc/zebra ${myconf} || \
+ die "econf failed in ospsapi-apiclient"
+ emake || die "emake failed in ospsapi-apiclient"
+ cd ..
+ fi
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc/zebra \
+ localstatedir=${D}/var \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die "zebra installation failed"
+
+ dodir ${D}/etc/ {D}/etc/zebra/ ${D}/etc/zebra/sample
+ cp */*.conf.sample* ${D}/etc/zebra/
+ mv ${D}/etc/zebra/*.conf.sample* ${D}/etc/zebra/sample
+
+ for proto in zebra bgpd ospfd ripd; do
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf.d/${proto}.confd ${proto}
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/init.d/${proto}.initd ${proto}
+ done
+
+ # second loop for ipv6
+ use ipv6 && for proto in ospf6d ripngd; do
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf.d/${proto}.confd ${proto}
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/init.d/${proto}.initd ${proto}
+ done
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README REPORTING-BUGS SERVICES TODO
+}
+
+pkg_postinst() {
+ einfo "Sample configuration files can be found in /etc/zebra/sample/"
+ einfo "You have to create config files in /etc/zebra before"
+ einfo "starting any one of the daemons."
+}