summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-13 00:35:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-13 00:35:03 +0000
commit3366950f5a99b7baa327cb43015d06bb6c4c3315 (patch)
treea5c71432ba00db428e8633dd5a2afc655aa477c0
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-3366950f5a99b7baa327cb43015d06bb6c4c3315.tar.gz
gentoo-2-3366950f5a99b7baa327cb43015d06bb6c4c3315.tar.bz2
gentoo-2-3366950f5a99b7baa327cb43015d06bb6c4c3315.zip
Revision bump to make sure that hte package is built with large file support on 32-bit architectures (it wasn't before, even though it was intended to). Make build verbose to avoid further mistakes slipping by as it happened before. Add die clauses to install while at it, and bump to EAPI=2.
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
-rw-r--r--dev-util/bsdiff/ChangeLog10
-rw-r--r--dev-util/bsdiff/bsdiff-4.3-r2.ebuild36
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-util/bsdiff/ChangeLog b/dev-util/bsdiff/ChangeLog
index 12e2fa0e6da4..1410f1f0039a 100644
--- a/dev-util/bsdiff/ChangeLog
+++ b/dev-util/bsdiff/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/bsdiff
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bsdiff/ChangeLog,v 1.32 2010/10/19 05:17:27 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bsdiff/ChangeLog,v 1.33 2010/12/13 00:35:03 flameeyes Exp $
+
+*bsdiff-4.3-r2 (13 Dec 2010)
+
+ 13 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org> +bsdiff-4.3-r2.ebuild:
+ Revision bump to make sure that hte package is built with large file support
+ on 32-bit architectures (it wasn't before, even though it was intended to).
+ Make build verbose to avoid further mistakes slipping by as it happened
+ before. Add die clauses to install while at it, and bump to EAPI=2.
19 Oct 2010; Mart Raudsepp <leio@gentoo.org> bsdiff-4.3-r1.ebuild:
Drop to ~mips
diff --git a/dev-util/bsdiff/bsdiff-4.3-r2.ebuild b/dev-util/bsdiff/bsdiff-4.3-r2.ebuild
new file mode 100644
index 000000000000..b596d86c7c2e
--- /dev/null
+++ b/dev-util/bsdiff/bsdiff-4.3-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bsdiff/bsdiff-4.3-r2.ebuild,v 1.1 2010/12/13 00:35:03 flameeyes Exp $
+
+EAPI=2
+
+inherit toolchain-funcs flag-o-matic
+
+IUSE=""
+
+DESCRIPTION="bsdiff: Binary Differencer using a suffix alg"
+HOMEPAGE="http://www.daemonology.net/bsdiff/"
+SRC_URI="http://www.daemonology.net/bsdiff/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+doecho() {
+ echo "$@"
+ "$@"
+}
+
+src_compile() {
+ append-lfs-flags
+ doecho $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o bsdiff bsdiff.c -lbz2 || die "failed compiling bsdiff"
+ doecho $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o bspatch bspatch.c -lbz2 || die "failed compiling bspatch"
+}
+
+src_install() {
+ dobin bs{diff,patch} || die
+ doman bs{diff,patch}.1 || die
+}