summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-10-21 17:39:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-10-21 17:39:17 +0000
commit354fe41029f12356a98be8d2f9e7bcb11a9af127 (patch)
treed9353164cac0dd60a4c38f5dce1c3f711811ed3f
parentChange -hppa to ~hppa (diff)
downloadgentoo-2-354fe41029f12356a98be8d2f9e7bcb11a9af127.tar.gz
gentoo-2-354fe41029f12356a98be8d2f9e7bcb11a9af127.tar.bz2
gentoo-2-354fe41029f12356a98be8d2f9e7bcb11a9af127.zip
version bump
(Portage version: 2.2_rc98/cvs/Linux x86_64)
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog8
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.13.0.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index 6733d87fd3ce..f7c6115d2954 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.17 2010/06/17 18:26:55 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.18 2010/10/21 17:39:17 aballier Exp $
+
+*postgresql-ocaml-1.13.0 (21 Oct 2010)
+
+ 21 Oct 2010; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-1.13.0.ebuild:
+ version bump
17 Jun 2010; Patrick Lauer <patrick@gentoo.org>
postgresql-ocaml-1.4.6.ebuild, postgresql-ocaml-1.12.5.ebuild:
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.13.0.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.13.0.ebuild
new file mode 100644
index 000000000000..03a524b3c821
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.13.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.13.0.ebuild,v 1.1 2010/10/21 17:39:17 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="examples +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ dev-db/postgresql-base
+ dev-db/postgresql-server"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_preinst
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS Changelog README.txt
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}