summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-28 02:26:18 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-28 02:26:18 +0000
commit3575e1f3c8b468e50586aa2de7dfbf97d08762cd (patch)
treeece1658a21f486cfa6cfb07f294ee55a8dc9698e
parentAdded ~sparc, ~mips (Manifest recommit) (diff)
downloadgentoo-2-3575e1f3c8b468e50586aa2de7dfbf97d08762cd.tar.gz
gentoo-2-3575e1f3c8b468e50586aa2de7dfbf97d08762cd.tar.bz2
gentoo-2-3575e1f3c8b468e50586aa2de7dfbf97d08762cd.zip
QA - fix use invocation
-rw-r--r--sys-libs/pam/ChangeLog7
-rw-r--r--sys-libs/pam/pam-0.75-r10.ebuild6
-rw-r--r--sys-libs/pam/pam-0.75-r11.ebuild6
-rw-r--r--sys-libs/pam/pam-0.75-r7.ebuild6
-rw-r--r--sys-libs/pam/pam-0.75-r8.ebuild6
-rw-r--r--sys-libs/pam/pam-0.75-r9.ebuild6
-rw-r--r--sys-libs/pam/pam-0.77-r1.ebuild35
-rw-r--r--sys-libs/pam/pam-0.77.ebuild35
-rw-r--r--x11-wm/evilwm/ChangeLog6
-rw-r--r--x11-wm/evilwm/evilwm-0.99.14.ebuild4
-rw-r--r--x11-wm/evilwm/evilwm-0.99.17.ebuild4
-rw-r--r--x11-wm/ion2/ChangeLog6
-rw-r--r--x11-wm/ion2/ion2-20040211-r2.ebuild4
-rw-r--r--x11-wm/ion2/ion2-20040211-r3.ebuild4
14 files changed, 73 insertions, 62 deletions
diff --git a/sys-libs/pam/ChangeLog b/sys-libs/pam/ChangeLog
index 415af3de3dc9..2472ffe56e73 100644
--- a/sys-libs/pam/ChangeLog
+++ b/sys-libs/pam/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/pam
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/ChangeLog,v 1.52 2004/06/24 23:08:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/ChangeLog,v 1.53 2004/06/28 02:22:20 agriffis Exp $
+
+ 27 Jun 2004; Aron Griffis <agriffis@gentoo.org> pam-0.75-r10.ebuild,
+ pam-0.75-r11.ebuild, pam-0.75-r7.ebuild, pam-0.75-r8.ebuild,
+ pam-0.75-r9.ebuild, pam-0.77-r1.ebuild, pam-0.77.ebuild:
+ QA - fix use invocation
02 Jun 2004; Travis Tilley <lv@gentoo.org> pam-0.77-r1.ebuild:
stable on amd64
diff --git a/sys-libs/pam/pam-0.75-r10.ebuild b/sys-libs/pam/pam-0.75-r10.ebuild
index 7857c5e97066..3d8a0defedc1 100644
--- a/sys-libs/pam/pam-0.75-r10.ebuild
+++ b/sys-libs/pam/pam-0.75-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r10.ebuild,v 1.15 2004/06/24 23:08:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r10.ebuild,v 1.16 2004/06/28 02:22:20 agriffis Exp $
IUSE="berkdb"
@@ -103,7 +103,7 @@ src_compile() {
rm -f Make.Rules.orig
fi
- if [ -z "$(use berkdb)" ]
+ if ! use berkdb
then
cp Make.Rules Make.Rules.orig
sed -e "s:^HAVE_LIBNDBM=yes:HAVE_LIBNDBM=no:" \
@@ -129,7 +129,7 @@ src_install() {
then
if ! ls -1 ${D}/lib/security/$(basename ${x})*.so &> /dev/null
then
- if [ -z "$(use berkdb)" -a "$(basename ${x})" = "pam_userdb" ]
+ if ! use berkdb && [ "$(basename ${x})" = "pam_userdb" ]
then
continue
fi
diff --git a/sys-libs/pam/pam-0.75-r11.ebuild b/sys-libs/pam/pam-0.75-r11.ebuild
index c2433dd69c14..dc4fbf0024af 100644
--- a/sys-libs/pam/pam-0.75-r11.ebuild
+++ b/sys-libs/pam/pam-0.75-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r11.ebuild,v 1.27 2004/06/24 23:08:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r11.ebuild,v 1.28 2004/06/28 02:22:20 agriffis Exp $
inherit gcc eutils flag-o-matic
@@ -108,7 +108,7 @@ src_compile() {
rm -f Make.Rules.orig
fi
- if [ -z "$(use berkdb)" ]
+ if ! use berkdb
then
cp Make.Rules Make.Rules.orig
sed -e "s:^HAVE_LIBNDBM=yes:HAVE_LIBNDBM=no:" \
@@ -140,7 +140,7 @@ src_install() {
then
if ! ls -1 ${D}/lib/security/$(basename ${x})*.so &> /dev/null
then
- if [ -z "$(use berkdb)" -a "$(basename ${x})" = "pam_userdb" ]
+ if ! use berkdb && [ "$(basename ${x})" = "pam_userdb" ]
then
continue
fi
diff --git a/sys-libs/pam/pam-0.75-r7.ebuild b/sys-libs/pam/pam-0.75-r7.ebuild
index e63add56bc17..c85adfa0d041 100644
--- a/sys-libs/pam/pam-0.75-r7.ebuild
+++ b/sys-libs/pam/pam-0.75-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r7.ebuild,v 1.18 2004/06/24 23:08:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r7.ebuild,v 1.19 2004/06/28 02:22:20 agriffis Exp $
IUSE="berkdb"
@@ -100,7 +100,7 @@ src_compile() {
sed -e "s:-lpwdb:-lpwdb -lcrypt -lnsl:g" \
modules/pam_pwdb/Makefile_orig > modules/pam_pwdb/Makefile
- if [ -z "`use berkdb`" ]
+ if ! use berkdb
then
cp Make.Rules Make.orig
sed -e "s:^HAVE_LIBNDBM=yes:HAVE_LIBNDBM=no:" \
@@ -128,7 +128,7 @@ src_install() {
then
if ! ls -1 ${D}/lib/security/`basename ${x}`*.so
then
- if [ -z "`use berkdb`" ] && \
+ if ! use berkdb && \
[ "`basename ${x}`" = "pam_userdb" ]
then
continue
diff --git a/sys-libs/pam/pam-0.75-r8.ebuild b/sys-libs/pam/pam-0.75-r8.ebuild
index fe6d1e47e5d6..2c3f1efb234d 100644
--- a/sys-libs/pam/pam-0.75-r8.ebuild
+++ b/sys-libs/pam/pam-0.75-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r8.ebuild,v 1.14 2004/06/24 23:08:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r8.ebuild,v 1.15 2004/06/28 02:22:20 agriffis Exp $
IUSE="berkdb"
@@ -91,7 +91,7 @@ src_compile() {
rm -f Make.Rules.orig
fi
- if [ -z "$(use berkdb)" ]
+ if ! use berkdb
then
cp Make.Rules Make.Rules.orig
sed -e "s:^HAVE_LIBNDBM=yes:HAVE_LIBNDBM=no:" \
@@ -116,7 +116,7 @@ src_install() {
then
if ! ls -1 ${D}/lib/security/$(basename ${x})*.so &> /dev/null
then
- if [ -z "$(use berkdb)" -a "$(basename ${x})" = "pam_userdb" ]
+ if ! use berkdb && [ "$(basename ${x})" = "pam_userdb" ]
then
continue
fi
diff --git a/sys-libs/pam/pam-0.75-r9.ebuild b/sys-libs/pam/pam-0.75-r9.ebuild
index ac586a799ff0..dd72b11900ce 100644
--- a/sys-libs/pam/pam-0.75-r9.ebuild
+++ b/sys-libs/pam/pam-0.75-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r9.ebuild,v 1.14 2004/06/24 23:08:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r9.ebuild,v 1.15 2004/06/28 02:22:20 agriffis Exp $
IUSE="berkdb"
@@ -91,7 +91,7 @@ src_compile() {
rm -f Make.Rules.orig
fi
- if [ -z "$(use berkdb)" ]
+ if ! use berkdb
then
cp Make.Rules Make.Rules.orig
sed -e "s:^HAVE_LIBNDBM=yes:HAVE_LIBNDBM=no:" \
@@ -116,7 +116,7 @@ src_install() {
then
if ! ls -1 ${D}/lib/security/$(basename ${x})*.so &> /dev/null
then
- if [ -z "$(use berkdb)" -a "$(basename ${x})" = "pam_userdb" ]
+ if ! use berkdb && [ "$(basename ${x})" = "pam_userdb" ]
then
continue
fi
diff --git a/sys-libs/pam/pam-0.77-r1.ebuild b/sys-libs/pam/pam-0.77-r1.ebuild
index 923acf47a350..f032c7ad0fe4 100644
--- a/sys-libs/pam/pam-0.77-r1.ebuild
+++ b/sys-libs/pam/pam-0.77-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.77-r1.ebuild,v 1.6 2004/06/24 23:08:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.77-r1.ebuild,v 1.7 2004/06/28 02:22:20 agriffis Exp $
PATCH_LEVEL="1.2"
BDB_VER="4.1.25"
@@ -72,15 +72,14 @@ apply_pam_patches() {
pkg_setup() {
local x=
- for x in libpwdb.a libcrack.a
- do
- [ -z "$(use pwdb)" ] && continue
-
- [ ! -f "${ROOT}/usr/lib/${x}" ] && {
- eerror "Could not find /usr/lib/${x} needed to build Linux-PAM!"
- die "Could not find /usr/lib/${x} needed to build Linux-PAM!"
- }
- done
+ if use pwdb; then
+ for x in libpwdb.a libcrack.a; do
+ if [ ! -f "${ROOT}/usr/lib/${x}" ]; then
+ eerror "Could not find /usr/lib/${x} needed to build Linux-PAM!"
+ die "Could not find /usr/lib/${x} needed to build Linux-PAM!"
+ fi
+ done
+ fi
return 0
}
@@ -109,7 +108,7 @@ src_unpack() {
src_compile() {
export CFLAGS="${CFLAGS} -fPIC"
- if [ -n "$(use berkdb)" ]
+ if use berkdb
then
einfo "Building Berkley DB ${BDB_VER}..."
cd ${WORKDIR}
@@ -186,7 +185,7 @@ src_compile() {
sed -i -e "s:-Wpointer-arith::" Make.Rules
fi
- if [ -z "$(use berkdb)" ]
+ if ! use berkdb
then
# Do not build pam_userdb.so ...
sed -i -e "s:^HAVE_NDBM_H=yes:HAVE_NDBM_H=no:" \
@@ -233,15 +232,15 @@ src_install() {
# Its OK if the module failed when we didnt ask for it anyway
if ! ls -1 ${D}/lib/security/$(basename ${x})*.so &> /dev/null
then
- if [ -z "$(use berkdb)" -a "$(basename ${x})" = "pam_userdb" ]
+ if ! use berkdb && [ "$(basename ${x})" = "pam_userdb" ]
then
continue
fi
- if [ -z "$(use pwdb)" -a "$(basename ${x})" = "pam_pwdb" ]
+ if ! use pwdb && [ "$(basename ${x})" = "pam_pwdb" ]
then
continue
fi
- if [ -z "$(use pwdb)" -a "$(basename ${x})" = "pam_radius" ]
+ if ! use pwdb && [ "$(basename ${x})" = "pam_radius" ]
then
continue
fi
@@ -249,15 +248,15 @@ src_install() {
exit 1
else
# Remove the ones we didnt want if it ended up building ok anyways
- if [ -z "$(use berkdb)" -a "$(basename ${x})" = "pam_userdb" ]
+ if ! use berkdb && [ "$(basename ${x})" = "pam_userdb" ]
then
rm -f ${D}/lib/security/pam_userdb*
fi
- if [ -z "$(use pwdb)" -a "$(basename ${x})" = "pam_pwdb" ]
+ if ! use pwdb && [ "$(basename ${x})" = "pam_pwdb" ]
then
rm -f ${D}/lib/security/pam_pwdb*
fi
- if [ -z "$(use pwdb)" -a "$(basename ${x})" = "pam_radius" ]
+ if ! use pwdb && [ "$(basename ${x})" = "pam_radius" ]
then
rm -f ${D}/lib/security/pam_radius*
fi
diff --git a/sys-libs/pam/pam-0.77.ebuild b/sys-libs/pam/pam-0.77.ebuild
index 3e68a8b03df9..14bf89a41eea 100644
--- a/sys-libs/pam/pam-0.77.ebuild
+++ b/sys-libs/pam/pam-0.77.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.77.ebuild,v 1.21 2004/06/24 23:08:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.77.ebuild,v 1.22 2004/06/28 02:22:20 agriffis Exp $
PATCH_LEVEL="1.2"
BDB_VER="4.1.25"
@@ -68,15 +68,14 @@ apply_pam_patches() {
pkg_setup() {
local x=
- for x in libpwdb.a libcrack.a
- do
- [ -z "$(use pwdb)" ] && continue
-
- [ ! -f "${ROOT}/usr/lib/${x}" ] && {
- eerror "Could not find /usr/lib/${x} needed to build Linux-PAM!"
- die "Could not find /usr/lib/${x} needed to build Linux-PAM!"
- }
- done
+ if use pwdb; then
+ for x in libpwdb.a libcrack.a; do
+ if [ ! -f "${ROOT}/usr/lib/${x}" ]; then
+ eerror "Could not find /usr/lib/${x} needed to build Linux-PAM!"
+ die "Could not find /usr/lib/${x} needed to build Linux-PAM!"
+ fi
+ done
+ fi
return 0
}
@@ -105,7 +104,7 @@ src_unpack() {
src_compile() {
export CFLAGS="${CFLAGS} -fPIC"
- if [ -n "$(use berkdb)" ]
+ if use berkdb
then
einfo "Building Berkley DB ${BDB_VER}..."
cd ${WORKDIR}
@@ -182,7 +181,7 @@ src_compile() {
sed -i -e "s:-Wpointer-arith::" Make.Rules
fi
- if [ -z "$(use berkdb)" ]
+ if ! use berkdb
then
# Do not build pam_userdb.so ...
sed -i -e "s:^HAVE_NDBM_H=yes:HAVE_NDBM_H=no:" \
@@ -218,15 +217,15 @@ src_install() {
# Its OK if the module failed when we didnt ask for it anyway
if ! ls -1 ${D}/lib/security/$(basename ${x})*.so &> /dev/null
then
- if [ -z "$(use berkdb)" -a "$(basename ${x})" = "pam_userdb" ]
+ if ! use berkdb && [ "$(basename ${x})" = "pam_userdb" ]
then
continue
fi
- if [ -z "$(use pwdb)" -a "$(basename ${x})" = "pam_pwdb" ]
+ if ! use pwdb && [ "$(basename ${x})" = "pam_pwdb" ]
then
continue
fi
- if [ -z "$(use pwdb)" -a "$(basename ${x})" = "pam_radius" ]
+ if ! use pwdb && [ "$(basename ${x})" = "pam_radius" ]
then
continue
fi
@@ -234,15 +233,15 @@ src_install() {
exit 1
else
# Remove the ones we didnt want if it ended up building ok anyways
- if [ -z "$(use berkdb)" -a "$(basename ${x})" = "pam_userdb" ]
+ if ! use berkdb && [ "$(basename ${x})" = "pam_userdb" ]
then
rm -f ${D}/lib/security/pam_userdb*
fi
- if [ -z "$(use pwdb)" -a "$(basename ${x})" = "pam_pwdb" ]
+ if ! use pwdb && [ "$(basename ${x})" = "pam_pwdb" ]
then
rm -f ${D}/lib/security/pam_pwdb*
fi
- if [ -z "$(use pwdb)" -a "$(basename ${x})" = "pam_radius" ]
+ if ! use pwdb && [ "$(basename ${x})" = "pam_radius" ]
then
rm -f ${D}/lib/security/pam_radius*
fi
diff --git a/x11-wm/evilwm/ChangeLog b/x11-wm/evilwm/ChangeLog
index 8d165396f891..26177fb91bf2 100644
--- a/x11-wm/evilwm/ChangeLog
+++ b/x11-wm/evilwm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-wm/evilwm
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/evilwm/ChangeLog,v 1.20 2004/06/26 08:11:22 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/evilwm/ChangeLog,v 1.21 2004/06/28 02:25:31 agriffis Exp $
+
+ 27 Jun 2004; Aron Griffis <agriffis@gentoo.org> evilwm-0.99.14.ebuild,
+ evilwm-0.99.17.ebuild:
+ QA - fix use invocation
26 Jun 2004; Danny van Dyk <kugelfang@gentoo.org> evilwm-0.99.17.ebuild:
Marked ~amd64.
diff --git a/x11-wm/evilwm/evilwm-0.99.14.ebuild b/x11-wm/evilwm/evilwm-0.99.14.ebuild
index 244b76080def..f23c6eda70db 100644
--- a/x11-wm/evilwm/evilwm-0.99.14.ebuild
+++ b/x11-wm/evilwm/evilwm-0.99.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/evilwm/evilwm-0.99.14.ebuild,v 1.12 2004/06/24 23:40:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/evilwm/evilwm-0.99.14.ebuild,v 1.13 2004/06/28 02:25:31 agriffis Exp $
MY_P="${PN}_${PV}.orig"
S=${WORKDIR}/${MY_P/_/-}
@@ -21,7 +21,7 @@ src_unpack() {
unpack ${A}
cd ${S}
- if [ -z "`use motif`" ]
+ if ! use motif
then
cp Makefile ${T}
sed "s:DEFINES += -DMWM_HINTS::" \
diff --git a/x11-wm/evilwm/evilwm-0.99.17.ebuild b/x11-wm/evilwm/evilwm-0.99.17.ebuild
index 9e8386c6ce9b..41740ae14a5f 100644
--- a/x11-wm/evilwm/evilwm-0.99.17.ebuild
+++ b/x11-wm/evilwm/evilwm-0.99.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/evilwm/evilwm-0.99.17.ebuild,v 1.8 2004/06/26 08:11:22 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/evilwm/evilwm-0.99.17.ebuild,v 1.9 2004/06/28 02:25:31 agriffis Exp $
MY_P="${PN}_${PV}.orig"
S=${WORKDIR}/${MY_P/_/-}
@@ -21,7 +21,7 @@ src_unpack() {
unpack ${A}
cd ${S}
- if [ -z "`use motif`" ]
+ if ! use motif
then
cp Makefile ${T}
sed "s:DEFINES += -DMWM_HINTS::" \
diff --git a/x11-wm/ion2/ChangeLog b/x11-wm/ion2/ChangeLog
index 6324633ce211..f5a26a3901fd 100644
--- a/x11-wm/ion2/ChangeLog
+++ b/x11-wm/ion2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-wm/ion2
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion2/ChangeLog,v 1.14 2004/06/24 23:42:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion2/ChangeLog,v 1.15 2004/06/28 02:26:18 agriffis Exp $
+
+ 27 Jun 2004; Aron Griffis <agriffis@gentoo.org> ion2-20040211-r2.ebuild,
+ ion2-20040211-r3.ebuild:
+ QA - fix use invocation
*ion2-20040601 (01 Jun 2004)
diff --git a/x11-wm/ion2/ion2-20040211-r2.ebuild b/x11-wm/ion2/ion2-20040211-r2.ebuild
index fed6bf5552b6..cb375fdc5df9 100644
--- a/x11-wm/ion2/ion2-20040211-r2.ebuild
+++ b/x11-wm/ion2/ion2-20040211-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion2/ion2-20040211-r2.ebuild,v 1.6 2004/06/24 23:42:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion2/ion2-20040211-r2.ebuild,v 1.7 2004/06/28 02:26:18 agriffis Exp $
inherit eutils
@@ -25,7 +25,7 @@ src_unpack() {
epatch ${FILESDIR}/ion2-20040207-20040211.patch
- if [ `use truetype` ]; then
+ if use truetype; then
mkdir xftde
cp de/{*.c,*.h,Makefile} xftde
( cd xftde && epatch ${FILESDIR}/xftde-20040207.patch )
diff --git a/x11-wm/ion2/ion2-20040211-r3.ebuild b/x11-wm/ion2/ion2-20040211-r3.ebuild
index 625420bb5f13..a134be867645 100644
--- a/x11-wm/ion2/ion2-20040211-r3.ebuild
+++ b/x11-wm/ion2/ion2-20040211-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion2/ion2-20040211-r3.ebuild,v 1.3 2004/06/24 23:42:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion2/ion2-20040211-r3.ebuild,v 1.4 2004/06/28 02:26:18 agriffis Exp $
inherit eutils
@@ -27,7 +27,7 @@ src_unpack() {
epatch ${FILESDIR}/ion2-20040207-20040211.patch
epatch ${FILESDIR}/ion2-20040207-rename.patch
- if [ `use truetype` ]; then
+ if use truetype; then
mkdir xftde
cp de/{*.c,*.h,Makefile} xftde
( cd xftde && epatch ${FILESDIR}/xftde-20040207.patch )