summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-22 18:00:16 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-22 18:00:16 +0000
commit365ac69e07e2ec520b0776f66fb96d19ab03a948 (patch)
tree6f28803a13cac59f97e17d5ae00b70cc25657dda
parentBump to 0.9.3, from gnome overlay (diff)
downloadgentoo-2-365ac69e07e2ec520b0776f66fb96d19ab03a948.tar.gz
gentoo-2-365ac69e07e2ec520b0776f66fb96d19ab03a948.tar.bz2
gentoo-2-365ac69e07e2ec520b0776f66fb96d19ab03a948.zip
Fix some iri tests after CVE patch #333965 by Xake.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--net-misc/wget/ChangeLog6
-rw-r--r--net-misc/wget/files/wget-1.12-CVE-2010-2252.patch40
-rw-r--r--net-misc/wget/wget-1.12-r2.ebuild4
3 files changed, 46 insertions, 4 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index a74de6c41120..1f945046d5a0 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/wget
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.123 2010/08/21 22:18:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.124 2010/08/22 18:00:16 vapier Exp $
+
+ 22 Aug 2010; Mike Frysinger <vapier@gentoo.org> wget-1.12-r2.ebuild,
+ files/wget-1.12-CVE-2010-2252.patch:
+ Fix some iri tests after CVE patch #333965 by Xake.
*wget-1.12-r2 (21 Aug 2010)
diff --git a/net-misc/wget/files/wget-1.12-CVE-2010-2252.patch b/net-misc/wget/files/wget-1.12-CVE-2010-2252.patch
index af1688ada582..d163996d73e2 100644
--- a/net-misc/wget/files/wget-1.12-CVE-2010-2252.patch
+++ b/net-misc/wget/files/wget-1.12-CVE-2010-2252.patch
@@ -136,7 +136,7 @@ ChangeLog:
N_("\
-I, --include-directories=LIST list of allowed directories.\n"),
N_("\
-+ --trust-server-names use the name specified by the redirection url last component.\n"),
++ --trust-server-names use the name specified by the redirection url last component.\n"),
+ N_("\
-X, --exclude-directories=LIST list of excluded directories.\n"),
N_("\
@@ -167,3 +167,41 @@ ChangeLog:
}
else if (u->scheme == SCHEME_FTP)
{
+
+make sure tests pass after this change
+https://bugs.gentoo.org/333965
+https://savannah.gnu.org/bugs/index.php?30841
+
+--- tests/Test-iri-forced-remote.px
++++ tests/Test-iri-forced-remote.px
+@@ -174,7 +174,7 @@ my %urls = (
+ },
+ );
+
+-my $cmdline = $WgetTest::WGETPATH . " --iri --remote-encoding=iso-8859-1 -nH -r http://localhost:{{port}}/";
++my $cmdline = $WgetTest::WGETPATH . " --iri --trust-server-names --remote-encoding=iso-8859-1 -nH -r http://localhost:{{port}}/";
+
+ my $expected_error_code = 0;
+
+--- tests/Test-iri-list.px
++++ tests/Test-iri-list.px
+@@ -143,7 +143,7 @@ my %urls = (
+ },
+ );
+
+-my $cmdline = $WgetTest::WGETPATH . " --iri -i http://localhost:{{port}}/url_list.txt";
++my $cmdline = $WgetTest::WGETPATH . " --iri --trust-server-names -i http://localhost:{{port}}/url_list.txt";
+
+ my $expected_error_code = 0;
+
+--- tests/Test-iri.px
++++ tests/Test-iri.px
+@@ -186,7 +186,7 @@ my %urls = (
+ },
+ );
+
+-my $cmdline = $WgetTest::WGETPATH . " --iri --restrict-file-names=nocontrol -nH -r http://localhost:{{port}}/";
++my $cmdline = $WgetTest::WGETPATH . " --iri --trust-server-names --restrict-file-names=nocontrol -nH -r http://localhost:{{port}}/";
+
+ my $expected_error_code = 0;
+
diff --git a/net-misc/wget/wget-1.12-r2.ebuild b/net-misc/wget/wget-1.12-r2.ebuild
index f339e65ba118..0287d2d44249 100644
--- a/net-misc/wget/wget-1.12-r2.ebuild
+++ b/net-misc/wget/wget-1.12-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.12-r2.ebuild,v 1.1 2010/08/21 22:18:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.12-r2.ebuild,v 1.2 2010/08/22 18:00:16 vapier Exp $
EAPI="2"
@@ -27,10 +27,10 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-CVE-2010-2252.patch #329941
epatch "${FILESDIR}"/${PN}-1.12-linking.patch
epatch "${FILESDIR}"/${PN}-1.12-sni.patch #301312
epatch "${FILESDIR}"/${P}-debug-tests.patch #286173
+ epatch "${FILESDIR}"/${P}-CVE-2010-2252.patch #329941
}
src_configure() {