summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2007-10-19 09:33:39 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2007-10-19 09:33:39 +0000
commit38192b94c536c654fb5c1611a0965259d15beb64 (patch)
tree59ff44a482c53335e84a4cc46490acb3fef5697a
parentRe-added temporarily PROVIDE=virtual/lapack (diff)
downloadgentoo-2-38192b94c536c654fb5c1611a0965259d15beb64.tar.gz
gentoo-2-38192b94c536c654fb5c1611a0965259d15beb64.tar.bz2
gentoo-2-38192b94c536c654fb5c1611a0965259d15beb64.zip
Install vim and some stuff from contrib (related: bug #194940)
(Portage version: 2.1.3.9)
-rw-r--r--dev-util/git/ChangeLog7
-rw-r--r--dev-util/git/files/digest-git-1.5.3.4-r19
-rw-r--r--dev-util/git/git-1.5.3.4-r1.ebuild182
3 files changed, 197 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index b946bdd8dfa2..80cdb17708d9 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/git
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.228 2007/10/05 07:36:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.229 2007/10/19 09:33:38 ferdy Exp $
+
+*git-1.5.3.4-r1 (19 Oct 2007)
+
+ 19 Oct 2007; Fernando J. Pereda <ferdy@gentoo.org> +git-1.5.3.4-r1.ebuild:
+ Install vim and some stuff from contrib (related: bug #194940)
05 Oct 2007; Mike Frysinger <vapier@gentoo.org> git-1.5.3.4.ebuild:
Fix incorrect binding of iconv<->uclibc.
diff --git a/dev-util/git/files/digest-git-1.5.3.4-r1 b/dev-util/git/files/digest-git-1.5.3.4-r1
new file mode 100644
index 000000000000..4f736f79b032
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.5.3.4-r1
@@ -0,0 +1,9 @@
+MD5 b35fd5abba0e8655733c8e8c470f39cf git-1.5.3.4.tar.bz2 1349196
+RMD160 739153affbb5e5372bf5ccd8ea502bf3b6126903 git-1.5.3.4.tar.bz2 1349196
+SHA256 3f2954c68cc6463924a0af7ccb684db0332e3db31258e993830521532a7aa764 git-1.5.3.4.tar.bz2 1349196
+MD5 577f686fc8eed259e11e6d424134025a git-htmldocs-1.5.3.4.tar.bz2 542116
+RMD160 3a899140806b02413661cc5bad9e23c7ce683bfd git-htmldocs-1.5.3.4.tar.bz2 542116
+SHA256 1be968219cdac1ce6035bf81d42e24973ca6d4841f5d1775e6adebb52d44bbf8 git-htmldocs-1.5.3.4.tar.bz2 542116
+MD5 1cfaecc1e29cdccd6c595e2fca343ff9 git-manpages-1.5.3.4.tar.bz2 147392
+RMD160 49acd94b911b61b2581539985fad6723c56282e1 git-manpages-1.5.3.4.tar.bz2 147392
+SHA256 08861a12a0abb37e9156f5942154fe103db3232dc70e980152b61c197dcbce96 git-manpages-1.5.3.4.tar.bz2 147392
diff --git a/dev-util/git/git-1.5.3.4-r1.ebuild b/dev-util/git/git-1.5.3.4-r1.ebuild
new file mode 100644
index 000000000000..814baaecfa0f
--- /dev/null
+++ b/dev-util/git/git-1.5.3.4-r1.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.5.3.4-r1.ebuild,v 1.1 2007/10/19 09:33:38 ferdy Exp $
+
+inherit toolchain-funcs eutils elisp-common perl-module bash-completion vim-plugin
+
+MY_PV="${PV/_rc/.rc}"
+MY_P="${PN}-${MY_PV}"
+
+DOC_VER=${MY_PV}
+
+DESCRIPTION="GIT - the stupid content tracker, the revision control system heavily used by the Linux kernel team"
+HOMEPAGE="http://git.or.cz/"
+SRC_URI="mirror://kernel/software/scm/git/${MY_P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc emacs gtk iconv mozsha1 perl ppcsha1 tk vim webdav"
+
+DEPEND="
+ !app-misc/git
+ dev-libs/openssl
+ sys-libs/zlib
+ dev-lang/perl
+ tk? ( dev-lang/tk )
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ perl? ( dev-perl/Error )
+ gtk? ( >=dev-python/pygtk-2.8 )"
+
+SITEFILE=72${PN}-gentoo.el
+S="${WORKDIR}/${MY_P}"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ use iconv || myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+showpkgdeps() {
+ local pkg=$1
+ shift
+ elog " $(printf "%-17s:" ${pkg}) ${@}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.5.3-symlinks.patch
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ -e 's:ln :ln -s :g' \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || \
+ die "make install failed"
+
+ use tk || rm "${D}"/usr/bin/git{k,-gui}
+
+ doman "${WORKDIR}"/man?/*
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ dodoc Documentation/technical/*
+ dodir /usr/share/doc/${PF}/html
+ cp -r "${WORKDIR}"/{*.html,howto} "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ dobashcompletion contrib/completion/git-completion.bash ${PN}
+
+ if use emacs ; then
+ elisp-install ${PN} contrib/emacs/{,vc-}git.el* || \
+ die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ # don't add automatically to the load-path, so the sitefile
+ # can do a conditional loading
+ touch "${D}"/"${SITELISP}"/${PN}/.nosearch
+ fi
+
+ if use vim ; then
+ S="${S}"/contrib/vim vim-plugin_src_install
+ fi
+
+ if use gtk ; then
+ dobin "${S}"/contrib/gitview/gitview
+ use doc && dodoc "${S}"/contrib/gitview/gitview.txt
+ fi
+
+ dodir /usr/share/${PN}/contrib
+ cp -rf \
+ "${S}"/contrib/{stats,workdir,hg-to-git,fast-import,hooks} \
+ "${D}"/usr/share/${PN}/contrib
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+
+ fixlocalpod
+}
+
+src_test() {
+ cd "${S}"
+ has_version dev-util/subversion || \
+ MY_MAKEOPTS="${MY_MAKEOPTS} NO_SVN_TESTS=YesPlease"
+ has_version app-arch/unzip || \
+ rm "${S}"/t/t5000-tar-tree.sh
+ # Stupid CVS won't let some people commit as root
+ rm "${S}"/t/t9200-git-cvsexportcommit.sh
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ if use emacs ; then
+ elisp-site-regen
+ elog "GNU Emacs has built-in Git support in versions greater 22.1."
+ elog "You can disable the emacs USE flag for dev-util/git"
+ elog "if you are using such a version."
+ fi
+ elog "These additional scripts need some dependencies:"
+ echo
+ showpkgdeps git-archimport "dev-util/tla"
+ showpkgdeps git-cvsimport ">=dev-util/cvsps-2.1"
+ showpkgdeps git-svnimport "dev-util/subversion(USE=perl)"
+ showpkgdeps git-svn \
+ "dev-util/subversion(USE=perl)" \
+ "dev-perl/libwww-perl" \
+ "dev-perl/TermReadKey"
+ showpkgdeps git-quiltimport "dev-util/quilt"
+ showpkgdeps git-cvsserver "dev-perl/DBI" "dev-perl/DBD-SQLite"
+ showpkgdeps git-instaweb \
+ "|| ( www-servers/lighttpd www-servers/apache(SLOT=2) )"
+ showpkgdeps git-send-email "USE=perl"
+ showpkgdeps git-remote "USE=perl"
+ echo
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}