summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-10-18 15:19:20 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-10-18 15:19:20 +0000
commit3c478175e0efe0877a856f1a908d62fdd7aea044 (patch)
tree9e38861e8cfa32ef296ae3fe3621126c98277836
parentRemove old. (diff)
downloadgentoo-2-3c478175e0efe0877a856f1a908d62fdd7aea044.tar.gz
gentoo-2-3c478175e0efe0877a856f1a908d62fdd7aea044.tar.bz2
gentoo-2-3c478175e0efe0877a856f1a908d62fdd7aea044.zip
Migrate to distutils-r1. Bug #522654 thanks to Ian Delaney
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
-rw-r--r--dev-util/buildbot-slave/ChangeLog8
-rw-r--r--dev-util/buildbot-slave/buildbot-slave-0.8.9-r1.ebuild56
-rw-r--r--dev-util/buildbot-slave/buildbot-slave-9999.ebuild26
3 files changed, 72 insertions, 18 deletions
diff --git a/dev-util/buildbot-slave/ChangeLog b/dev-util/buildbot-slave/ChangeLog
index 27d2d2f59066..a4b58c20ba4d 100644
--- a/dev-util/buildbot-slave/ChangeLog
+++ b/dev-util/buildbot-slave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/buildbot-slave
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/ChangeLog,v 1.63 2014/10/02 20:30:27 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/ChangeLog,v 1.64 2014/10/18 15:19:20 hwoarang Exp $
+
+*buildbot-slave-0.8.9-r1 (18 Oct 2014)
+
+ 18 Oct 2014; Markos Chandras <hwoarang@gentoo.org>
+ +buildbot-slave-0.8.9-r1.ebuild, buildbot-slave-9999.ebuild:
+ Migrate to distutils-r1. Bug #522654 thanks to Ian Delaney
02 Oct 2014; Markos Chandras <hwoarang@gentoo.org>
buildbot-slave-0.8.9.ebuild:
diff --git a/dev-util/buildbot-slave/buildbot-slave-0.8.9-r1.ebuild b/dev-util/buildbot-slave/buildbot-slave-0.8.9-r1.ebuild
new file mode 100644
index 000000000000..eee1b963f318
--- /dev/null
+++ b/dev-util/buildbot-slave/buildbot-slave-0.8.9-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/buildbot-slave-0.8.9-r1.ebuild,v 1.1 2014/10/18 15:19:20 hwoarang Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1 readme.gentoo systemd user
+
+DESCRIPTION="BuildBot Slave Daemon"
+HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+PYTHON_MODNAME="buildslave"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewuser buildbot
+
+ DOC_CONTENTS="The \"buildbot\" user and the \"buildslave\" init script has been added
+ to support starting buildslave through Gentoo's init system. To use this,
+ set up your build slave following the documentation, make sure the
+ resulting directories are owned by the \"buildbot\" user and point
+ \"${ROOT}etc/conf.d/buildslave\" at the right location. The scripts can
+ run as a different user if desired. If you need to run more than one
+ build slave, just copy the scripts."
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman docs/buildslave.1
+
+ newconfd "${FILESDIR}/buildslave.confd" buildslave
+ newinitd "${FILESDIR}/buildslave.initd" buildslave
+ systemd_dounit "${FILESDIR}/buildslave.service"
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/dev-util/buildbot-slave/buildbot-slave-9999.ebuild b/dev-util/buildbot-slave/buildbot-slave-9999.ebuild
index 08cfb9559464..ebb7885ab3b3 100644
--- a/dev-util/buildbot-slave/buildbot-slave-9999.ebuild
+++ b/dev-util/buildbot-slave/buildbot-slave-9999.ebuild
@@ -1,17 +1,13 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/buildbot-slave-9999.ebuild,v 1.1 2013/09/11 20:22:04 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/buildbot-slave-9999.ebuild,v 1.2 2014/10/18 15:19:20 hwoarang Exp $
EAPI="5"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-DISTUTILS_SRC_TEST="trial buildslave"
-DISTUTILS_DISABLE_TEST_DEPENDENCY="1"
+PYTHON_COMPAT=( python2_7 )
EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
[[ ${PV} = 9999 ]] && inherit git-2
-inherit distutils readme.gentoo user
+inherit distutils-r1 readme.gentoo user
DESCRIPTION="BuildBot Slave Daemon"
HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"
@@ -29,19 +25,16 @@ else
fi
IUSE="test"
-RDEPEND="dev-python/setuptools
- dev-python/twisted-core
- !!<dev-util/buildbot-0.8.1
- !<dev-util/buildbot-0.8.3"
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- test? ( dev-python/mock )"
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
PYTHON_MODNAME="buildslave"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
- python_pkg_setup
enewuser buildbot
DOC_CONTENTS="The \"buildbot\" user and the \"buildslave\" init script has been added
@@ -55,12 +48,12 @@ pkg_setup() {
src_compile() {
[[ ${PV} = 9999 ]] && cd slave/
- distutils_src_compile
+ distutils-r1_src_compile
}
src_install() {
[[ ${PV} = 9999 ]] && cd slave/
- distutils_src_install
+ distutils-r1_src_install
doman docs/buildslave.1
@@ -72,6 +65,5 @@ src_install() {
pkg_postinst() {
[[ ${PV} = 9999 ]] && cd slave/
- distutils_pkg_postinst
readme.gentoo_print_elog
}