summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-07-28 00:38:40 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-07-28 00:38:40 +0000
commit3c51dd2a0bf9e6b3d289e2e143dbf5cf37551827 (patch)
tree0db33ffe3ddb0f8fbf25f74fde587f06d64a0296
parentdigest (diff)
downloadgentoo-2-3c51dd2a0bf9e6b3d289e2e143dbf5cf37551827.tar.gz
gentoo-2-3c51dd2a0bf9e6b3d289e2e143dbf5cf37551827.tar.bz2
gentoo-2-3c51dd2a0bf9e6b3d289e2e143dbf5cf37551827.zip
Initial import. Works on my box;)
-rw-r--r--dev-util/eclipse-cdt/ChangeLog8
-rw-r--r--dev-util/eclipse-cdt/Manifest4
-rw-r--r--dev-util/eclipse-cdt/eclipse-cdt-2.0.ebuild62
-rw-r--r--dev-util/eclipse-cdt/files/digest-eclipse-cdt-2.01
-rw-r--r--dev-util/eclipse-cdt/metadata.xml21
5 files changed, 96 insertions, 0 deletions
diff --git a/dev-util/eclipse-cdt/ChangeLog b/dev-util/eclipse-cdt/ChangeLog
new file mode 100644
index 000000000000..c91aae1c4e2b
--- /dev/null
+++ b/dev-util/eclipse-cdt/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-util/eclipse-cdt
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed unde the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-cdt/ChangeLog,v 1.1 2004/07/28 00:38:40 karltk Exp $
+
+*eclipse-cdt-2.0 (27 Jul 2004)
+
+ 27 Jul 2004; Karl Trygve Kalleberg <karltk@gentoo.org> eclipse-cdt-2.0.ebuild:
+ Initial import. Ebuild submitted by myself. Needs a lot of work still.
diff --git a/dev-util/eclipse-cdt/Manifest b/dev-util/eclipse-cdt/Manifest
new file mode 100644
index 000000000000..6d9990c9f444
--- /dev/null
+++ b/dev-util/eclipse-cdt/Manifest
@@ -0,0 +1,4 @@
+MD5 d83345de63885b8e0b14651834738b08 eclipse-cdt-2.0.ebuild 1017
+MD5 9acbb8df76c2e8d16617b496d84ad3c9 ChangeLog 287
+MD5 0637a933ecb6e8cedfc4ddfcf3491728 metadata.xml 310
+MD5 32737dc4e509b46595d20f5df9ce6e1d files/digest-eclipse-cdt-2.0 75
diff --git a/dev-util/eclipse-cdt/eclipse-cdt-2.0.ebuild b/dev-util/eclipse-cdt/eclipse-cdt-2.0.ebuild
new file mode 100644
index 000000000000..48be719ab973
--- /dev/null
+++ b/dev-util/eclipse-cdt/eclipse-cdt-2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-cdt/eclipse-cdt-2.0.ebuild,v 1.1 2004/07/28 00:38:40 karltk Exp $
+
+inherit eclipse-ext
+
+DESCRIPTION="Eclipse C/C++ Development Tools"
+HOMEPAGE="http://www.eclipse.org/cdt"
+SRC_URI="http://dev.gentoo.org/~karltk/projects/eclipse/distfiles/eclipse-cdt-2.0-gentoo.tar.gz"
+LICENSE="CPL-1.0"
+SLOT="2"
+KEYWORDS="-* ~x86"
+IUSE=""
+DEPEND=">=dev-util/eclipse-3.0.0"
+S=${WORKDIR}/${P}
+
+# karltk: A lot more work to do:
+# - make a better snapshot of the CVS
+# - remove the the CVS connects during build!
+# - fix the unzip hack
+# - use eclipse-ext
+# - add back other arches
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mkdir -p ${S}/results/eclipse-copy
+ (
+ cd ${S}/results/eclipse-copy
+ lndir -silent /usr/lib/eclipse-3
+ # getProtectionDomain().getCodeSource() my buttocks...
+ rm startup.jar ; cp /usr/lib/eclipse-3/startup.jar .
+ )
+ sed -e "s/name=\"buildId\" value=\"[^\"]*\"/name=\"buildId\" value=\"${P}_gentoo\"/" \
+ -e 's_name="zipsdir" value="[^"]*"_name="zipsdir" value="${buildDirectory}/final-result"_' \
+ -i build.xml
+}
+
+src_compile() {
+ # Use java-utils
+ addwrite /proc/cpuinfo
+ (
+ cd results/plugins/org.eclipse.cdt.core.linux/library || die
+ make ARCH=x86 all || die "Failed to compile platform-specific code"
+ )
+ ./build.sh || die "Failed to compile"
+}
+
+src_install() {
+ if [ ! -f results/I.eclipse-cdt-2.0_gentoo/org.eclipse.cdt-2.1.0-eclipse-cdt-2.0_gentoo-linux.x86.zip ] ; then
+ die "Compilation of final SDK zip failed"
+ fi
+
+ dodir /usr/lib/eclipse-3
+
+ # Nasty!
+ unzip results/I.eclipse-cdt-2.0_gentoo/org.eclipse.cdt-2.1.0-eclipse-cdt-2.0_gentoo-linux.x86.zip \
+ -d ${D}/usr/lib/eclipse-3
+ mv ${D}/usr/lib/eclipse-3/eclipse/{features,plugins} ${D}/usr/lib/eclipse-3
+ rmdir ${D}/usr/lib/eclipse-3/eclipse
+}
+
diff --git a/dev-util/eclipse-cdt/files/digest-eclipse-cdt-2.0 b/dev-util/eclipse-cdt/files/digest-eclipse-cdt-2.0
new file mode 100644
index 000000000000..2f5bd3c1281e
--- /dev/null
+++ b/dev-util/eclipse-cdt/files/digest-eclipse-cdt-2.0
@@ -0,0 +1 @@
+MD5 c0238a29f9447cb998bcbc2f782d6753 eclipse-cdt-2.0-gentoo.tar.gz 7618341
diff --git a/dev-util/eclipse-cdt/metadata.xml b/dev-util/eclipse-cdt/metadata.xml
new file mode 100644
index 000000000000..6d2d9758c658
--- /dev/null
+++ b/dev-util/eclipse-cdt/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+The CDT (C/C++ Development Tools) Project is working towards providing a fully
+functional C and C++ Integrated Development Environment (IDE) for the Eclipse
+platform.
+
+Features:
+* C/C++ Editor (basic functionality, syntax highlighting, code completion etc.)
+* C/C++ Debugger (APIs & Default implementation, using GDB)
+* C/C++ Launcher (APIs & Default implementation, launches and external application)
+* Parser
+* Search Engine
+* Content Assist Provider
+* Makefile generator
+</longdescription>
+</pkgmetadata>