summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-02-15 20:45:27 +0000
committerPacho Ramos <pacho@gentoo.org>2013-02-15 20:45:27 +0000
commit41b4c8376f55937be25385979e5cee1231a2e570 (patch)
treeda66ae126f408a368c9d512f97e3940e9a11481b
parentDepend on app-text/texlive so that the linguas and useflag logic can be reuse... (diff)
downloadgentoo-2-41b4c8376f55937be25385979e5cee1231a2e570.tar.gz
gentoo-2-41b4c8376f55937be25385979e5cee1231a2e570.tar.bz2
gentoo-2-41b4c8376f55937be25385979e5cee1231a2e570.zip
Don't show elog messages always (#457596)
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
-rw-r--r--dev-util/buildbot/ChangeLog5
-rw-r--r--dev-util/buildbot/buildbot-0.8.7_p1-r1.ebuild23
2 files changed, 17 insertions, 11 deletions
diff --git a/dev-util/buildbot/ChangeLog b/dev-util/buildbot/ChangeLog
index 8109e180d0b8..3b4bdf22b9e6 100644
--- a/dev-util/buildbot/ChangeLog
+++ b/dev-util/buildbot/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/buildbot
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.122 2013/02/06 18:15:35 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.123 2013/02/15 20:45:27 pacho Exp $
+
+ 15 Feb 2013; Pacho Ramos <pacho@gentoo.org> buildbot-0.8.7_p1-r1.ebuild:
+ Don't show elog messages always (#457596)
*buildbot-0.8.7_p1-r1 (06 Feb 2013)
diff --git a/dev-util/buildbot/buildbot-0.8.7_p1-r1.ebuild b/dev-util/buildbot/buildbot-0.8.7_p1-r1.ebuild
index 439f48d47890..334cd8283f33 100644
--- a/dev-util/buildbot/buildbot-0.8.7_p1-r1.ebuild
+++ b/dev-util/buildbot/buildbot-0.8.7_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.8.7_p1-r1.ebuild,v 1.1 2013/02/06 18:15:35 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.8.7_p1-r1.ebuild,v 1.2 2013/02/15 20:45:27 pacho Exp $
EAPI="5"
PYTHON_DEPEND="2"
@@ -9,7 +9,7 @@ RESTRICT_PYTHON_ABIS="3.* *-jython"
DISTUTILS_SRC_TEST="trial"
DISTUTILS_DISABLE_TEST_DEPENDENCY="1"
-inherit distutils user
+inherit distutils readme.gentoo user
MY_PV="${PV/_p/p}"
MY_P="${PN}-${MY_PV}"
@@ -49,6 +49,14 @@ S="${WORKDIR}/${MY_P}"
pkg_setup() {
python_pkg_setup
enewuser buildbot
+
+ DOC_CONTENTS="The \"buildbot\" user and the \"buildmaster\" init script has been added
+ to support starting buildbot through Gentoo's init system. To use this,
+ set up your build master following the documentation, make sure the
+ resulting directories are owned by the \"buildbot\" user and point
+ \"${EROOT}etc/conf.d/buildmaster\" at the right location. The scripts can
+ run as a different user if desired. If you need to run more than one
+ build master, just copy the scripts."
}
src_compile() {
@@ -92,18 +100,13 @@ src_install() {
echo "CONFIG_PROTECT=\"${cp}\"" \
> 85${PN} || die
doenvd 85${PN}
+
+ readme.gentoo_create_doc
}
pkg_postinst() {
distutils_pkg_postinst
-
- elog "The \"buildbot\" user and the \"buildmaster\" init script has been added"
- elog "to support starting buildbot through Gentoo's init system. To use this,"
- elog "set up your build master following the documentation, make sure the"
- elog "resulting directories are owned by the \"buildbot\" user and point"
- elog "\"${EROOT}etc/conf.d/buildmaster\" at the right location. The scripts can"
- elog "run as a different user if desired. If you need to run more than one"
- elog "build master, just copy the scripts."
+ readme.gentoo_print_elog
elog
elog "Upstream recommends the following when upgrading:"
elog "Each time you install a new version of Buildbot, you should run the"