summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-14 12:43:55 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-14 12:43:55 +0000
commit43d8b3fe111139369bc49d80e634f27aded55320 (patch)
treeda21f2b624784f500db33393d8953ba40483c36f
parentdrop old (diff)
downloadgentoo-2-43d8b3fe111139369bc49d80e634f27aded55320.tar.gz
gentoo-2-43d8b3fe111139369bc49d80e634f27aded55320.tar.bz2
gentoo-2-43d8b3fe111139369bc49d80e634f27aded55320.zip
drop old
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--dev-python/traits/ChangeLog6
-rw-r--r--dev-python/traits/traits-3.6.0.ebuild63
-rw-r--r--dev-python/traits/traits-4.0.0.ebuild54
-rw-r--r--dev-python/traits/traits-4.1.0.ebuild59
-rw-r--r--dev-python/traits/traits-4.2.0.ebuild59
5 files changed, 5 insertions, 236 deletions
diff --git a/dev-python/traits/ChangeLog b/dev-python/traits/ChangeLog
index 59b63b2714e1..b978296a2184 100644
--- a/dev-python/traits/ChangeLog
+++ b/dev-python/traits/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/traits
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/ChangeLog,v 1.38 2013/04/11 06:12:54 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/ChangeLog,v 1.39 2013/05/14 12:43:55 idella4 Exp $
+
+ 14 May 2013; Ian Delaney <idella4@gentoo.org> -traits-3.6.0.ebuild,
+ -traits-4.0.0.ebuild, -traits-4.1.0.ebuild, -traits-4.2.0.ebuild:
+ drop old
*traits-4.3.0-r1 (11 Apr 2013)
diff --git a/dev-python/traits/traits-3.6.0.ebuild b/dev-python/traits/traits-3.6.0.ebuild
deleted file mode 100644
index 1fcb5862284e..000000000000
--- a/dev-python/traits/traits-3.6.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-3.6.0.ebuild,v 1.6 2012/02/21 12:24:57 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit distutils
-
-MY_PN="Traits"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="http://code.enthought.com/projects/traits/ http://pypi.python.org/pypi/Traits"
-SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86"
-IUSE="doc examples"
-
-RDEPEND=">=dev-python/enthoughtbase-3.1.0
- >=dev-python/numpy-1.1
- dev-python/setuptools"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="docs/*.txt"
-PYTHON_MODNAME="enthought"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_install() {
- find -name "*LICENSE.txt" -delete
- distutils_src_install
-
- if use doc; then
- pushd docs/build/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _images _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/* || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/traits/traits-4.0.0.ebuild b/dev-python/traits/traits-4.0.0.ebuild
deleted file mode 100644
index df6f3119248e..000000000000
--- a/dev-python/traits/traits-4.0.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-4.0.0.ebuild,v 1.3 2012/02/21 12:24:57 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="http://code.enthought.com/projects/traits/ http://pypi.python.org/pypi/traits"
-SRC_URI="http://www.enthought.com/repo/ETS/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/numpy"
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )
- test? ( dev-python/numpy )"
-
-DOCS="docs/*.txt"
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_install() {
- find -name "*LICENSE*.txt" -delete
- distutils_src_install
-
- if use doc; then
- pushd docs/build/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/traits/traits-4.1.0.ebuild b/dev-python/traits/traits-4.1.0.ebuild
deleted file mode 100644
index b54a89a39e1e..000000000000
--- a/dev-python/traits/traits-4.1.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-4.1.0.ebuild,v 1.6 2012/11/20 20:34:42 ago Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils virtualx
-
-DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="http://code.enthought.com/projects/traits/ http://pypi.python.org/pypi/traits"
-SRC_URI="http://www.enthought.com/repo/ETS/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/numpy"
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )
- test? ( dev-python/numpy )"
-
-DOCS="docs/*.txt"
-
-src_prepare() {
- sed -i -e "s/'-O3'//g" setup.py
-}
-
-src_compile() {
- distutils_src_compile
- use doc && virtualmake -C docs html
-}
-
-src_test() {
- testing() {
- local exit_status=0
- pushd $(find build-${PYTHON_ABI}/ -name "${PN}") > /dev/null
- PYTHONPATH=. nosetests -v tests || exit_status=1
- popd > /dev/null
- return $exit_status
- }
- python_execute_function testing
-}
-
-src_install() {
- find -name "*LICENSE*.txt" -delete
- distutils_src_install
-
- use doc && dohtml -r docs/build/html/*
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/traits/traits-4.2.0.ebuild b/dev-python/traits/traits-4.2.0.ebuild
deleted file mode 100644
index e178d97d836d..000000000000
--- a/dev-python/traits/traits-4.2.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traits/traits-4.2.0.ebuild,v 1.4 2012/12/06 17:38:45 bicatali Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils virtualx
-
-DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="http://code.enthought.com/projects/traits/ http://pypi.python.org/pypi/traits"
-SRC_URI="http://www.enthought.com/repo/ETS/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/numpy"
-DEPEND="dev-python/setuptools
- doc? ( dev-python/sphinx )
- test? ( dev-python/numpy )"
-
-DOCS="docs/*.txt"
-
-src_prepare() {
- sed -i -e "s/'-O3'//g" setup.py
-}
-
-src_compile() {
- distutils_src_compile
- use doc && virtualmake -C docs html
-}
-
-src_test() {
- testing() {
- local exit_status=0
- pushd $(find build-${PYTHON_ABI}/ -name "${PN}") > /dev/null
- PYTHONPATH=. nosetests -v tests || exit_status=1
- popd > /dev/null
- return $exit_status
- }
- python_execute_function testing
-}
-
-src_install() {
- find -name "*LICENSE*.txt" -delete
- distutils_src_install
-
- use doc && dohtml -r docs/build/html/*
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}