summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-01-23 21:03:55 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-01-23 21:03:55 +0000
commit445fde062df74acea88e7e90fc84e911fcfbeb57 (patch)
tree086892da7d7d880ef6af5ddce422cf6e18e37ec9
parentCleanup PNP logic. (diff)
downloadgentoo-2-445fde062df74acea88e7e90fc84e911fcfbeb57.tar.gz
gentoo-2-445fde062df74acea88e7e90fc84e911fcfbeb57.tar.bz2
gentoo-2-445fde062df74acea88e7e90fc84e911fcfbeb57.zip
Remove cdparanoia local flag.
(Portage version: 2.0.51-r14)
-rw-r--r--kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-3.4.0_beta1.ebuild9
-rw-r--r--kde-base/kdemultimedia/kdemultimedia-3.4.0_beta1.ebuild8
-rw-r--r--kde-base/mpeglib/mpeglib-3.4.0_beta1.ebuild8
3 files changed, 12 insertions, 13 deletions
diff --git a/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-3.4.0_beta1.ebuild b/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-3.4.0_beta1.ebuild
index c33ce2305019..76b513be0778 100644
--- a/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-3.4.0_beta1.ebuild
+++ b/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-3.4.0_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-3.4.0_beta1.ebuild,v 1.1 2005/01/15 02:24:30 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-3.4.0_beta1.ebuild,v 1.2 2005/01/23 21:02:29 greg_g Exp $
KMNAME=kdemultimedia
KMMODULE=kioslave
@@ -10,20 +10,19 @@ inherit kde-meta eutils
DESCRIPTION="kioslaves from kdemultimedia package"
KEYWORDS="~x86"
-IUSE="oggvorbis flac encode cdparanoia"
+IUSE="oggvorbis flac encode"
DEPEND="$(deprange-dual $PV $MAXKDEVER kde-base/libkcddb)
media-sound/cdparanoia
media-libs/taglib
oggvorbis? ( media-libs/libvorbis )
flac? ( media-libs/flac )
- encode? ( media-sound/lame )
- cdparanoia? ( media-sound/cdparanoia )"
+ encode? ( media-sound/lame )"
KMCOPYLIB="libkcddb libkcddb"
KMEXTRACTONLY="kdemultimedia-3.3.0/akode/configure.in.in"
KMCOMPILEONLY="libkcddb/"
src_compile() {
- myconf="$(use_with cdparanoia) $(use_enable cdparanoia)"
+ myconf="--with-cdparanoia --enable-cdparanoia"
use oggvorbis && myconf="$myconf --with-vorbis=/usr" || myconf="$myconf --without-vorbis"
DO_NOT_COMPILE=libkcddb kde-meta_src_compile myconf configure
cd $S/libkcddb && make configbase.h
diff --git a/kde-base/kdemultimedia/kdemultimedia-3.4.0_beta1.ebuild b/kde-base/kdemultimedia/kdemultimedia-3.4.0_beta1.ebuild
index 921177de70c6..1410ec5c35c8 100644
--- a/kde-base/kdemultimedia/kdemultimedia-3.4.0_beta1.ebuild
+++ b/kde-base/kdemultimedia/kdemultimedia-3.4.0_beta1.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.4.0_beta1.ebuild,v 1.4 2005/01/20 16:34:42 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.4.0_beta1.ebuild,v 1.5 2005/01/23 21:01:00 greg_g Exp $
inherit kde-dist flag-o-matic
DESCRIPTION="KDE multimedia apps: noatun, kscd, juk..."
KEYWORDS="~x86"
-IUSE="alsa audiofile cdparanoia encode flac gstreamer oggvorbis speex theora xine"
+IUSE="alsa audiofile encode flac gstreamer oggvorbis speex theora xine"
DEPEND="~kde-base/kdebase-${PV}
+ media-sound/cdparanoia
audiofile? ( media-libs/audiofile )
- cdparanoia? ( media-sound/cdparanoia )
flac? ( media-libs/flac )
encode? ( media-sound/lame )
oggvorbis? ( media-sound/vorbis-tools )
@@ -29,7 +29,7 @@ src_compile() {
use xine && myconf="$myconf --with-xine-prefix=/usr"
use xine || DO_NOT_COMPILE="$DO_NOT_COMPILE xine_artsplugin"
- myconf="${myconf} $(use_with cdparanoia)"
+ myconf="${myconf} --with-cdparanoia --enable-cdparanoia"
# make -j2 fails, at least on ppc
use ppc && export MAKEOPTS="$MAKEOPTS -j1"
diff --git a/kde-base/mpeglib/mpeglib-3.4.0_beta1.ebuild b/kde-base/mpeglib/mpeglib-3.4.0_beta1.ebuild
index f0527fec839c..8cbc25d7dd4c 100644
--- a/kde-base/mpeglib/mpeglib-3.4.0_beta1.ebuild
+++ b/kde-base/mpeglib/mpeglib-3.4.0_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/mpeglib/mpeglib-3.4.0_beta1.ebuild,v 1.1 2005/01/15 02:24:41 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/mpeglib/mpeglib-3.4.0_beta1.ebuild,v 1.2 2005/01/23 21:03:55 greg_g Exp $
KMNAME=kdemultimedia
MAXKDEVER=$PV
@@ -9,11 +9,11 @@ inherit kde-meta eutils
DESCRIPTION="KDE mpeg library"
KEYWORDS="~x86"
-IUSE="cdparanoia"
-DEPEND="cdparanoia? ( media-sound/cdparanoia )"
+IUSE=""
+DEPEND="media-sound/cdparanoia"
if [ "${ARCH}" != "amd64" ] ; then
PATCHES="${FILESDIR}/kdemultimedia-64bit.patch"
fi
-myconf="$(use_with cdparanoia) $(use_enable cdparanoia)"
+myconf="--with-cdparanoia --enable-cdparanoia"