summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-07-12 02:59:19 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-07-12 02:59:19 +0000
commit44a55ad0922062c8ec9c8423b2f760b95130134f (patch)
treeaa5afe628443f302bf6dafd269e470613580f373
parentRemove the mask of the developmental MythTV ebuild (diff)
downloadgentoo-2-44a55ad0922062c8ec9c8423b2f760b95130134f.tar.gz
gentoo-2-44a55ad0922062c8ec9c8423b2f760b95130134f.tar.bz2
gentoo-2-44a55ad0922062c8ec9c8423b2f760b95130134f.zip
Version bump
(Portage version: 2.1.10.65/cvs/Linux x86_64)
-rw-r--r--www-apps/mythweb/ChangeLog9
-rw-r--r--www-apps/mythweb/files/mythweb-0.22_p22763-ao-click.patch13
-rw-r--r--www-apps/mythweb/files/postinstall-en-0.20.txt16
-rw-r--r--www-apps/mythweb/files/postinstall-en-0.21.txt12
-rw-r--r--www-apps/mythweb/mythweb-0.25.1.ebuild60
5 files changed, 68 insertions, 42 deletions
diff --git a/www-apps/mythweb/ChangeLog b/www-apps/mythweb/ChangeLog
index 649b322dc9de..33e8a9bee85b 100644
--- a/www-apps/mythweb/ChangeLog
+++ b/www-apps/mythweb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/mythweb
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.90 2012/07/10 04:38:34 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.91 2012/07/12 02:59:19 cardoe Exp $
+
+*mythweb-0.25.1 (11 Jul 2012)
+
+ 11 Jul 2012; Doug Goldstein <cardoe@gentoo.org>
+ -files/postinstall-en-0.20.txt, -files/postinstall-en-0.21.txt,
+ -files/mythweb-0.22_p22763-ao-click.patch, +mythweb-0.25.1.ebuild:
+ Version bump
09 Jul 2012; Doug Goldstein <cardoe@gentoo.org>
mythweb-0.24_p20110310.ebuild:
diff --git a/www-apps/mythweb/files/mythweb-0.22_p22763-ao-click.patch b/www-apps/mythweb/files/mythweb-0.22_p22763-ao-click.patch
deleted file mode 100644
index 25f6e7b553f6..000000000000
--- a/www-apps/mythweb/files/mythweb-0.22_p22763-ao-click.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: mythplugins/mythweb/modules/tv/tmpl/default/_advanced_options.php
-===================================================================
---- mythplugins/mythweb/modules/tv/tmpl/default/_advanced_options.php (revision 22859)
-+++ mythplugins/mythweb/modules/tv/tmpl/default/_advanced_options.php (working copy)
-@@ -29,7 +29,7 @@
-
- <h3><?php echo t('Advanced Options') ?>:</h3>
- (<?php
-- echo '<a href="#" onclick="toggle_advanced(false)" id="hide_advanced"';
-+ echo '<a onclick="toggle_advanced(false)" id="hide_advanced"';
- if (!$_SESSION['tv']['show_advanced_schedule'])
- echo ' style="display: none"';
- echo '>', t('Hide'), '</a>',
diff --git a/www-apps/mythweb/files/postinstall-en-0.20.txt b/www-apps/mythweb/files/postinstall-en-0.20.txt
deleted file mode 100644
index e3d7f7962b44..000000000000
--- a/www-apps/mythweb/files/postinstall-en-0.20.txt
+++ /dev/null
@@ -1,16 +0,0 @@
-You should modify ${MY_INSTALLDIR}/.htaccess to fit your needs.
-
-****************************************************
-In order to prevent unauthorized access to your Myth
-installation, MythWeb has been installed requiring
-authentication by default but with no valid users.
-You can add users by using these instructions:
-
-Run htpasswd2 as follows to set your username and
-password.
-
-# htpasswd2 -c ${MY_INSTALLDIR}/.htpasswd <username>
-
-If you already have an .htpasswd file you'd like to
-use, copy it to ${MY_INSTALLDIR}
-*****************************************************
diff --git a/www-apps/mythweb/files/postinstall-en-0.21.txt b/www-apps/mythweb/files/postinstall-en-0.21.txt
deleted file mode 100644
index 623c103f46f7..000000000000
--- a/www-apps/mythweb/files/postinstall-en-0.21.txt
+++ /dev/null
@@ -1,12 +0,0 @@
-****************************************************
-You probably want to modify
-${MY_SERVERCONFIGDIR}/mythweb.conf.apache
-to fit your needs and create a symlink to it as
-/etc/apache2/modules.d/mythweb.conf
-****************************************************
-In order to prevent unauthorized access to your Myth
-installation, MythWeb can be configured to require
-authentication using htdigest. The apache controls for
-doing this are commented out in mythweb.conf.apache
-by default.
-*****************************************************
diff --git a/www-apps/mythweb/mythweb-0.25.1.ebuild b/www-apps/mythweb/mythweb-0.25.1.ebuild
new file mode 100644
index 000000000000..2a664ffa1738
--- /dev/null
+++ b/www-apps/mythweb/mythweb-0.25.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.25.1.ebuild,v 1.1 2012/07/12 02:59:19 cardoe Exp $
+
+EAPI=4
+
+inherit webapp depend.php
+
+# Release version
+MY_PV="${PV%_*}"
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser."
+HOMEPAGE="http://www.mythtv.org"
+LICENSE="GPL-2"
+SRC_URI="ftp://ftp.osuosl.org/pub/mythtv/mythplugins-${MY_PV}.tar.bz2"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-lang/php:5.3[json,mysql,session,posix]
+ dev-perl/DBI
+ dev-perl/DBD-mysql
+ dev-perl/HTTP-Date
+ dev-perl/Net-UPnP"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/mythplugins-${MY_PV}/${PN}"
+
+need_httpd_cgi
+need_php5_httpd
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cd "${S}"
+ dodoc README INSTALL
+
+ dodir "${MY_HTDOCSDIR}"/data
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]*
+
+ webapp_configfile "${MY_HTDOCSDIR}"/mythweb.conf.{apache,lighttpd}
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/data
+
+ webapp_postinst_txt en "${FILESDIR}"/0.24-postinstall-en.txt
+
+ webapp_src_install
+
+ fperms 755 /usr/share/webapps/mythweb/${PV}/htdocs/mythweb.pl
+}