summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-01-21 17:19:43 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-01-21 17:19:43 +0000
commit4795299e249ca9f09d8a991e419f7891208dd09f (patch)
tree4728ba16d03a4c1083ea835984db8062c181ba95
parentVersion Bump. (diff)
downloadgentoo-2-4795299e249ca9f09d8a991e419f7891208dd09f.tar.gz
gentoo-2-4795299e249ca9f09d8a991e419f7891208dd09f.tar.bz2
gentoo-2-4795299e249ca9f09d8a991e419f7891208dd09f.zip
Fixed issues with duplicated CODON files, case-insensitive filesystems (ppc-macos) and restriction enzymes equivalences (see bugs #118832 and #115446)
(Portage version: 2.0.53)
-rw-r--r--sci-biology/emboss/ChangeLog13
-rw-r--r--sci-biology/emboss/Manifest2
-rw-r--r--sci-biology/emboss/emboss-3.0.0-r1.ebuild80
-rw-r--r--sci-biology/emboss/files/digest-emboss-3.0.0-r11
-rw-r--r--sci-biology/rebase/ChangeLog8
-rw-r--r--sci-biology/rebase/Manifest2
-rw-r--r--sci-biology/rebase/files/digest-rebase-601-r11
-rw-r--r--sci-biology/rebase/rebase-601-r1.ebuild43
8 files changed, 147 insertions, 3 deletions
diff --git a/sci-biology/emboss/ChangeLog b/sci-biology/emboss/ChangeLog
index 3e860d6d3867..99d686c9f63a 100644
--- a/sci-biology/emboss/ChangeLog
+++ b/sci-biology/emboss/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-biology/emboss
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.24 2005/12/14 03:28:52 spyderous Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.25 2006/01/21 17:19:43 ribosome Exp $
+
+*emboss-3.0.0-r1 (21 Jan 2006)
+
+ 21 Jan 2006; Olivier Fisette <ribosome@gentoo.org>
+ +emboss-3.0.0-r1.ebuild:
+ Install codons and restriction enzyme equivalence files in alternative
+ directories. This avoids file collisions on case insensitive filesystems
+ (see bug #115446), allows the installation of an updated enzyme prototypes
+ file that will give more consistent results (see bug #118832).
14 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>; emboss-3.0.0.ebuild:
Add modular X dependencies.
diff --git a/sci-biology/emboss/Manifest b/sci-biology/emboss/Manifest
index 02c46adea9d5..5031a68e7fc5 100644
--- a/sci-biology/emboss/Manifest
+++ b/sci-biology/emboss/Manifest
@@ -1,5 +1,7 @@
MD5 6747fe89baf91e10880d44ecd28bd5f3 ChangeLog 5216
+MD5 12a9ce7a5e8cecb45348e897130fa529 emboss-3.0.0-r1.ebuild 2926
MD5 ecb49ecef824e368a8ad751b90f19186 emboss-3.0.0.ebuild 1854
MD5 ef2dfa3d13837026f59c0cf5f04f67c5 files/22emboss-r1 110
MD5 84fbde044d74a82c084fa22d5d59ae8e files/digest-emboss-3.0.0 66
+MD5 84fbde044d74a82c084fa22d5d59ae8e files/digest-emboss-3.0.0-r1 66
MD5 6051afb1f26bf343082490327784b958 metadata.xml 1013
diff --git a/sci-biology/emboss/emboss-3.0.0-r1.ebuild b/sci-biology/emboss/emboss-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..3f27832a6330
--- /dev/null
+++ b/sci-biology/emboss/emboss-3.0.0-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-3.0.0-r1.ebuild,v 1.1 2006/01/21 17:19:43 ribosome Exp $
+
+DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
+HOMEPAGE="http://emboss.sourceforge.net/"
+SRC_URI="ftp://${PN}.open-bio.org/pub/EMBOSS/EMBOSS-${PV}.tar.gz"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~ppc64 ~x86"
+IUSE="X png minimal"
+
+DEPEND="X? ( || ( x11-libs/libXt virtual/x11 ) )
+ png? (
+ sys-libs/zlib
+ media-libs/libpng
+ >=media-libs/gd-1.8
+ )
+ !minimal? (
+ sci-biology/primer3
+ sci-biology/clustalw
+ )"
+
+PDEPEND="!minimal? (
+ sci-biology/aaindex
+ sci-biology/cutg
+ sci-biology/prints
+ >=sci-biology/prosite-19.7
+ >=sci-biology/rebase-601-r1
+ sci-biology/transfac
+ )"
+
+S=${WORKDIR}/EMBOSS-${PV}
+
+src_compile() {
+ EXTRA_CONF="--includedir=${D}/usr/include/emboss"
+ ! use X && EXTRA_CONF="${EXTRA_CONF} --without-x"
+ ! use png && EXTRA_CONF="${EXTRA_CONF} --without-pngdriver"
+
+ econf ${EXTRA_CONF} || die
+ # Do not install the JEMBOSS component (the --without-java configure option
+ # does not work). JEMBOSS will be available as a separate package.
+ sed -i -e 's/SUBDIRS = plplot ajax nucleus emboss test doc jemboss/SUBDIRS = plplot ajax nucleus emboss test doc/' Makefile || die
+ emake || die
+}
+
+src_install() {
+ einstall || die "Failed to install program files."
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS "${FILESDIR}"/README.Gentoo \
+ || die "Failed to install documentation."
+
+ # Install env file for setting libplplot and acd files path.
+ insinto /etc/env.d
+ newins ${FILESDIR}/22emboss-r1 22emboss || \
+ die "Failed to install environment file."
+
+ # Symlink preinstalled docs to /usr/share/doc.
+ dosym /usr/share/EMBOSS/doc/manuals /usr/share/doc/${PF}/manuals || die
+ dosym /usr/share/EMBOSS/doc/programs /usr/share/doc/${PF}/programs || die
+ dosym /usr/share/EMBOSS/doc/tutorials /usr/share/doc/${PF}/tutorials || die
+
+ # Remove useless dummy files from the image.
+ rm "${D}"/usr/share/EMBOSS/data/{AAINDEX,PRINTS,PROSITE,REBASE}/dummyfile \
+ || die "Failed to remove dummy files."
+
+ # Move the provided codon files to a different directory. This will avoid
+ # user confusion and file collisions on case-insensitive file systems (see
+ # bug #115446). This change is documented in "README.Gentoo".
+ mv "${D}"/usr/share/EMBOSS/data/CODONS \
+ "${D}"/usr/share/EMBOSS/data/CODONS.orig || \
+ die "Failed to move CODON directory."
+
+ # Move the provided restriction enzyme prototypes file to a different name.
+ # This will avoid file collisions with future versions of rebase that will
+ # install their own enzyme prototypes file (see bug #118832).
+ mv "${D}"/usr/share/EMBOSS/data/embossre.equ \
+ "${D}"/usr/share/EMBOSS/data/embossre.equ.orig || \
+ die "Failed to move enzyme equivalence file."
+}
diff --git a/sci-biology/emboss/files/digest-emboss-3.0.0-r1 b/sci-biology/emboss/files/digest-emboss-3.0.0-r1
new file mode 100644
index 000000000000..5dfd3480a664
--- /dev/null
+++ b/sci-biology/emboss/files/digest-emboss-3.0.0-r1
@@ -0,0 +1 @@
+MD5 fa72feded9ab9272e3e731c09f545dcc EMBOSS-3.0.0.tar.gz 16257908
diff --git a/sci-biology/rebase/ChangeLog b/sci-biology/rebase/ChangeLog
index bcc87a245910..f7c2a8b74e07 100644
--- a/sci-biology/rebase/ChangeLog
+++ b/sci-biology/rebase/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/rebase
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.51 2006/01/18 21:28:24 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.52 2006/01/21 17:19:43 ribosome Exp $
+
+*rebase-601-r1 (21 Jan 2006)
+
+ 21 Jan 2006; Olivier Fisette <ribosome@gentoo.org> +rebase-601-r1.ebuild:
+ Install an enzymes prototypes file, replacing the one distributed with
+ EMBOSS. This will solve the inconsistencies reported in bug #118832.
18 Jan 2006; Markus Rothe <corsair@gentoo.org> rebase-512.ebuild:
Stable on ppc64; bug #118832
diff --git a/sci-biology/rebase/Manifest b/sci-biology/rebase/Manifest
index 9db7760c6724..e5af18ff6bb0 100644
--- a/sci-biology/rebase/Manifest
+++ b/sci-biology/rebase/Manifest
@@ -3,8 +3,10 @@ MD5 8b72021e3a53e0c9ab7acaf2d016637e files/digest-rebase-509 63
MD5 de0923d154ca7a32f45ee6bb9d3a40c4 files/digest-rebase-511 63
MD5 0327e485fe0040317dd1016583b0d76d files/digest-rebase-512 63
MD5 9b37c587b84cf914d6f9a9b616c493db files/digest-rebase-601 63
+MD5 9b37c587b84cf914d6f9a9b616c493db files/digest-rebase-601-r1 63
MD5 550f8d428f3e75690b43d32df6aa60cd metadata.xml 900
MD5 b4f7769279c4301bacb9c4b78f136d08 rebase-509.ebuild 1097
MD5 fe94217aa8122be5dc5855d73772d8b0 rebase-511.ebuild 1237
MD5 292928f0068bac8ab37a29c223af581e rebase-512.ebuild 1238
+MD5 ef9d51f417289656336e9f1f26edf920 rebase-601-r1.ebuild 1360
MD5 ac62c4563f22a49719f3623d9e163ce1 rebase-601.ebuild 1244
diff --git a/sci-biology/rebase/files/digest-rebase-601-r1 b/sci-biology/rebase/files/digest-rebase-601-r1
new file mode 100644
index 000000000000..514623f4bd95
--- /dev/null
+++ b/sci-biology/rebase/files/digest-rebase-601-r1
@@ -0,0 +1 @@
+MD5 473a812ec6119fb8b02ac3e0bfec6884 rebase-601.tar.bz2 181829
diff --git a/sci-biology/rebase/rebase-601-r1.ebuild b/sci-biology/rebase/rebase-601-r1.ebuild
new file mode 100644
index 000000000000..8cb1c680615e
--- /dev/null
+++ b/sci-biology/rebase/rebase-601-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-601-r1.ebuild,v 1.1 2006/01/21 17:19:43 ribosome Exp $
+
+DESCRIPTION="A restriction enzyme database"
+LICENSE="public-domain"
+HOMEPAGE="http://rebase.neb.com"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="~x86 ~ppc ~amd64 ~ppc-macos ~ppc64"
+
+DEPEND="emboss? ( >=sci-biology/emboss-3.0.0-r1 )"
+
+src_compile() {
+ if use emboss; then
+ echo
+ einfo "Indexing ${PN} for usage with EMBOSS."
+ mkdir REBASE
+ EMBOSS_DATA=. rebaseextract -auto -infile withrefm.${PV} \
+ -protofile proto.${PV} || die "Indexing ${PN} failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins withrefm.${PV} proto.${PV} || die \
+ "Failed to install raw database."
+ fi
+ newdoc REBASE.DOC README || die "Failed to install documentation."
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/REBASE
+ doins REBASE/{embossre.enz,embossre.ref,embossre.sup} || die \
+ "Failed to install EMBOSS data files."
+ insinto /usr/share/EMBOSS/data
+ doins embossre.equ || die "Failed to install enzyme prototypes file."
+ fi
+}