summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-24 00:23:17 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-24 00:23:17 +0000
commit47b7bb8d8c4c6776170a9424c9f55632a85e2986 (patch)
tree10dfe7c1c1a98882ce48fad6ee2e2e227700630a
parentVersion bump to resolve insecure tempfile usage #101773. (diff)
downloadgentoo-2-47b7bb8d8c4c6776170a9424c9f55632a85e2986.tar.gz
gentoo-2-47b7bb8d8c4c6776170a9424c9f55632a85e2986.tar.bz2
gentoo-2-47b7bb8d8c4c6776170a9424c9f55632a85e2986.zip
cp -a -> cp -pPR #103487
(Portage version: 2.0.51.22-r2)
-rw-r--r--dev-games/gtkradiant/gtkradiant-1.5.0_pre20041205.ebuild4
-rw-r--r--dev-games/gtkradiant/gtkradiant-1.5.0_pre20050626.ebuild4
-rw-r--r--dev-lang/ezm3/ezm3-1.2.ebuild4
-rw-r--r--dev-libs/openssl/openssl-0.9.8.ebuild4
4 files changed, 8 insertions, 8 deletions
diff --git a/dev-games/gtkradiant/gtkradiant-1.5.0_pre20041205.ebuild b/dev-games/gtkradiant/gtkradiant-1.5.0_pre20041205.ebuild
index 26f645d9494d..02f835d38509 100644
--- a/dev-games/gtkradiant/gtkradiant-1.5.0_pre20041205.ebuild
+++ b/dev-games/gtkradiant/gtkradiant-1.5.0_pre20041205.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/gtkradiant/gtkradiant-1.5.0_pre20041205.ebuild,v 1.3 2005/03/20 19:34:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/gtkradiant/gtkradiant-1.5.0_pre20041205.ebuild,v 1.4 2005/08/24 00:22:23 vapier Exp $
inherit eutils games rpm
@@ -33,7 +33,7 @@ src_install() {
local dir="${GAMES_PREFIX_OPT}/${PN}"
dodir "${dir}"
- cp -a * "${D}/${dir}/"
+ cp -pPR * "${D}/${dir}/"
games_make_wrapper q3map2 ./q3map2.x86 "${dir}"
games_make_wrapper radiant ./radiant.x86 "${dir}"
diff --git a/dev-games/gtkradiant/gtkradiant-1.5.0_pre20050626.ebuild b/dev-games/gtkradiant/gtkradiant-1.5.0_pre20050626.ebuild
index 794babc7a0e8..f4cd39c4ef4d 100644
--- a/dev-games/gtkradiant/gtkradiant-1.5.0_pre20050626.ebuild
+++ b/dev-games/gtkradiant/gtkradiant-1.5.0_pre20050626.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/gtkradiant/gtkradiant-1.5.0_pre20050626.ebuild,v 1.1 2005/08/04 04:39:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/gtkradiant/gtkradiant-1.5.0_pre20050626.ebuild,v 1.2 2005/08/24 00:22:23 vapier Exp $
inherit eutils games rpm
@@ -33,7 +33,7 @@ src_install() {
local dir="${GAMES_PREFIX_OPT}/${PN}"
dodir "${dir}"
- cp -a * "${D}/${dir}/"
+ cp -pPR * "${D}/${dir}/"
games_make_wrapper q3map2 ./q3map2.x86 "${dir}"
games_make_wrapper radiant ./radiant.x86 "${dir}"
diff --git a/dev-lang/ezm3/ezm3-1.2.ebuild b/dev-lang/ezm3/ezm3-1.2.ebuild
index 0b742673c991..e0804b92164d 100644
--- a/dev-lang/ezm3/ezm3-1.2.ebuild
+++ b/dev-lang/ezm3/ezm3-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ezm3/ezm3-1.2.ebuild,v 1.3 2005/07/14 20:59:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ezm3/ezm3-1.2.ebuild,v 1.4 2005/08/24 00:22:51 vapier Exp $
inherit eutils
@@ -70,6 +70,6 @@ src_compile() {
src_install() {
cd binaries/$(ezm3target)
- cp -a usr ${D}/ || die
+ cp -pPR usr ${D}/ || die
rm -rf ${D}/usr/man
}
diff --git a/dev-libs/openssl/openssl-0.9.8.ebuild b/dev-libs/openssl/openssl-0.9.8.ebuild
index 09d26c446cc3..4281fa83f390 100644
--- a/dev-libs/openssl/openssl-0.9.8.ebuild
+++ b/dev-libs/openssl/openssl-0.9.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.8.ebuild,v 1.8 2005/08/18 00:13:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.8.ebuild,v 1.9 2005/08/24 00:23:17 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -147,7 +147,7 @@ src_install() {
pkg_preinst() {
if [[ -e ${ROOT}/usr/$(get_libdir)/libcrypto.so.0.9.7 ]] ; then
- cp -a "${ROOT}"/usr/$(get_libdir)/lib{crypto,ssl}.so.0.9.7 "${IMAGE}"/usr/$(get_libdir)/
+ cp -pPR "${ROOT}"/usr/$(get_libdir)/lib{crypto,ssl}.so.0.9.7 "${IMAGE}"/usr/$(get_libdir)/
fi
}