summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-01-20 06:18:47 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-01-20 06:18:47 +0000
commit4a0b4433ca6fd295b2fb4ca56bc7e917f7ebf9e4 (patch)
tree1e9d1c05b4fdc097daab2a6783d017fad367ffc4
parentVersion bump. Remove old. (diff)
downloadgentoo-2-4a0b4433ca6fd295b2fb4ca56bc7e917f7ebf9e4.tar.gz
gentoo-2-4a0b4433ca6fd295b2fb4ca56bc7e917f7ebf9e4.tar.bz2
gentoo-2-4a0b4433ca6fd295b2fb4ca56bc7e917f7ebf9e4.zip
jsonpatch-0.10 needed because glanceclient is stupid
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
-rw-r--r--dev-python/jsonpatch/ChangeLog8
-rw-r--r--dev-python/jsonpatch/jsonpatch-0.10.ebuild21
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-python/jsonpatch/ChangeLog b/dev-python/jsonpatch/ChangeLog
index 773c088d9751..f01ec8234e5f 100644
--- a/dev-python/jsonpatch/ChangeLog
+++ b/dev-python/jsonpatch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/jsonpatch
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpatch/ChangeLog,v 1.2 2013/01/17 19:23:48 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpatch/ChangeLog,v 1.3 2013/01/20 06:18:47 prometheanfire Exp $
+
+*jsonpatch-0.10 (20 Jan 2013)
+
+ 20 Jan 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +jsonpatch-0.10.ebuild:
+ jsonpatch-0.10 needed because glanceclient is stupid
17 Jan 2013; Matthew Thode <prometheanfire@gentoo.org> jsonpatch-0.12.ebuild:
update for [${PYTHON_USEDEP}]
diff --git a/dev-python/jsonpatch/jsonpatch-0.10.ebuild b/dev-python/jsonpatch/jsonpatch-0.10.ebuild
new file mode 100644
index 000000000000..0c75241e76c1
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-0.10.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpatch/jsonpatch-0.10.ebuild,v 1.1 2013/01/20 06:18:47 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches according to
+http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jsonpointer[${PYTHON_USEDEP}]"