summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-04-08 03:30:27 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-04-08 03:30:27 +0000
commit4a5b447986304d15e4283ad8d0e7ad30ccfd3712 (patch)
treec21df21bb7923c3cf82cdec69fa392d6deb46990
parentRemoved mask for vim-6.1-r1 since vim-6.1-r2 doesn't contain sandbox fix, bec... (diff)
downloadgentoo-2-4a5b447986304d15e4283ad8d0e7ad30ccfd3712.tar.gz
gentoo-2-4a5b447986304d15e4283ad8d0e7ad30ccfd3712.tar.bz2
gentoo-2-4a5b447986304d15e4283ad8d0e7ad30ccfd3712.zip
Added perl modules needed for media-sound/rip.
CDDB_get gets the CDDB info for an audio cd; MP3-Info is an interface to mp3 tag info.
-rw-r--r--dev-perl/CDDB_get/CDDB_get-1.66.ebuild28
-rw-r--r--dev-perl/CDDB_get/CDDB_get-2.10.ebuild28
-rw-r--r--dev-perl/CDDB_get/ChangeLog13
-rw-r--r--dev-perl/CDDB_get/files/digest-CDDB_get-1.661
-rw-r--r--dev-perl/CDDB_get/files/digest-CDDB_get-2.101
-rw-r--r--dev-perl/MP3-Info/ChangeLog13
-rw-r--r--dev-perl/MP3-Info/MP3-Info-0.91.ebuild28
-rw-r--r--dev-perl/MP3-Info/MP3-Info-1.01.ebuild28
-rw-r--r--dev-perl/MP3-Info/files/digest-MP3-Info-0.911
-rw-r--r--dev-perl/MP3-Info/files/digest-MP3-Info-1.011
10 files changed, 142 insertions, 0 deletions
diff --git a/dev-perl/CDDB_get/CDDB_get-1.66.ebuild b/dev-perl/CDDB_get/CDDB_get-1.66.ebuild
new file mode 100644
index 000000000000..fbbf036256e5
--- /dev/null
+++ b/dev-perl/CDDB_get/CDDB_get-1.66.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: George Shapovalov <georges@its.caltech.edu>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.4 2002/03/12 16:05:09 tod Exp
+
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Read the CDDB entry for an audio CD in your drive"
+SRC_URI="http://armin.emx.at/cddb/${P}.tar.gz"
+HOMEPAGE="http://armin.emx.at/cddb/"
+
+DEPEND=""
+RDEPEND="sys-devel/perl"
+
+
+src_compile() {
+ perl Makefile.PL && make || die
+}
+
+src_install () {
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ install || die
+ # Install documentation.
+ dodoc Changes Copying README
+}
diff --git a/dev-perl/CDDB_get/CDDB_get-2.10.ebuild b/dev-perl/CDDB_get/CDDB_get-2.10.ebuild
new file mode 100644
index 000000000000..fbbf036256e5
--- /dev/null
+++ b/dev-perl/CDDB_get/CDDB_get-2.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: George Shapovalov <georges@its.caltech.edu>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.4 2002/03/12 16:05:09 tod Exp
+
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Read the CDDB entry for an audio CD in your drive"
+SRC_URI="http://armin.emx.at/cddb/${P}.tar.gz"
+HOMEPAGE="http://armin.emx.at/cddb/"
+
+DEPEND=""
+RDEPEND="sys-devel/perl"
+
+
+src_compile() {
+ perl Makefile.PL && make || die
+}
+
+src_install () {
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ install || die
+ # Install documentation.
+ dodoc Changes Copying README
+}
diff --git a/dev-perl/CDDB_get/ChangeLog b/dev-perl/CDDB_get/ChangeLog
new file mode 100644
index 000000000000..86a85b404b9d
--- /dev/null
+++ b/dev-perl/CDDB_get/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-perl/CDDB_get
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/CDDB_get/ChangeLog,v 1.1 2002/04/08 03:30:27 george Exp $
+
+*CDDB_get-1.66,2.10 (7 Apr 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/dev-perl/CDDB_get/files/digest-CDDB_get-1.66 b/dev-perl/CDDB_get/files/digest-CDDB_get-1.66
new file mode 100644
index 000000000000..efb01f03aaca
--- /dev/null
+++ b/dev-perl/CDDB_get/files/digest-CDDB_get-1.66
@@ -0,0 +1 @@
+MD5 1233239ee80d7a317588e12afc40d5e4 CDDB_get-1.66.tar.gz 15828
diff --git a/dev-perl/CDDB_get/files/digest-CDDB_get-2.10 b/dev-perl/CDDB_get/files/digest-CDDB_get-2.10
new file mode 100644
index 000000000000..1c13dace2a0d
--- /dev/null
+++ b/dev-perl/CDDB_get/files/digest-CDDB_get-2.10
@@ -0,0 +1 @@
+MD5 45a879d84c66e772933fedb83ceedf4c CDDB_get-2.10.tar.gz 18083
diff --git a/dev-perl/MP3-Info/ChangeLog b/dev-perl/MP3-Info/ChangeLog
new file mode 100644
index 000000000000..9471d1ad42a9
--- /dev/null
+++ b/dev-perl/MP3-Info/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-perl/MP3-Info
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/MP3-Info/ChangeLog,v 1.1 2002/04/08 03:30:27 george Exp $
+
+*MP3-Info-0.91, 1.01 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/dev-perl/MP3-Info/MP3-Info-0.91.ebuild b/dev-perl/MP3-Info/MP3-Info-0.91.ebuild
new file mode 100644
index 000000000000..ac8293457ed0
--- /dev/null
+++ b/dev-perl/MP3-Info/MP3-Info-0.91.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: George Shapovalov <georges@its.caltech.edu>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.4 2002/03/12 16:05:09 tod Exp
+
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A Perl module to manipulate/fetch info from MP3 files"
+SRC_URI="http://prdownloads.sourceforge.net/mp3-info/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/mp3-info/"
+
+DEPEND=""
+RDEPEND="sys-devel/perl"
+
+
+src_compile() {
+ perl Makefile.PL && make || die
+}
+
+src_install () {
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ install || die
+ # Install documentation.
+ dodoc README
+}
diff --git a/dev-perl/MP3-Info/MP3-Info-1.01.ebuild b/dev-perl/MP3-Info/MP3-Info-1.01.ebuild
new file mode 100644
index 000000000000..ac8293457ed0
--- /dev/null
+++ b/dev-perl/MP3-Info/MP3-Info-1.01.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: George Shapovalov <georges@its.caltech.edu>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.4 2002/03/12 16:05:09 tod Exp
+
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A Perl module to manipulate/fetch info from MP3 files"
+SRC_URI="http://prdownloads.sourceforge.net/mp3-info/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/mp3-info/"
+
+DEPEND=""
+RDEPEND="sys-devel/perl"
+
+
+src_compile() {
+ perl Makefile.PL && make || die
+}
+
+src_install () {
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ install || die
+ # Install documentation.
+ dodoc README
+}
diff --git a/dev-perl/MP3-Info/files/digest-MP3-Info-0.91 b/dev-perl/MP3-Info/files/digest-MP3-Info-0.91
new file mode 100644
index 000000000000..a65e7dde62f4
--- /dev/null
+++ b/dev-perl/MP3-Info/files/digest-MP3-Info-0.91
@@ -0,0 +1 @@
+MD5 985e9be5234ffa0018d0fc42139b958d MP3-Info-0.91.tar.gz 50987
diff --git a/dev-perl/MP3-Info/files/digest-MP3-Info-1.01 b/dev-perl/MP3-Info/files/digest-MP3-Info-1.01
new file mode 100644
index 000000000000..59eb638efb49
--- /dev/null
+++ b/dev-perl/MP3-Info/files/digest-MP3-Info-1.01
@@ -0,0 +1 @@
+MD5 168abf312bc9fe52b6d9bd5af510fe7b MP3-Info-1.01.tar.gz 51394