summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2004-04-02 22:42:38 +0000
committerJoshua Brindle <method@gentoo.org>2004-04-02 22:42:38 +0000
commit4bf695b5aea3758ede2b17bf662536f3c09d6821 (patch)
tree2ce86d4181f9447e1ebf914fcdf35ef2a3be2c0e
parentAdd MPICH_CONFIGURE_OPTS variable for customization (#38207). (Manifest recom... (diff)
downloadgentoo-2-4bf695b5aea3758ede2b17bf662536f3c09d6821.tar.gz
gentoo-2-4bf695b5aea3758ede2b17bf662536f3c09d6821.tar.bz2
gentoo-2-4bf695b5aea3758ede2b17bf662536f3c09d6821.zip
added conf file and vars to init file
-rw-r--r--media-sound/audio-entropyd/ChangeLog6
-rw-r--r--media-sound/audio-entropyd/audio-entropyd-0.0.6.ebuild5
-rw-r--r--media-sound/audio-entropyd/files/audio-entropyd.conf13
-rw-r--r--media-sound/audio-entropyd/files/audio-entropyd.init4
4 files changed, 25 insertions, 3 deletions
diff --git a/media-sound/audio-entropyd/ChangeLog b/media-sound/audio-entropyd/ChangeLog
index 5ef85af4105d..4f4d157d99b6 100644
--- a/media-sound/audio-entropyd/ChangeLog
+++ b/media-sound/audio-entropyd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/audio-entropyd
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/ChangeLog,v 1.3 2004/03/31 23:01:46 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/ChangeLog,v 1.4 2004/04/02 22:42:38 method Exp $
+
+ 02 Apr 2004; Joshua Brindle <method@gentoo.org> audio-entropyd-0.0.6.ebuild,
+ files/audio-entropyd.init:
+ fixed up the init file and conf.d to read more variables
01 Apr 2004; David Holm <dholm@gentoo.org> audio-entropyd-0.0.6.ebuild:
Added to ~ppc.
diff --git a/media-sound/audio-entropyd/audio-entropyd-0.0.6.ebuild b/media-sound/audio-entropyd/audio-entropyd-0.0.6.ebuild
index fa2ca9ae668d..709d39a3d170 100644
--- a/media-sound/audio-entropyd/audio-entropyd-0.0.6.ebuild
+++ b/media-sound/audio-entropyd/audio-entropyd-0.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/audio-entropyd-0.0.6.ebuild,v 1.3 2004/03/31 23:01:46 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/audio-entropyd-0.0.6.ebuild,v 1.4 2004/04/02 22:42:38 method Exp $
DESCRIPTION="Audio-entropyd generates entropy-data for the /dev/random device."
HOMEPAGE="http://www.vanheusden.com/aed/"
@@ -34,4 +34,7 @@ src_install() {
insinto /etc/init.d
insopts -m0755
newins ${FILESDIR}/${PN}.init ${PN}
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/${PN}.conf ${PN}
}
diff --git a/media-sound/audio-entropyd/files/audio-entropyd.conf b/media-sound/audio-entropyd/files/audio-entropyd.conf
new file mode 100644
index 000000000000..dcd7993b7ba7
--- /dev/null
+++ b/media-sound/audio-entropyd/files/audio-entropyd.conf
@@ -0,0 +1,13 @@
+# /etc/conf.d/audio-entropyd:
+# $Header:
+
+# The acceptable values are DEVICE, READSIZE and SAMPLERATE
+# These defaults give the optimum entropy
+
+#DEVICE="/dev/dsp"
+
+#READSIZE *must* be a power of 2
+READSIZE="65536"
+
+#SAMPLERATE must be a valid sampling rate of your audio source
+SAMPLERATE="44050"
diff --git a/media-sound/audio-entropyd/files/audio-entropyd.init b/media-sound/audio-entropyd/files/audio-entropyd.init
index dacf5debb37e..f861f699be41 100644
--- a/media-sound/audio-entropyd/files/audio-entropyd.init
+++ b/media-sound/audio-entropyd/files/audio-entropyd.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/files/audio-entropyd.init,v 1.2 2004/03/31 10:14:35 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audio-entropyd/files/audio-entropyd.init,v 1.3 2004/04/02 22:42:38 method Exp $
depend() {
need modules
@@ -11,6 +11,8 @@ depend() {
start() {
local params=""
[ -n "$DEVICE" ] && params="$params -d $DEVICE"
+ [ -n "$READSIZE" ] && params="$params -r $READSIZE"
+ [ -n "$SAMPLERATE" ] && params="$params -N $SAMPLERATE"
ebegin "Starting audio entropy gathering daemon"
start-stop-daemon --start --quiet --exec /usr/sbin/audio-entropyd -- ${params}