summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-02-24 05:58:37 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-02-24 05:58:37 +0000
commit4bfe31f9a64d9c915279579166194b46a03e0473 (patch)
treed44b59189afd0422f3d9c5bf84872965cf35be73
parentUpstream uses --rootprefix= now for networkdir= so stop overriding it. Overri... (diff)
downloadgentoo-2-4bfe31f9a64d9c915279579166194b46a03e0473.tar.gz
gentoo-2-4bfe31f9a64d9c915279579166194b46a03e0473.tar.bz2
gentoo-2-4bfe31f9a64d9c915279579166194b46a03e0473.zip
Bump #487804 #450658
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/ws4py/ChangeLog9
-rw-r--r--dev-python/ws4py/ws4py-0.3.2.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-python/ws4py/ChangeLog b/dev-python/ws4py/ChangeLog
index 415b701fb3c6..d32664f27c29 100644
--- a/dev-python/ws4py/ChangeLog
+++ b/dev-python/ws4py/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/ws4py
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ChangeLog,v 1.10 2013/07/19 07:56:00 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ChangeLog,v 1.11 2014/02/24 05:58:37 patrick Exp $
+
+*ws4py-0.3.2 (24 Feb 2014)
+
+ 24 Feb 2014; Patrick Lauer <patrick@gentoo.org> +ws4py-0.3.2.ebuild:
+ Bump #487804 #450658
19 Jul 2013; Michał Górny <mgorny@gentoo.org> ws4py-0.2.3.ebuild,
ws4py-0.2.4-r1.ebuild, ws4py-0.2.4.ebuild:
diff --git a/dev-python/ws4py/ws4py-0.3.2.ebuild b/dev-python/ws4py/ws4py-0.3.2.ebuild
new file mode 100644
index 000000000000..386bce4195ee
--- /dev/null
+++ b/dev-python/ws4py/ws4py-0.3.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ws4py-0.3.2.ebuild,v 1.1 2014/02/24 05:58:37 patrick Exp $
+
+# We could depend on dev-python/cherrypy when USE=server, but
+# that is an optional component ...
+# Same for www-servers/tornado and USE=client ...
+
+EAPI="5"
+PYTHON_COMPAT=( python2_{6,7} )
+PYTHON_REQ_USE="threads?"
+
+inherit distutils-r1
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Lawouach/WebSocket-for-Python.git"
+ inherit git-2
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="WebSocket support for Python"
+HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="+client +server test +threads"
+
+RDEPEND=""
+DEPEND="test? (
+ ${RDEPEND}
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ >=dev-python/cherrypy-3.2.0[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ use client || rm -rf "${ED}$(python_get_sitedir)"/ws4py/client
+ use server || rm -rf "${ED}$(python_get_sitedir)"/ws4py/server
+}